Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Cisco 1841 Ethernet WAN and BGP

I need to install a cisco 1841 router on an MPLS line running BGP with WAN interface presented as Ethernet 2/10Mb

I have configured many serial WAN links using BGP but never ethernet.  Has anyone an example config I can use as a guide?

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Re: Cisco 1841 Ethernet WAN and BGP

bluesheep11 wrote:

Thanks Jon

Do I need to make the nieghbour update source fa0/1?

Thanks

Mike

Mike

No. You only need to specify update-source if you want to use a different interface for peering than the actual physical interface and you are using the physical interface.

Jon

12 REPLIES
Hall of Fame Super Blue

Re: Cisco 1841 Ethernet WAN and BGP

bluesheep11 wrote:

I need to install a cisco 1841 router on an MPLS line running BGP with WAN interface presented as Ethernet 2/10Mb

I have configured many serial WAN links using BGP but never ethernet.  Has anyone an example config I can use as a guide?

Thanks

Mike

Not sure what you mean by 2/10Mb ? Do you mean you have a fastethernet and want to limit traffic to 20Mbps ? In which case you would need shaping.

Also are you looking for BGP config or not ?

There is nothing special about using ethernet as a WAN link, you would configure it as you would a serial link although obviously you don't need to specify the encapsulation.

Can you clarify the speed thing and exactly what it is config wise you are looking for ?

Jon

New Member

Re: Cisco 1841 Ethernet WAN and BGP

Hi Jon

The circuit has a 10Mb access speed but is limited to 2Mb.

With a serial connection I would create the serial interface, create a sub interface and a loopback.  Configure BGP to update the loopback and put the ip unnumbered loopback 0 command against the sub interface.

How would this work when using an ethernet connection rather than a serial interface?

I can do the BGP config, just not sure how it all ties together.

Thanks

Mike

Hall of Fame Super Blue

Re: Cisco 1841 Ethernet WAN and BGP

bluesheep11 wrote:

Hi Jon

The circuit has a 10Mb access speed but is limited to 2Mb.

With a serial connection I would create the serial interface, create a sub interface and a loopback.  Configure BGP to update the loopback and put the ip unnumbered loopback 0 command against the sub interface.

How would this work when using an ethernet connection rather than a serial interface?

I can do the BGP config, just not sure how it all ties together.

Thanks

Mike

Mike

You will need to use shaping on the ethernet interface. Your provider will undoubtedly be using shaping/policing at their end but you should also do it on yours.

With ethernet you can configure the BGP directly onto the ethernet interface and not bother with a loopback. That's what i did at the last place i worked when we were presented with ethernet by our MPLS provider. Works fine. If you want to use loopbacks for BGP peering you can but then you would need a static route to get to the providers loopback via their ethernet interface and they would need one to get to yours. It's a lot easier just using the ethernet IP address itself.

Note. i'm assuming here that you are configuring standard BGP only ie. you are not configuring MP-BGP for MPLS where a loopback is often needed.

Jon

New Member

Re: Cisco 1841 Ethernet WAN and BGP

Hi Jon

I have done the following:

Created FA0/0 with LAN address - 192.168.x.x

Created FA0/1 with no IP address

Created FA0/1.101 with dot1q encap and ip address 10.172.x.x - my loopback address

Set up the bgp peers etc

Created a static route for the bgp peer address to go via FA0/1.101

However I still get no active tcp connection when running "show ip bgp neig"

Am i missing something?

CHeers

Mike

Hall of Fame Super Blue

Re: Cisco 1841 Ethernet WAN and BGP

bluesheep11 wrote:

Hi Jon

I have done the following:

Created FA0/0 with LAN address - 192.168.x.x

Created FA0/1 with no IP address

Created FA0/1.101 with dot1q encap and ip address 10.172.x.x - my loopback address

Set up the bgp peers etc

Created a static route for the bgp peer address to go via FA0/1.101

However I still get no active tcp connection when running "show ip bgp neig"

Am i missing something?

CHeers

Mike

Mike

Do you mean you have used "ip unnumbered" on the subinterface ?

Not sure what you mean by static route, can you post example ?

Have you tried debugging bgp eg. "debug ip bgp" to see what is happening ?

Finally is there a paticular reason you want to use a loopback ?

Jon

New Member

Re: Cisco 1841 Ethernet WAN and BGP

Hi John

Here is what i have:

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$UCcS$WiB4G6XA.U1sajC.8Rcfs/

enable password!

no aaa new-model

ip cef

!

!

!

!

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.50.200 255.255.255.0

speed auto

half-duplex

no mop enabled

!

interface FastEthernet0/1

bandwidth 2048

no ip address

duplex auto

speed auto

!

!

interface FastEthernet0/1.101

encapsulation dot1Q 20

ip address 10.172.10.202 255.255.255.252

!

router bgp 64521

no synchronization

bgp log-neighbor-changes

network 192.168.50.0

neighbor 81.144.23.1 remote-as 2856

neighbor 81.144.23.1 ebgp-multihop 3

neighbor 81.144.23.1 update-source FastEthernet0/1.101

no auto-summary

!

ip forward-protocol nd

ip route 81.144.23.1 255.255.255.255 FastEthernet0/1.101

!

!

ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

!

line con 0

line aux 0

line vty 0 4

password login

!

scheduler allocate 20000 1000

end

Hall of Fame Super Blue

Re: Cisco 1841 Ethernet WAN and BGP

Mike

I'm confused now

Can't see a loopback in that config but more importantly -

ethernet is not a point to point setup like serial. You have ebgp-multihop 3 which suggests that the neighbor address is not directly connected ? By using that static route -

ip route 81.144.23.1 255.255.255.255 FastEthernet0/1.101

you are simply telling your router to arp out for 81.144.23.1 which won't work because even if it was connected how would it route it back, it is on a different network.  Lets step back a bit -

1) if the connection is ethernet what is the provider IP address of their ethernet interface ? They should have provided you with the IP of their ethernet interface and then given you an IP to use on your ethernet interface - did this not happen.

2) Why do you want to use a subinterface rather than simply apply the IP to the fa0/1 interface ?

Is 81.144.23.1 the address of the ISP ethernet interface  ? or is the ISP address a 10.172.10.x address ?

Jon

New Member

Re: Cisco 1841 Ethernet WAN and BGP

Hi John

OK I think I know where I am going wrong.

The ethernet interface on the PE router is 10.172.10.201

I am used to working with serial hense why I used a sub interface, I removed the loopback based on your previous suggestion.

81.144.23.1 is the address of the peer BGP router.

Does that make sense?

Cheers

Mike

Hall of Fame Super Blue

Re: Cisco 1841 Ethernet WAN and BGP

Mike

Okay, that makes more sense.

Make these changes to your config -

int fa0/1

ip address 10.172.10.202 255.255.255.252


router bgp 64521

no neighbor 81.144.23.1 update-source fa0/1.101


ip route 81.144.23.1 255.255.255.255 10.172.10.201

If you wanted to use a loopback then you could but then the ISP would need to add a route on their router to get your loopback via fa0/1 interface on your router. So you may want to do that later but lets just test this.

Jon

New Member

Re: Cisco 1841 Ethernet WAN and BGP

Thanks Jon

Do I need to make the nieghbour update source fa0/1?

Thanks

Mike

Hall of Fame Super Blue

Re: Cisco 1841 Ethernet WAN and BGP

bluesheep11 wrote:

Thanks Jon

Do I need to make the nieghbour update source fa0/1?

Thanks

Mike

Mike

No. You only need to specify update-source if you want to use a different interface for peering than the actual physical interface and you are using the physical interface.

Jon

New Member

Re: Cisco 1841 Ethernet WAN and BGP

OK Thanks.

Thanks for your help.

Cheers

Mike

1755
Views
0
Helpful
12
Replies
CreatePlease to create content