Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 1841 Help

I need some help getting my Cisco 1841 set up correctly.

My ISP is weird, so it is making my head hurt. I have 5 static IPs but the ISP gives my wan address as a DHCP address. So i need one FastEthernet port to act as my Gateway to my ISP and be configured for DHCP as well as set the default gateway. Then i need the second FastEthernet port to act as my internal Default Gateway. This will be hooked up to a Switch that will act as my "External Switch" In the external switch i will then plug devices and give them my External Static IPs.

Below is the configuration that i currently have. With this configuration i can plug my ISP into Fa0/0 and then from the router ping the internet (8.8.8.8) successfully. I then tried to hook my computer up to Fa0/1 with 64.135.211.162 as its static IP and i was able to ping the default gateway of 64.135.211.161 (the address of fa0/1), but i cannot, from my laptop, ping the internet. Im missing something here. Can you guys help?

Thanks.


Current configuration : 2570 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ELG-FoxValleRouter
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$TurQ$nZGzoAk2lJnmccovkVdpe0
enable password lucent1
!
no aaa new-model
no ip routing
no ip cef
!
!
!
!
!
crypto pki trustpoint TP-self-signed-1109424009
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1109424009
revocation-check none
rsakeypair TP-self-signed-1109424009
!
!
crypto pki certificate chain TP-self-signed-1109424009
certificate self-signed 01
  3082024A 308201B3 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31313039 34323430 3039301E 170D3131 31323137 31373535
  34345A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 31303934
  32343030 3930819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100E071 019D5020 5046A64A DAA22C55 AFDEA1A3 EB4C7DCD 641F201A 02C195FA
  9DF1F64E 55DD16B2 70F05727 99B92948 86EFEEB7 020E3974 9706F628 790D50A1
  F600525F FB445D7A 16B78004 23E406AA CDF48193 538ED8B1 32331D0C 3F6F4723
  51E51120 58C20CFC 125CA3C3 A608BF16 165D06D3 551AD0AB 683E6A6D 45164FCB
  08970203 010001A3 72307030 0F060355 1D130101 FF040530 030101FF 301D0603
  551D1104 16301482 12454C47 2D466F78 56616C6C 65526F75 74657230 1F060355
  1D230418 30168014 9694A112 8BA58EAF 1A6DCC8C 15D46EE8 6FC77709 301D0603
  551D0E04 16041496 94A1128B A58EAF1A 6DCC8C15 D46EE86F C7770930 0D06092A
  864886F7 0D010104 05000381 8100280A 5D4633A3 EECACE27 8ED18188 BBDB9B93
  2436DB2D C53C303E EAF9EFD7 50BC83BB 6847F748 D6A424D2 951734B1 81B26EE6
  101DD01A 9F38AA1C 0ABED47C 37AD24D0 4FC6F98F 45AE7A60 DE74F9EB 18B52B6A
  A346B4AF B090E3AC AD0A50C1 96E77C00 DC1A5271 16C0F7EA 6718A7AB FCF3EB4B
  A69DFA40 EA286AD0 E901A5F1 BF2A
  quit
!
!
!
!
interface FastEthernet0/0
ip address dhcp
no ip route-cache
duplex auto
speed auto
no cdp enable
!
interface FastEthernet0/1
ip address 64.135.211.161 255.255.255.248
no ip route-cache
speed auto
half-duplex
no cdp enable
no mop enabled
!
interface Serial0/0/0
no ip address
no ip route-cache
shutdown
!
ip forward-protocol nd
!
!
ip http server
ip http secure-server
!
!
!
!
control-plane
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
password bandwidth
login
!
scheduler allocate 20000 1000
no process cpu extended
no process cpu autoprofile hog
end

ELG-FoxValleRouter#

6 REPLIES

Cisco 1841 Help

Hello Patrick,

Please add the following command and give it a try

ip route 0.0.0.0 0.0.0.0 xx.xx.xx.xx ) Ip address of the ISP device

Please rate helpful posts

Regards,

Julio

Looking for some Networking Assistance? Contact me directly at jcarvaja@laguiadelnetworking.com I will fix your problem ASAP. Cheers, Julio Carvajal Segura http://laguiadelnetworking.com
New Member

Cisco 1841 Help

To add onto what jcarvaja is saying, you can also use the following command:

ip route 0.0.0.0 0.0.0.0 fa0/0

In order to get out to the Internet, your router needs to know where to send the packets to.  What these commands are saying is this:

ip route = I want to route traffic FROM

0.0.0.0 0.0.0.0 = source subnet and subnet mask

xx.xx.xx.xx = destination to send packets to

OR fa0/0 = interface to send packets out of

I hope this helps solve your issue and helps you understand routing a little better.  If you have any more questions hit me up.

New Member

Cisco 1841 Help

Thanks guys. I swear I Had that in there already defining the route via the interface and it wasn't working. I will have to try it again and report back. For some reason it's not I'm this configuration.

Purple

Cisco 1841 Help

Hi,

1)

no ip routing
no ip cef

You have ip routing disabled so it won't work even if you configure a static route and you have CEFdisabled so all traffic will be process switched which means awful performance.

So first enable ip routing and CEF  with the following commands:

ip routing

ip cef

2) configure your static route but not to the interface, never configure a static route to point to a multipoint interface because even if it works it is also bad performance wise and if the other side is not using proxy-arp it will never work.

Regards.

Alain

Don't forget to rate helpful posts.
New Member

Cisco 1841 Help

Ok. I'll do that. But how do I define a default route out to my ISP which is DHCP? This is why I set the static route to the interface.

Purple

Cisco 1841 Help

Hi,

if the ISP is DHCP then no need for a default route as it will be given by DHCP.

Reagrds.

Alain

Don't forget to rate helpful posts.
475
Views
0
Helpful
6
Replies