Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 1841 support BGP

Hi,

I have cisco 1841 router in my office.

In that router we configured MPLS bgp with two different service provider.

Config:

router bgp 58001

no synchronization

bgp log-neighbor-changes

network 10.30.120.0 mask 255.255.254.0

neighbor 10.237.68.15 remote-as 65600

neighbor 10.237.68.15 description ***TULIP WAN***

neighbor 10.237.68.15 soft-reconfiguration inbound

neighbor 192.168.12.36 remote-as 9725

neighbor 192.168.12.36 description ***BSNL WAN***

neighbor 192.168.12.36 soft-reconfiguration inbound

no auto-summary

We can't able to use the different service provider at the sametime.

My question:

Cisco 1841 is support two different AS ???

12 REPLIES
Hall of Fame Super Silver

Re: Cisco 1841 support BGP

the 1841 should be capable of supporting 2 ISP with 2 AS numbers, depending on how many prefixes are advertised by the peers (and depending on how much memory is present in them).

I wonder if your issue is related to the AS number of the peer shown in your config.

HTH

Rick

Sent from Cisco Technical Support iPhone App

New Member

Cisco 1841 support BGP

In that router we are not configured any prefixes.

Our 10.30.110.0 advertised to both Tulip and bsnl.

Both link is not working at the same time.After i shutdown any one of the port it is working.

We want all traffic should be working with Tulip as primary and if any problem in that tulip it should be take the BSNL link.

Can u tell me the solution??

Hall of Fame Super Silver

Cisco 1841 support BGP

We do not have enough information to know what the problem is, much less to be able to tell you the solution. A good starting place would be to post the configuration of the router.

HTH

Rick

New Member

Cisco 1841 support BGP

Building configuration...

Current configuration : 4116 bytes

!

version 12.4

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

!

boot-start-marker

boot system flash c1841-advsecurityk9-mz.124-24.T4.bin

boot-end-marker

!

logging message-counter syslog

logging buffered 51200 notifications

!

no aaa new-model

clock timezone India 5 30

dot11 syslog

ip source-route

--More--      

!

!

!

ip cef

!

multilink bundle-name authenticated

!

isdn switch-type basic-net3

!

crypto pki trustpoint TP-self-signed-2080122312

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-2080122312

revocation-check none

rsakeypair TP-self-signed-2080122312

archive

log config

  hidekeys

!

--More--      

!

!

!

!

!

!

interface FastEthernet0/0

description ***** LAN *****$ETH-LAN$

ip address 10.30.120.100 255.255.254.0

duplex auto

speed auto

keepalive 1000

!

interface FastEthernet0/1

description $$TULIP-WAN$$

bandwidth 512

ip address 10.237.68.14 255.255.255.252

ip accounting output-packets

duplex auto

speed auto

!

interface BRI0/0/0

no ip address

encapsulation hdlc

shutdown

isdn switch-type basic-net3

isdn point-to-point-setup

!

interface Serial0/1/0

description #### BSNL WAN  ####

ip address 192.168.12.35 255.255.255.252

ip accounting output-packets

ip nbar protocol-discovery

ip flow ingress

ip flow egress

ip virtual-reassembly

encapsulation ppp

load-interval 30

no fair-queue

!

router bgp 58001

no synchronization

bgp log-neighbor-changes

network 10.30.120.0 mask 255.255.254.0

neighbor 10.237.68.15 remote-as 65600

neighbor 10.237.68.15 description ***TULIP WAN***

neighbor 10.237.68.15 soft-reconfiguration inbound

neighbor 192.168.12.36 remote-as 9725

neighbor 192.168.12.36 description ***BSNL WAN***

neighbor 192.168.12.36 soft-reconfiguration inbound

no auto-summary

!

ip forward-protocol nd

ip http server

no ip http secure-server

!

snmp-server community startrac RW 55

snmp-server community h0Wd@r3U RW

snmp-server enable traps snmp authentication linkdown linkup

snmp-server enable traps envmon

snmp-server enable traps bgp

snmp-server enable traps config

snmp-server enable traps cpu threshold

snmp-server host 10.10.42.20 h0Wd@r3U

Cisco 1841 support BGP

Hi,

what does it mean "Both link is not working at the same time" exactly?

BGP sessions down?

Or some routing loop?

I\d be careful here - your AS might become a transfer AS for both providers - don't forget you are adverting all prefixes received from on eBGP neighbor to the other neighbor.

So I'd try to use an oytgoing route-map towards both neigbors permitting only the  10.30.110.0 prefix to be advertised.

HTH,

Milan

New Member

Cisco 1841 support BGP

As per ur Instructions i should advertise the 10.30.120.0 to both the neighbor which ISP route they take???

Anyother configuration is needed for this requirement???

Cisco 1841 support BGP

Hi,

you could add to your config for example:

ip prefix-list adv_to_providers seq 5 permit  10.30.120.100/23

!

route-map outging permit 10

match ip add prefix-list adv_to_providers

!

route-map from_tulip permit 10

set local-preference 200

!

router bgp 58001

neighbor 10.237.68.15 route-map from_tulip in

neighbor 10.237.68.15 route-map outgoing out

neighbor 192.168.12.36 route-map outgiong out

This way you would advertise only the 10.30.120.100/23 to both providers.

And the prefixes received from Tulip would be preferred, so you would use Tulip for outgoing traffic.

Are some other sites connected to both providers?

If yes, you might need to tune prefix preference on that sites to prefer Tulip, too.

HTH,

Milan

New Member

Cisco 1841 support BGP

Thanks for ur support.

We are using the Tulip for all users access the application in HO.

BSNL link for using our CCTV camera in that office.

We are configured 10.30.120.120 in the CCTV DVR.

All traffic should working in TULIP expect that 10.30.120.120.

CCTV Traffic should go only for BSNL link.

If any case Tulip Link down,we want allow all  the traffic to BSNL LINK for temporary.

After Tulip link came means traffic should go to Tulip.

The above configuration u given  is enough for this requirement???

Cisco 1841 support BGP

DHINESHKUMAR PALANIAPPAN wrote:

Thanks for ur support.

We are using the Tulip for all users access the application in HO.

BSNL link for using our CCTV camera in that office.

We are configured 10.30.120.120 in the CCTV DVR.

All traffic should working in TULIP expect that 10.30.120.120.

CCTV Traffic should go only for BSNL link.

If any case Tulip Link down,we want allow all  the traffic to BSNL LINK for temporary.

After Tulip link came means traffic should go to Tulip.

The above configuration u given  is enough for this requirement???

Of course it's not enough!

You would probably need to advertise a host prefix  10.30.120.120/32 to achieve that.

And handle incoming/outgoing traffic for this host special way.

IMHO, you should hire a skilled professional to make the configuration fulfilling all your requirements.

This forum can give you hints, but not perform a detailed configuration for you!

BR,

Milan

New Member

Cisco 1841 support BGP

Thanks for ur advice.

Last question

i want the tulip to be a primary route in the time of both link available.

can i give like this for my requirement.

neighbor 10.237.68.15 weight 100.

If i give like this it will take the Tulip route as primary.

Cisco 1841 support BGP

Sure.

It will have similar effect as the local preference increase I used in my example route-map.

BR,

Milan

New Member

Cisco 1841 support BGP

Now in my client end  router 1841 both ISP working.

But i am not able to ping the both WAN  IP through My system.System in HO

But client end both ISP is pinging  through my HO Router.

If i shut any one of the ISP in client end  that another ISP is pinging through my system.

where is the problem??any problem in the client end router.

995
Views
0
Helpful
12
Replies
CreatePlease to create content