Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 1941 ADSL configuration

Dear cisco,

 

We have Cisco 1941 with ADSL card, we need config this device go to internet via by ADSL, after doing the configuration, the ATM is up, dial 1 up, but it not receive IP Address and not connect to the internet, below is my configuration:

 

Building configuration...

Current configuration : 3793 bytes
!
! Last configuration change at 11:33:25 UTC Fri Oct 17 2014
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname EY-SGNAO-RTR1
!
boot-start-marker
boot system flash:c1900-universalk9-mz.SPA.154-1.T.bin
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
crypto pki trustpoint TP-self-signed-3347395915
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3347395915
 revocation-check none
 rsakeypair TP-self-signed-3347395915
!
!
crypto pki certificate chain TP-self-signed-3347395915
 certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33333437 33393539 3135301E 170D3134 31303137 30393136
  35355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 33343733
  39353931 3530819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  81009850 4B3A6B54 0BC343A2 572149B5 EE87C989 879454C6 AB43840C FDE6C864
  460FB5BD 983E5CAC CD34E2E5 3AB8ACFF 1BDDCF6A CA226711 752AA890 321A57D8
  9D4C9100 F0B1C611 1AE47832 DDCBC19C 2E0360D0 8E4384C8 60E23F98 E54D40DF
  25467C5E 080D9C7A 48964958 7B1C1F93 1209C5E0 61EDBB20 29866442 A471EADF
  9C1B0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
  551D2304 18301680 1401EF80 E2900A39 B2DD8A40 87A6BD09 2885F470 BC301D06
  03551D0E 04160414 01EF80E2 900A39B2 DD8A4087 A6BD0928 85F470BC 300D0609
  2A864886 F70D0101 05050003 81810078 5219BB27 D6629803 49FFE254 947C42DB
  9E8F4E1C 0B89EC14 40298F97 8ED77ACA 12C16F72 733052D0 C37043E0 B02E5539
  03BBED84 5D64D3BD B651754B 0B4B29E7 3F552B58 28ED349B 5E054F2B E89DFADE
  3BF82E69 458CF46A CE6475EB 872F5610 DC4749E9 CA2B66E1 06A166EA 64921FAC
  45AD183C 14D2380E 5026B9DC B11858
      quit
license udi pid CISCO1941/K9 sn FGL1750217T
!
!
!
redundancy
!
!
!
!
!
controller VDSL 0/0/0
no cdp run
!
!
!
!
!
!
!
!
!
!
bba-group pppoe global
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 no ip address
 ip tcp adjust-mss 1412
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description "Connected to LAN"
 ip address 10.200.53.98 255.255.255.224
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat inside
 ip virtual-reassembly in
 ip tcp adjust-mss 1412
 duplex auto
 speed auto
!
interface ATM0/0/0
 no ip address
 no atm ilmi-keepalive
!
interface ATM0/0/0.1 point-to-point
 pvc 8/35
  encapsulation aal5snap
  pppoe-client dial-pool-number 1
 !
!
interface Ethernet0/0/0
 no ip address
!
interface Dialer1
 ip address dhcp
 ip mtu 1452
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication pap callin
 ppp pap sent-username xxxxxx password xxxxxx
 ppp ipcp dns request
 no cdp enable
!
ip forward-protocol nd
!
ip http server
ip http secure-server
!
ip nat inside source list 100 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
dialer-list 1 protocol ip permit
dialer-list 2 protocol ip permit
!
!
access-list 100 permit ip any any
access-list 199 permit ip any any
!
control-plane
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 exec-timeout 0 0
 logging synchronous
 login
 transport input all
!
scheduler allocate 20000 1000

 

 

EY-SGNAO-RTR1#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
Embedded-Service-Engine0/0 unassigned      YES NVRAM  administratively down down    
GigabitEthernet0/0         unassigned      YES NVRAM  administratively down down    
GigabitEthernet0/1         10.200.53.98    YES NVRAM  up                    up      
ATM0/0/0                   unassigned      YES NVRAM  up                    up      
ATM0/0/0.1                 unassigned      YES unset  up                    up      
Ethernet0/0/0              unassigned      YES NVRAM  down                  down    
Dialer1                    unassigned      YES DHCP   up                    up      
NVI0                       10.200.53.98    YES unset  up                    up      
Virtual-Access1            unassigned      YES unset  up                    up      
Virtual-Access2            unassigned      YES unset  up                    up    

 

 

 

EY-SGNAO-RTR1#sh int dialer 1
Dialer1 is up, line protocol is up (spoofing)
  Hardware is Unknown
  Internet address will be negotiated using DHCP
  MTU 1500 bytes, BW 56 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Closed, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 1 seconds on reset
  Interface is bound to Vi2
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 00:08:30
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     5 packets input, 538 bytes
     12 packets output, 1830 bytes
Bound to:
Virtual-Access2 is up, line protocol is up
  Hardware is Virtual Access interface
  MTU 1500 bytes, BW 637 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open
  Open: IPCP
  PPPoE vaccess, cloned from Dialer1
  Vaccess status 0x44, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 5 seconds on reset
  Interface is bound to Di1 (Encapsulation PPP)
  Last input 00:00:07, output never, output hang never
  Last clearing of "show interface" counters 00:00:58
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     16 packets input, 707 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     19 packets output, 1952 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions

 

Any one can help me on this

 

Thanks

 

Minh

9 REPLIES

Without knowing who your ISP

Without knowing who your ISP is, it's difficult to be certain, but I would look at your "ip address dhcp" statement on the Dialer1 interface. For most PPPoE connections, the setting should be "ip address negotiated" in order to get the address via IPCP rather than DHCP.

New Member

HI Jody, Even i set ip

HI Jody,

 

Even i set ip address negotiated on Dialer 1, the dialer 1 still not bind any ip address

 

The IPS is located at Viet Nam, they are provide ADSL service

 

Thanks,

 

Minh

Every ISP is a little bit

Every ISP is a little bit different. Without knowing how your specific ISP is implementing the connection, it's difficult to guess what might be going wrong. You might want to try "terminal monitor", "debug ppp authentication" and then "clear pppoe interface ATM0/0/0.1" to see if your authentication is succeeding.

New Member

Looking from the interface

Looking from the interface dialer 1:

 

EY-SGNAO-RTR1#sh int dialer 1
Dialer1 is up, line protocol is up (spoofing)
  Hardware is Unknown
  Internet address will be negotiated using DHCP
  MTU 1500 bytes, BW 56 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Closed, loopback not set
  Keepalive set (10 sec)

 

 

Why it spoofing, anyone can know the root cause of spoofing ?

Spoofing essentially means

Spoofing essentially means that it's a template and is just faking the functions of a real interface. When the PPPoE session establishes, you'll see all of the parameters from the dialer1 interface get copied to a virtual-access interface all of the real traffic occurs there.

Did you have any results from debugging the authentication?

New Member

Looking from attachment for

Looking from attachment for debuging, from the debug file, i saw the IPS assign static IP address for virtual access interface, but it not bind with dialer 1

New Member

Anyone can help me ?

Anyone can help me ?

It looks like you're getting

It looks like you're getting "113.176.64.4" from your ISP. Can you post the output from "show ip interface brief" when the negotiation completes?

New Member

Hello,Did it work?

Hello,

Did it work?


648
Views
0
Helpful
9
Replies
CreatePlease login to create content