Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 2501 lab problem

Hello

I have 2 cisco 2501 routers, (1E and 2S ports)

I have attached each ethernet to a different part of the LAN

I have put a db60-db60 cable on the S1 ports of both routers

10.0.x.x network SwitchA--ethernet--RouterB <-Serial-> RouterA - SwitchB 10.2.x.x network

I have looked it up in my CCNP BCRAN book but i don`t get the setup started

The setup for both connections are basic from a fresh install

8 REPLIES
Silver

Re: Cisco 2501 lab problem

Hi There

I am not sure I understand what the problem is or what you are asking. Is it a problem routing from the 10.0.x.x network to the 10.2.x.x network?

Best Regards,

Michael

New Member

Re: Cisco 2501 lab problem

Hi

Kindly tell your problem in detail.

Actually,your mail is not clearifying your problem.

New Member

Re: Cisco 2501 lab problem

I have a DB-60 serial cable between 2x Cisco 2501

Ethernet routerA is 10.0.0.0/16 network

Ethernet RouterB is 10.2.0.0/16 network

I want to establish a connection between these 2, but i get the message that the link is DOWN, while the config says the line should be up (without any configuration)

New Member

Re: Cisco 2501 lab problem

Hi Ramoonus,

I am not very clear what is the issue or our objectives of this lab.

As per my understanding you have 2 routers (model c2501). Say A and B.

On the Ethernet of router A you have 10.0.0.0/16 network and on Ethernet of Router B you have 10.2.0.0/16 network. Bother the router are connected by a Serial link using db60 cable.

You objective (I think) are to establish connecting between the two Ethernets subnet that is 10.0.0.0/16 and 10.2.0.0/16.

If so then here is the solution.

1) You need to assign IP address in the serial interface of both routers.

2) Configure routing on both the routers (either static or dynamic).

For point ONE command is

On router A

On the serial interface mode

IP address 192.168.1.1 255.255.255.0

No shut

Exit

On router B

On the serial interface mode

IP address 192.168.1.2 255.255.255.0

No shut

Exit

For second (static)

On router A (this is static default route)

In the configuration mode

IP route 0.0.0.0 0.0.0.0 192.168.1.2

On router B

In the configuration mode

IP route 0.0.0.0 0.0.0.0 192.168.1.1

Dynamic

On router A

In the configuration mode

Ip classless

Router rip

Network 10.0.0.0

Network 192.168.1.0

Version 2

Exit

On router B

In the configuration mode

Ip classless

Router rip

Network 10.2.0.0

Network 192.168.1.0

Version 2

Exit

Do rate the solution if it works

New Member

Re: Cisco 2501 lab problem

Thank you very much evsrajatgupta !

I think this will just do the trick but i cant test it untill tomorrow.

New Member

Re: Cisco 2501 lab problem

------------------ show running-config ------------------

Building configuration...

Current configuration : 725 bytes

!

version 12.1

service config

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname RouterB

!

enable secret 5

enable password

!

!

!

!

!

clock timezone CET 1

ip subnet-zero

!

!

!

!

interface Ethernet0

ip address 10.2.0.1 255.0.0.0

no ip mroute-cache

!

interface Serial0

ip address 192.168.1.2 255.255.255.0

no ip mroute-cache

no fair-queue

!

interface Serial1

no ip address

no ip mroute-cache

!

router rip

version 2

network 10.0.0.0

network 192.168.1.0

!

ip classless

ip http server

!

snmp-server community RO

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

password

login

!

New Member

Re: Cisco 2501 lab problem

ive found it

one of the cables was placed upside down :o

New Member

Re: Cisco 2501 lab problem

Hi Ramoonus,

There is a mis-configuration

Command ip address 10.2.0.1 255.0.0.0 mean that your network is 10.0.0.0/8 a class network. I think the command should be ip address 10.2.0.1 255.255.0.0 only then your network will be 10.2.0.0/16

Please rate

189
Views
10
Helpful
8
Replies