Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Cisco 2600 ADSL Static IP Issue

I'm coming from a Cisco 837 with a static IP to a 2600 with a ADSL WIC. Same ISP, just moving to new equipment

I have debugging turned on, and get an IP and route from my ISP (AT&T) but when I try to use my static IP I do not get connectivity (and the PPP logs show a completely different route from my ISP than I should be getting statically)

Was hoping someone could take a look at my config and give me some suggestions as to why my static IP doesn't work, but using the following does work:

ip address negotiated

ip route 0.0.0.0 0.0.0.0 Dialer0

[code]

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname SL2600

!

boot-start-marker

boot system flash:c2600-advipservicesk9-mz.124-19.bin

boot-end-marker

!

enable secret <SNIP>

!

no aaa new-model

no network-clock-participate slot 1

no network-clock-participate wic 0

ip cef

!

!

!

!

ip domain name domain.net

ip name-server 4.2.2.2

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

vpdn enable

!

vpdn-group 1

!

!

!

!

!

!

!

username admin privilege 15 secret 5 <SNIP>

!

!

!

interface ATM0/0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

no atm ilmi-keepalive

bundle enable

!

dsl operating-mode auto

hold-queue 224 in

!

interface ATM0/0.1 point-to-point

pvc 0/35

  pppoe-client dial-pool-number 1

!

!

interface FastEthernet0/0

ip address 10.10.10.201 255.255.255.0

duplex auto

speed auto

!

interface ATM0/1

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

shutdown

no atm ilmi-keepalive

dsl operating-mode auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Dialer0

description WAN

ip address <MY STATIC IP> 255.255.255.248

ip access-group INPUT_ACL in

no ip redirects

no ip unreachables

no ip proxy-arp

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

ip route-cache flow

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname user@static.sbcglobal.net

ppp chap password 7 <SNIP>

ppp pap sent-username <SNIP>@static.sbcglobal.net password 7 <SNIP>

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 <STATIC ROUTE>

!

!

no ip http server

no ip http secure-server

ip nat inside source list NAT_ACL interface Dialer0 overload

7 REPLIES
Hall of Fame Super Gold

Cisco 2600 ADSL Static IP Issue

If with negotiated you're getting 'your' address, then all is good.

If not, complain to ISP.

Re: Cisco 2600 ADSL Static IP Issue

Hi,

You've forgot to define your inside NAT interface.

int f0/0

ip nat inside

Kindly test again and revert the results.

Sent from Cisco Technical Support iPhone App

New Member

Cisco 2600 ADSL Static IP Issue

Thanks for the response guys.

The NAT issue isn't relevant in this case unfortunately, although I have added that now.

It doesn't appear to be an ISP issue because the 837 works just fine using the static IP. The Dialer0 config is taken straight from the 837.

Re: Cisco 2600 ADSL Static IP Issue

Hi,

Try again to contact your ISP. A static WAN IP is usually applied under the ATM interface. Your config clearly shows a dynamic broadband setup using PPPoE.

Sent from Cisco Technical Support iPhone App

New Member

Cisco 2600 ADSL Static IP Issue

Thanks for your help, I'll do that.

Could you reference me a config that puts static IP under ATM0 interface? Every config I've seen for a static IP has been under Dialer0.

New Member

Cisco 2600 ADSL Static IP Issue

Below is some debugging output, maybe it will help: (The 76.249.179.X IP is the static IP I have historically been able to use)

*Aug 12 01:13:26.897: Vi2 PPP: Treating connection as a callout

*Aug 12 01:13:26.897: Vi2 PPP: Session handle[12000020] Session id[0]

*Aug 12 01:13:26.897: Vi2 PPP: Phase is ESTABLISHING, Active Open

*Aug 12 01:13:26.901: Vi2 PPP: Authorization required

*Aug 12 01:13:26.901: Vi2 PPP: No remote authentication for call-out

*Aug 12 01:13:26.901: Vi2 LCP: O CONFREQ [Closed] id 1 len 10

*Aug 12 01:13:26.901: Vi2 LCP:    MagicNumber 0x14131518 (0x050614131518)

*Aug 12 01:13:26.901: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state p

*Aug 12 01:13:26.949: Vi2 LCP: I CONFREQ [REQsent] id 195 len 18

*Aug 12 01:13:26.949: Vi2 LCP:    MRU 1492 (0x010405D4)

*Aug 12 01:13:26.949: Vi2 LCP:    AuthProto PAP (0x0304C023)

*Aug 12 01:13:26.949: Vi2 LCP:    MagicNumber 0x5BDB971A (0x05065BDB971A)

SL2600#

*Aug 12 01:13:26.953: Vi2 LCP: O CONFNAK [REQsent] id 195 len 8

*Aug 12 01:13:26.953: Vi2 LCP:    MRU 1500 (0x010405DC)

*Aug 12 01:13:26.953: Vi2 LCP: I CONFACK [REQsent] id 1 len 10

*Aug 12 01:13:26.953: Vi2 LCP:    MagicNumber 0x14131518 (0x050614131518)

*Aug 12 01:13:27.001: Vi2 LCP: I CONFREQ [ACKrcvd] id 196 len 18

*Aug 12 01:13:27.001: Vi2 LCP:    MRU 1500 (0x010405DC)

*Aug 12 01:13:27.001: Vi2 LCP:    AuthProto PAP (0x0304C023)

*Aug 12 01:13:27.001: Vi2 LCP:    MagicNumber 0x5BDB971A (0x05065BDB971A)

*Aug 12 01:13:27.001: Vi2 LCP: O CONFACK [ACKrcvd] id 196 len 18

*Aug 12 01:13:27.001: Vi2 LCP:    MRU 1500 (0x010405DC)

*Aug 12 01:13:27.005: Vi2 LCP:    AuthProto PAP (0x0304C023)

*Aug 12 01:13:27.005: Vi2 LCP:    MagicNumber 0x5BDB971A (0x05065BDB971A)

*Aug 12 01:13:27.005: Vi2 LCP: State is Open

*Aug 12 01:13:27.005: Vi2 PPP: No authorization without authentication

*Aug 12 01:13:27.005: Vi2 PPP: Phase is AUTHENTICATING, by the peer

*Aug 12 01:13:27.005: Vi2 PAP: Using hostname from interface PAP

*Aug 12 01:13:27.005: Vi2 PAP: Using password from interface PAP

*Aug 12 01:13:27.005: Vi2 PAP: O AUTH-REQ id 1 len 47 from "terminamorte@static"

*Aug 12 01:13:29.121: Vi2 PAP: I AUTH-ACK id 1 len 5

*Aug 12 01:13:29.121: Vi2 PPP: Phase is FORWARDING, Attempting Forward

*Aug 12 01:13:29.121: Vi2 PPP: Queue IPCP code[1] id[201]

*Aug 12 01:13:29.125: Vi2 PPP SSS: Receive SSS-Mgr Connect-Local

*Aug 12 01:13:29.125: Vi2 PPP: Phase is ESTABLISHING, Finish LCP

*Aug 12 01:13:29.125: Vi2 PPP: Phase is UP

*Aug 12 01:13:29.125: Vi2 IPCP: O CONFREQ [Closed] id 1 len 10

*Aug 12 01:13:29.129: Vi2 IPCP:    Address 76.249.179.X (0x03064CF9B391)

*Aug 12 01:13:29.129: Vi2 PPP: Process pending ncp packets

*Aug 12 01:13:29.129: Vi2 IPCP: Redirect packet to Vi2

*Aug 12 01:13:29.129: Vi2 IPCP: I CONFREQ [REQsent] id 201 len 10

SL2600#

SL2600#

*Aug 12 01:13:29.129: Vi2 IPCP:    Address 99.143.127.254 (0x0306638F7FFE)

*Aug 12 01:13:29.129: Vi2 IPCP: O CONFACK [REQsent] id 201 len 10

*Aug 12 01:13:29.129: Vi2 IPCP:    Address 99.143.127.254 (0x0306638F7FFE)

*Aug 12 01:13:29.209: Vi2 IPCP: I CONFNAK [ACKsent] id 1 len 10

*Aug 12 01:13:29.209: Vi2 IPCP:    Address 99.143.118.64 (0x0306638F7640)

*Aug 12 01:13:29.209: Vi2 IPCP: O CONFREQ [ACKsent] id 2 len 4

*Aug 12 01:13:29.289: Vi2 IPCP: I CONFNAK [ACKsent] id 2 len 10

*Aug 12 01:13:29.289: Vi2 IPCP:    Address 99.143.118.64 (0x0306638F7640)

*Aug 12 01:13:29.293: Vi2 IPCP: Ignoring unrequested options!

*Aug 12 01:13:29.293: Vi2 IPCP: O CONFREQ [ACKsent] id 3 len 4

*Aug 12 01:13:29.689: Vi2 IPCP: I CONFACK [ACKsent] id 3 len 4

*Aug 12 01:13:29.689: Vi2 IPCP: State is Open

*Aug 12 01:13:29.693: Di0 IPCP: Install route to 99.143.127.254

*Aug 12 01:13:29.697: Vi2 IPCP: Add link info for cef entry 99.143.127.254

New Member

Cisco 2600 ADSL Static IP Issue

Hi William,

Did you get this working? I have a similar setup and want to run my sbc w/Static on a Cisco 3845 router, not on this moto NVG510 with its limited config they gave me.

But looking through the docs and info from SBC, I have more questions then answers.

I think your config looks good, I don't see a dialer list or the input ACL, but I'm just assuming you left it out. And in this case the layer 3 information always goes under the dialer interface, ip addresses, ACLs, etc.

I've seen a few configs out there using Chap and Pap. From the debugs it looks like pap is what was answered from the carrier.

I'm wondering if because of the PPPoE needed that the only way for the DSLAM to register an address is dynamic. Is the address always the same when you use dynamic?

It seems us people with some statics on DSL are left out in the cold a little, most of the info I'm finding deals with dynamic addresses, including the ppp authentication user/pass.

Please let me know if u got this up and working.  I'm really interested and maybe we can figure it out.

Thanks,

Karl

735
Views
0
Helpful
7
Replies
CreatePlease to create content