Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Cisco 2610 ADSL

I have a cisco 2610 with a WIC1-ADSL card, and the c2600-is4-mz version of IOS installed...

...My problem, I do believe, is in configuration. If I show interface adsl 0/0, it shows that there are packets being sent and received. On the BVI1 interface, they're only being outputted. I'm using Embarq (sprint) DSL, and they told me to use 8/35 for my vpi and vci...I have a static IP. What am I doing wrong? I can't ping the gateway from my router...?

--scott

21 REPLIES
Hall of Fame Super Gold

Re: Cisco 2610 ADSL

Hi,

please try:

interface ATM0/0

no bundle-enable

no bridge-group 1

no pvc 8/35

interface ATM0/0.1 point-to-point

bridge-group 1

pvc 8/35

encapsulation aal5snap

Hope this helps, please rate post if it does!

Community Member

Re: Cisco 2610 ADSL

I am not sure I understand why you need a BVI to accomplish your goal here.... you don't have any other interfaces in the bridge group to receive L2 packets.

Nothing is actually being bridged here, so you could probably just throw the ip configuration and the nat on the subint and get going!

NS

Hall of Fame Super Gold

Re: Cisco 2610 ADSL

Hi NS,

Well, I'm nor sure about Embarq (sprint) DSL, but many ISPs use bridged rfc1483 encapsulation for their service, so that is the reason for the BVI and the suggest configuration.

The reason why they to that, is because when the CPE is a "dumb" modem/bridge, a PC directly connected via ethernet will work with either rfc1483 bridged or PPPoE encapsulation, but it would not work with rfc1483 routed encap.

Community Member

Re: Cisco 2610 ADSL

I configured my old dsl 'modem' to use rfc1483...but I thought that was covered when I set the encapsulation to aal5snap in the pvc 8/35 within the atm 0/0...

Hall of Fame Super Gold

Re: Cisco 2610 ADSL

Does it work with the config changes I suggested ?

The thing is that you have to use point-to-point interfaces for rfc1483, and the main ATM it is point-to-multipoint instead. So the need for a subinterface.

Community Member

Re: Cisco 2610 ADSL

I did give that a try, simply executing those commands on top of the posted config...I would like to try it with a clean config, though. Now, I got the drift that you left the bvi in place and bridged it to the atm0/0.1, yes?

--scott

Hall of Fame Super Gold

Re: Cisco 2610 ADSL

Yes. Pasting the lines should have been enough. May be they have routed encap, as NS incidentally suggested.

To try that, remove bridging, and configure IP directly under atm0/0.1

Community Member

Re: Cisco 2610 ADSL

I'll try that with a fresh configuration right now. I did find, on google, someone configuring one of sprint's (who is now embarq) dsl modems as follows. It mentions encap;

DHCP= Server

Client IP Pool Starting Address= 192.168.1.2

Size of Client IP Pool= 1

Primary DNS Server= (supplied by Sprint) (204.x.x.10)

Secondary DNS Server= (supplied by Sprint) (199.x.x.10)

Remote DHCP Server= N/A

TCP/IP Setup:

IP Address= 192.168.1.1

IP Subnet Mask= 255.255.255.252

RIP Direction= Both

Version= RIP-1

Multicast= None

IP Policies=

Edit IP Alias= No

ISP's Name= MyISP

Encapsulation= ENET ENCAP

Multiplexing= LLC-based

VPI #= 8 (Assigned by Sprint)

VCI #= 35 (Assigned by Sprint)

Service Name= N/A

My Login= N/A

My Password= N/A

Single User Account= Yes

IP Address Assignment= Static

IP Address= (assigned by Sprint)

ENET ENCAP Gateway= (assigned by Sprint)

Community Member

Re: Cisco 2610 ADSL

alright, I tried a fresh configuration, and I attached it. I still can't ping my next hop, but both the atm interfaces are transferring packets. Here are the show interfaces:

CNRouter#show interfaces ATM 0/0

ATM0/0 is up, line protocol is up

Hardware is DSLSAR (with Alcatel ADSL Module)

MTU 4470 bytes, sub MTU 4470, BW 448 Kbit, DLY 4570 usec,

reliability 210/255, txload 1/255, rxload 1/255

Encapsulation ATM, loopback not set

Encapsulation(s): AAL5 AAL2, PVC mode

23 maximum active VCs, 256 VCs per VP, 1 current VCCs

VC Auto Creation Disabled.

VC idle disconnect time: 300 seconds

Last input 00:00:00, output 00:00:47, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: Per VC Queueing

5 minute input rate 1000 bits/sec, 2 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

1607 packets input, 188486 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 994 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

7 packets output, 596 bytes, 0 underruns

0 output errors, 0 collisions, 2 interface resets

0 output buffer failures, 0 output buffers swapped out

CNRouter#show interfaces ATM 0/0.1

ATM0/0.1 is up, line protocol is up

Hardware is DSLSAR (with Alcatel ADSL Module)

Internet address is 65.41.113.117/24

MTU 4470 bytes, BW 448 Kbit, DLY 4570 usec,

reliability 216/255, txload 1/255, rxload 1/255

Encapsulation ATM

1734 packets input, 201766 bytes

7 packets output, 596 bytes

0 OAM cells input, 0 OAM cells output

AAL5 CRC errors : 0

AAL5 SAR Timeouts : 0

AAL5 Oversized SDUs : 0

Last clearing of "show interface" counters never

Here is the running-config:

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname CNRouter

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip subnet-zero

ip cef

!

!

ip name-server 65.41.112.28

ip dhcp excluded-address 192.168.1.0 192.168.1.99

!

ip dhcp pool cnpool

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 65.41.112.28

netbios-name-server 192.168.1.6

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface ATM0/0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0/0.1 point-to-point

ip address 65.41.113.117 255.255.255.0

pvc 8/35

encapsulation aal5snap

!

!

interface Ethernet0/0

ip address 192.168.1.99 255.255.255.0

ip nat inside

full-duplex

!

interface Serial0/1

no ip address

shutdown

!

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 65.41.113.1

!

!

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

login local

!

!

end

Community Member

Re: Cisco 2610 ADSL

Make sure you're pinging from the ATM interface... you don't have enough configuration for your nat to work at this point. :-)

NS

Community Member

Re: Cisco 2610 ADSL

I put ip nat outside on the ATM0/0.1 interface, now what else do I have to do to configure nat?

Hall of Fame Super Gold

Re: Cisco 2610 ADSL

Hi, by the example posted seems like it should be bridged, however you have many errors also:

1607 packets input, 188486 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 994 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

would try another router to verify that the circuit is working first.

Community Member

Re: Cisco 2610 ADSL

When you say another router, do you mean try the WIC in a different router? or try a different DSL line? or try a different WIC?

--scott

Hall of Fame Super Gold

Re: Cisco 2610 ADSL

Would try a "consumer level" dsl router on the same line.

Community Member

Re: Cisco 2610 ADSL

Yeah, thats what I'm using now...its a "660 series" that I got from Embarq...

Hall of Fame Super Gold

Re: Cisco 2610 ADSL

Ok, can you post a show dsl interface and show atm pvc x/y, and check if CRC errors on i/f are still increasing, perhaps a dsl fw issue. Config should be ok by now and should work.

Community Member

Re: Cisco 2610 ADSL

Okay, here is the running config and the "shows" you wanted...

CNRouter Running Config:

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname CNRouter

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$XXXXXXXXXXXXXXXXXXXXXXXXXXX

!

no aaa new-model

ip subnet-zero

ip cef

!

!

ip name-server 65.x.x.28

ip dhcp excluded-address 192.168.1.0 192.168.1.99

!

ip dhcp pool cnpool

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 65.x.x.28

netbios-name-server 192.168.1.6

!

!

!

!

!

!

!

!

!

!

!

!

username cottsay secret 5 $1$XXXXXXXXXXXXXXXX

!

!

!

!

!

interface ATM0/0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0/0.1 point-to-point

ip address 65.x.x.117 255.255.255.0

ip nat outside

pvc 8/35

encapsulation aal5snap

!

!

interface Ethernet0/0

ip address 192.168.1.99 255.255.255.0

ip nat inside

full-duplex

!

interface Serial0/1

no ip address

shutdown

!

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 65.41.113.1

!

!

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

password 7 XXXXXXXXXXXXXXXX

login local

!

!

end

CNRouter#show interfaces ATM 0/0

ATM0/0 is up, line protocol is up

Hardware is DSLSAR (with Alcatel ADSL Module)

MTU 4470 bytes, sub MTU 4470, BW 448 Kbit, DLY 4570 usec,

reliability 68/255, txload 1/255, rxload 1/255

Encapsulation ATM, loopback not set

Encapsulation(s): AAL5 AAL2, PVC mode

23 maximum active VCs, 256 VCs per VP, 1 current VCCs

VC Auto Creation Disabled.

VC idle disconnect time: 300 seconds

Last input 00:00:01, output 00:00:37, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: Per VC Queueing

5 minute input rate 1000 bits/sec, 2 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

170 packets input, 15577 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 51 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

5 packets output, 460 bytes, 0 underruns

0 output errors, 0 collisions, 2 interface resets

0 output buffer failures, 0 output buffers swapped out

CNRouter#show interfaces ATM 0/0.1

ATM0/0.1 is up, line protocol is up

Hardware is DSLSAR (with Alcatel ADSL Module)

Internet address is 65.41.113.117/24

MTU 4470 bytes, BW 448 Kbit, DLY 4570 usec,

reliability 86/255, txload 1/255, rxload 1/255

Encapsulation ATM

214 packets input, 19446 bytes

5 packets output, 460 bytes

0 OAM cells input, 0 OAM cells output

AAL5 CRC errors : 0

AAL5 SAR Timeouts : 0

AAL5 Oversized SDUs : 0

Last clearing of "show interface" counters never

Question...what about NAT? Is NAT configured correctly? I did the "ip nat inside" and "ip nat outside", but I think I remember there being more to configuring NAT...

Another question...may seem dumb...but what is CRC? Is it bad?

--scott

Hall of Fame Super Gold

Re: Cisco 2610 ADSL

I doubt this will ever work unless yo get a clean circuit - crc's are transmission errors.

Possibly an IOS upgrade can get you new FW - the one you have doesn;t even show what version is it, try show controllers.

I also think you shouls use a BVI config for this. For NAT you only miss "ip nat inside source list 10 interface bvi1 overload" and 'access-list 10 permit ip 192.168.1.0 255.255.255.0". bvi woulr be replace with atm0/0.1 for a routed 1482 encapsulation.

Community Member

Re: Cisco 2610 ADSL

I would expect CRCs on an ADSL line. I mean, its DSL. Runs over house pairs. Goes a long way. Etcetera, and so forth.

I think the original config was probably right, I asked because I thought this might have been a business DSL routed sort of line, rather than a consumer line that had a modem on it before.

For that, it is certainly not correct anymore. Move the ip address back to a BVI, and delete it from the ATM PVC. After that, make sure that the encapsulation on the interface actually changes to AAL5 and RFC1483. Right now, it is AAL2. Then, verify the ATM interface is in the bridge table (show bridge 1) and try to ping the default gateway from the router, sourced from int BVI1 (ping x.x.x.x source bvi1).

If all that works, then you can add the nat stuff back. You were just missing an access list that matches your inside lan subnet.

NS

Community Member

Re: Cisco 2610 ADSL

Alright, please look at the other post for my new config, but I still can't ping...even with the 'source bvi1' on the tail. Here's my show bridge 1...it looks right to me.

CNRouter#show bridge 1

Total of 300 station blocks, 299 free

Codes: P - permanent, S - self

Bridge Group 1:

Address Action Interface Age RX count TX count

0030.8803.459b forward ATM0/0 3 37 0

...and if you'll notice in the show int for the atm, it shows AAL5 AND AAL2...

thanks,

--scott

Community Member

Re: Cisco 2610 ADSL

Alrighty, so here's my new configuration:

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname CNRouter

!

boot-start-marker

boot-end-marker

!

enable secret 5 xxxxxxxxxxxxxxxxxx

!

no aaa new-model

ip subnet-zero

ip cef

!

!

ip name-server 65.41.112.28

ip dhcp excluded-address 192.168.1.0 192.168.1.99

!

ip dhcp pool cnpool

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 65.41.112.28

netbios-name-server 192.168.1.6

!

!

!

!

!

!

!

!

!

!

!

!

username cottsay secret 5 xxxxxxxxxxxx

!

!

bridge irb

!

!

!

interface ATM0/0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

bridge-group 1

pvc 8/35

encapsulation aal5snap

!

!

interface Ethernet0/0

ip address 192.168.1.99 255.255.255.0

ip nat inside

full-duplex

!

interface Serial0/1

no ip address

shutdown

!

interface BVI1

ip address 65.41.113.117 255.255.255.0

ip nat outside

!

ip nat inside source list 10 interface BVI1 overload

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 65.41.113.1

!

!

access-list 10 permit 0.0.0.0 255.255.255.0

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

password 7 xxxxxxxxxxxxxxxxxx

login local

!

!

end

CNRouter#show interfaces ATM 0/0

ATM0/0 is up, line protocol is up

Hardware is DSLSAR (with Alcatel ADSL Module)

MTU 4470 bytes, sub MTU 4470, BW 448 Kbit, DLY 4570 usec,

reliability 226/255, txload 1/255, rxload 1/255

Encapsulation ATM, loopback not set

Encapsulation(s): AAL5 AAL2, PVC mode

23 maximum active VCs, 256 VCs per VP, 1 current VCCs

VC Auto Creation Disabled.

VC idle disconnect time: 300 seconds

Last input 00:00:00, output 00:02:15, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: Per VC Queueing

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

342 packets input, 35745 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 172 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

17 packets output, 1258 bytes, 0 underruns

0 output errors, 0 collisions, 2 interface resets

0 output buffer failures, 0 output buffers swapped out

CNRouter#show interfaces BVI 1

BVI1 is up, line protocol is up

Hardware is BVI, address is 0000.0cf0.ffe5 (bia 0004.9a8f.c920)

Internet address is 65.41.113.117/24

MTU 4470 bytes, BW 448 Kbit, DLY 5000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/0 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

11 packets output, 660 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

----------------------

Now here's something interesting...I tried the show controllers, and I got four of these on the console...

*Mar 2 09:51:27.531: ASSERTION FAILED: file "../les/if_dslsar_util.c", line 382

That doesn't look good...bad IOS image? Bad firmware? I have no idea...?

--scott

664
Views
0
Helpful
21
Replies
CreatePlease to create content