Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Cisco 2621 Can't connect 2 LANs

I have a Cisco 2621, and Can't connect 2 LANs. I have 2 Fast Ethernet interfaces, but need some help with the code to get the 2 to see each other, and share resources.

I have 2 LANs - 10.38.77.0 and 192.168.0.0. I can ping both LANs from the router, but, from each side, can only ping that LAN.

Any help would be greatly appreciated!!

10 REPLIES
Cisco Employee

Re: Cisco 2621 Can't connect 2 LANs

Make sure that the workstations are configured with a default gateway, which is the router interface address in the respective subnet.

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Community Member

Re: Cisco 2621 Can't connect 2 LANs

The workstations all have a default gateway set to their respective firewalls for internet access. Do I need to change all of this, or can I add this router's address as an alternative gateway?

Hall of Fame Super Blue

Re: Cisco 2621 Can't connect 2 LANs

Hi Larry

Can you make sure ip routing is enabled on the 2621 router. It should be by default so unless there is a statement

"no ip routing" in the config you should be okay.

Could you send a copy of the 2621 config ?.

Have you set the PC's default gateway to be the relevant router interface ?

Jon

Community Member

Re: Cisco 2621 Can't connect 2 LANs

Routing is enabled.

I have the router I/Fs set to 10.38.77.35 and 192.168.0.35

I have 2 test machines with respective addresses of 10.38.77.177 and 192.168.0.6

The config is below:

Router#sho runist

Building configuration...ntry

Current configuration : 714 bytes alias Crea

!

version 12.2

service timestamps debug uptime

alps

service timestamps log uptimeol

!d

call rsvp-syncp parameters

!

!

!

!

!

!

!

!

interface FastEthernet0/0

autonomous-sys

ip address 10.38.77.35 255.255.255.0to which we belong

duplex auto

speed auto

!

interface FastEthernet0/1ger Configure Backhaul

ip address 192.168.0.35 255.255.255.0

speed auto

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.0.2

ip route 10.38.77.0 255.255.255.0 10.38.77.177

ip route 10.38.77.0 255.255.255.0 192.168.0.0

ip route 192.168.0.0 255.255.255.0 192.168.0.6

ip route 192.168.0.0 255.255.255.0 10.38.77.0

no ip http server

ip pim bidir-enable

!

!

dial-peer cor custom

!

!

!

!

line con 0

line aux 0

line vty 0 4

!

end

Community Member

Re: Cisco 2621 Can't connect 2 LANs

ip route 0.0.0.0 0.0.0.0 192.168.0.2

ip route 10.38.77.0 255.255.255.0 10.38.77.177

ip route 10.38.77.0 255.255.255.0 192.168.0.0

ip route 192.168.0.0 255.255.255.0 192.168.0.6

ip route 192.168.0.0 255.255.255.0 10.38.77.0

Get rid of the static routes you have configured(see above). Make sure the hosts on the 192.168.0.0/24 network are using 192.168.0.35 as their default gateway.

Make sure the hosts on the 10.38.77.0/24 network are using 10.38.77.35 as their default gateway.

Community Member

Re: Cisco 2621 Can't connect 2 LANs

Thanks, I'll try that, but this router's only purpose is to connect the 2 LANs. When I get this into the live network, the gateway address for the internet is different (10.38.77.130 and 192.168.0.4 respectively).

Community Member

Re: Cisco 2621 Can't connect 2 LANs

As hritter said, the users workstations/servers will need to have a default gw set to the 2621. For these users to access the internet, you'll need to add default routes to the 2621 to reach the firewall.

Make sense?

Community Member

Re: Cisco 2621 Can't connect 2 LANs

Thanks - yes, makes sense. So I would use the command:

ip route 0.0.0.0 0.0.0.0 10.38.77.130

correct? That being the firewall on one of the LANs.

Sorry for my ignorance.

Community Member

Re: Cisco 2621 Can't connect 2 LANs

THANKS to all - it works now, using 1 gateway address for both LANs, then routing to the firewall!

Community Member

Re: Cisco 2621 Can't connect 2 LANs

Well, I thought it worked on the test machines, but didn't test internet on Both - only one of them. So, when I put them on-site, the only way they talked to each other was to set each LAN gateway as the other's firewall.

So am I correct in thinking that I need to (as stated in an earlier reply) set each LAN's workstations' gateway as the corresponding FA address? And then add routes from each of those to their respective firewalls as below?

ip route 10.38.77.35 255.255.255.0 10.38.77.130

ip route 192.168.0.35 255.255.255.0 192.168.0.4

166
Views
0
Helpful
10
Replies
CreatePlease to create content