Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 2800 IRB or VLAN or Both?

Good day and thank you for taking the time to read this.  My current setup is a Cisco 2811 router with v15.1 IOS, dhcp WAN through external cable modem.  I am able to get more dhcp addresses on my subscription.  I have been reading the IRB documents to see if there is a way to have the router grab one address and do what it is currently doing, and then have a bridge to another router or Linux NIC to grab another WAN dhcp address for other purposes.  I can't seem to get the bridging to work.  Here are a few pieces of the config WITHOUT any IRB or Vlans so you can get an idea of the topology here.  Thanks!

Router#show run
Building configuration...


Current configuration : 3799 bytes
!
! Last configuration change at 13:06:32 PDT Sat Mar 22 2014
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!

!
no aaa new-model
!
clock timezone PST -8 0
clock summer-time PDT recurring
!
crypto pki token default removal timeout 0
!
!
dot11 syslog
ip source-route
!
!
ip cef
!
no ip dhcp use vrf connected
ip dhcp binding cleanup interval 10

!
ip dhcp pool HOME
 network 172.16.0.0 255.255.252.0
 default-router 172.16.1.1
 dns-server 172.16.1.100
 option 42 ip 172.16.1.1
 option 66 ip 172.16.1.105
!

!
!

!
ipv6 unicast-routing
ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
voice service voip
 sip
!
!
!
!
!
voice-card 0
!
!
!
license udi pid CISCO2811 sn
!
redundancy
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0

 ip ddns update no-ip
 ip address dhcp
 ip access-group 123 in
 ip accounting output-packets
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
 ipv6 address dhcp
 ipv6 enable
 ipv6 nd autoconfig default-route
 ipv6 dhcp client pd PREFIX_1
!
interface FastEthernet0/1
 ip address 172.16.1.1 255.255.252.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
 ipv6 address PREFIX_1 ::1/64
 ipv6 enable
 ipv6 nd other-config-flag
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 1 interface FastEthernet0/0 overload

ip route 0.0.0.0 0.0.0.0 dhcp
!
access-list 1 permit 172.16.0.0 0.0.255.255
access-list 123 permit tcp 0.0.0.0 255.255.252.0 any eq telnet
access-list 123 deny   tcp any any eq telnet
access-list 123 permit ip any any
access-list 144 permit ipinip any any
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp profile default
!
!

!
!
sip-ua
 sip-server ipv4:172.16.1.105:5060
!
!
!
gatekeeper
 shutdown
!
!
!

!
scheduler allocate 20000 1000

end

 

3 REPLIES

Hello, Phil.As I understood

Hello, Phil.

As I understood your question you want to get more than 1 public IP-address from provider. If so, then why do you need them if you run NAT?

If you want port mapping, then it could be configured with single IP-address.

New Member

Two reasons.  1) I cannot get

Two reasons.  1) I cannot get enough public IP addresses to assign to all of my interfaces.  2) I have a situation where I need to serve as a gateway to a public IP address block (44-net, if you are familiar with that).  In order to do that with a single public IP, I would have to employ a type of double NAT, and that doesn't work so well with the frequent routing updates on the 44 network.  The second public IP I want to route directly to a NIC on my Linux box to handle the 44 stuff.

 

Thanks!
 

New Member

Actually, forget it - that

Actually, forget it - that wont work.  It turns out I do not get multiple public IPs from my ISP.

 

I think I will need to set up a vlan with ipinip encap.

90
Views
0
Helpful
3
Replies