Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 2801 router not showing temperature in show environment all command output

Dear All,

We have a Cisco 2801 router running IOS "c2801-spservicesk9-mz.151-4.M4.bin" which we upgraded from previous “c2801-spservicesk9-mz.124-3d.bin”.

Requirement.

We want to monitor the device temperature via snmp but unable to do because temperature ratings are not available on "show environment all" output like below.

Routeri# sh environment all
  Fan  1 OK
  Fan  2 OK
  ILP  Power Supply - Absent
  Fan Speed Setting: Normal

Where as on Cisco 2811/51 & Cisco 3825/45 we can get temperature ratings on "show env all" output.

As per link http://www-tss.cisco.com/eservice/elearning/router/cisco2800/doc/e-learning.pdf  below commands are supported on Cisco 2800 series router.

Command options

• show environment all

• show environment fans

• show environment leds

• show environment power-supply

• show environment table

• show environment temperatures

• show environment voltages

I want to know whether this is Cisco 2801 platform limitations or something else. tried to find Cisco doc on this but no luck.

Thanks in Advance.

1 ACCEPTED SOLUTION

Accepted Solutions

Cisco 2801 router not showing temperature in show environment al

Hi Pramod,

It appearst that it does have a temperature sensor per the "Overview of Cisco 2800 Series Routers":

Chassis Ventilation

Internal multispeed fans provide chassis cooling, controlled by an onboard temperature sensor.

The Cisco 2801 router has two fans. The Cisco 2801 router with inline  power includes two additional fans integrated with the inline power  supply, for a total of four fans. The Cisco 2801 internal fans operate  at three different speeds, running at the slower speeds to conserve  power and reduce fan noise at ambient temperatures below 40oC. They operate at the highest speed in ambient temperatures above 40oC.

The Cisco 2811 router has three fans that operate at a slower speed to  conserve power and reduce fan noise at ambient temperatures below 32oC. They operate at high speed in ambient temperatures above 32oC.

The Cisco 2821 and Cisco 2851 routers have three fans that operate at a  slower speed to conserve power and reduce fan noise at ambient  temperatures below 40oC. They operate at high speed in ambient temperatures above 40oC.

My 2851 shows a temperature reading with sh env, for what thats worth as well.

Best,

David

Please rate helpful posts.

2 REPLIES

Cisco 2801 router not showing temperature in show environment al

Hi Pramod,

It appearst that it does have a temperature sensor per the "Overview of Cisco 2800 Series Routers":

Chassis Ventilation

Internal multispeed fans provide chassis cooling, controlled by an onboard temperature sensor.

The Cisco 2801 router has two fans. The Cisco 2801 router with inline  power includes two additional fans integrated with the inline power  supply, for a total of four fans. The Cisco 2801 internal fans operate  at three different speeds, running at the slower speeds to conserve  power and reduce fan noise at ambient temperatures below 40oC. They operate at the highest speed in ambient temperatures above 40oC.

The Cisco 2811 router has three fans that operate at a slower speed to  conserve power and reduce fan noise at ambient temperatures below 32oC. They operate at high speed in ambient temperatures above 32oC.

The Cisco 2821 and Cisco 2851 routers have three fans that operate at a  slower speed to conserve power and reduce fan noise at ambient  temperatures below 40oC. They operate at high speed in ambient temperatures above 40oC.

My 2851 shows a temperature reading with sh env, for what thats worth as well.

Best,

David

Please rate helpful posts.

New Member

Cisco 2801 router not showing temperature in show environment al

Thanks Davaid,

I got link on support forum only i.e. Cisco 1841 and 2801 doesn’t have temperature sensor & doesn't show temperature in the “show environment all” output.

https://supportforums.cisco.com/thread/196056

And the closest document : "%ENVMON-3-OVERTEMP_OK: System temperature normal" messages doesn't supported on Cisco 2801.

http://www.cisco.com/en/US/docs/routers/access/2800/hardware/installation/guide/07_hw.html#wp1004092

17182
Views
10
Helpful
2
Replies