Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

paa
New Member

cisco 2811 as pptp-client

Hi! Is it possible to use 2811 12.4(15)T5-advipservices as pptp-client (like simple Windows XP client)? I know, that cisco works fine like pptp-server, but I don't find any information how to configure router like pptp-client.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: cisco 2811 as pptp-client

it's unsupported feature.

but you can try

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

service internal <-- #### HIDDEN COMMAND, REQUIRED ###

!

hostname R3

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip cef

!

!

!

!

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

multilink bundle-name authenticated

vpdn enable

!

vpdn-group PPTP

request-dialin

protocol pptp

rotary-group 0

initiate-to ip 10.0.0.1

l2tp tunnel receive-window 1024

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

archive

log config

hidekeys

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 10.0.0.5 255.255.255.252

duplex full

speed 100

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Dialer0

ip address negotiated

encapsulation ppp

dialer in-band

dialer idle-timeout 0

dialer string 123456

dialer vpdn

dialer-group 1

no cdp enable

ppp encrypt mppe auto

ppp chap hostname cisco

ppp chap password 0 cisco

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer0

ip route 10.0.0.1 255.255.255.255 10.0.0.6

no ip http server

no ip http secure-server

!

!

!

logging alarm informational

dialer-list 1 protocol ip permit

!

!

!

!

!

!

control-plane

!

!

!

!

!

!

gatekeeper

shutdown

!

!

line con 0

stopbits 1

line aux 0

line vty 0 4

!

!

end

2 REPLIES

Re: cisco 2811 as pptp-client

it's unsupported feature.

but you can try

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

service internal <-- #### HIDDEN COMMAND, REQUIRED ###

!

hostname R3

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip cef

!

!

!

!

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

multilink bundle-name authenticated

vpdn enable

!

vpdn-group PPTP

request-dialin

protocol pptp

rotary-group 0

initiate-to ip 10.0.0.1

l2tp tunnel receive-window 1024

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

archive

log config

hidekeys

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 10.0.0.5 255.255.255.252

duplex full

speed 100

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Dialer0

ip address negotiated

encapsulation ppp

dialer in-band

dialer idle-timeout 0

dialer string 123456

dialer vpdn

dialer-group 1

no cdp enable

ppp encrypt mppe auto

ppp chap hostname cisco

ppp chap password 0 cisco

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer0

ip route 10.0.0.1 255.255.255.255 10.0.0.6

no ip http server

no ip http secure-server

!

!

!

logging alarm informational

dialer-list 1 protocol ip permit

!

!

!

!

!

!

control-plane

!

!

!

!

!

!

gatekeeper

shutdown

!

!

line con 0

stopbits 1

line aux 0

line vty 0 4

!

!

end

paa
New Member

Re: cisco 2811 as pptp-client

Great thanks! It woks fine. Why cisco hide this information?

649
Views
0
Helpful
2
Replies