Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 2821 router

hi i got problem with my upload very slow.

when i check in speedtest.net download 10mb upload .10mb , when i remove the router and connect direct to computer. upload and downloads is fast 10mb for download and 6mb upload.

router 2821.

my config:

Code:

Building configuration...

Current configuration : 1498 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$v099$O3hUq1RShonkrqFQQfE0o.
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 172.100.60.0 172.100.60.209
ip dhcp excluded-address 172.100.60.241 172.100.60.255
!        
ip dhcp pool DHCP
   import all
   network 172.100.60.0 255.255.255.0
   domain-name network.com
   default-router 172.100.60.1
   dns-server 172.100.10.2
   lease 7
!        
!        
ip name-server 172.100.10.2
ip name-server 172.100.10.1
!        
!        
!        
!        
!        
!        
!        
!        
!        
interface GigabitEthernet0/0
ip address 172.100.10.10 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
hold-queue 100 out
!        
interface GigabitEthernet0/1
ip address 172.100.60.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
hold-queue 100 out
!        
ip classless
ip route 0.0.0.0 0.0.0.0 172.100.10.2
ip route 10.10.0.0 255.255.0.0 172.100.10.215
ip route 10.20.0.0 255.255.0.0 172.100.60.10
!        
no ip http server
no ip http secure-server
ip nat inside source list 10 interface GigabitEthernet0/1 overload
!        
access-list 10 permit 172.100.60.0
access-list 10 permit 172.100.60.0 0.0.0.225
snmp-server community public RO
!        
!        
control-plane
!        
!        
!        
line con 0
password cisco
login   
line aux 0
line vty 0 4
password cisco
login   
!        
scheduler allocate 20000 1000
!        
end


11 REPLIES
Gold

Cisco 2821 router

Hi,

May i ask you how is your connectivity looking like? I mean to what device this router is connecting to?

Regards

Najaf

New Member

Cisco 2821 router

connected to microwave link from another office of ours.

Gold

Cisco 2821 router

Hi Nacho,

Do you know the micro wave link output support 1000Mbps..If it doesn't try manually configuring your router interface with speed 100 and duplex full.

Coming back to your configuration your outside interface (from NAT's prespective) is showns as GigabitEthernet0/0 and inside interface as GigabitEthernet0/1.

Your NAT statement shows your Natting to the inside interface. Is this not suppose to be outside interface like as below. May be i'm wrong but worth cross checking the same.

ip nat inside source list 10 interface GigabitEthernet0/0 overload

Hope that helps

Regards

Najaf

Please rate when applicable or helpful !!!



New Member

Cisco 2821 router

if i manually change to full duplex connection will be drop.

and i change it to " ip nat inside source list 10 interface GigabitEthernet0/0 overload" no effect still. do i need to reboot?


Gold

Cisco 2821 router

Hi,

After NAT change you don't have to reboot. Is Internet still working after the NAT statement change?

Have you tried changing speed and duplex to confirm the connection is completely dropping? I agree that there would be a momentarily drop

Could you please share below outout from router?

show inter gi0/1

show inter gi0/0

show nat trans

Hope that helps

Regards

Najaf

Please rate when applicable or helpful !!!

New Member

Cisco 2821 router

GigabitEthernet0/0 is up, line protocol is up

  Hardware is MV96340 Ethernet, address is 001b.542c.d530 (bia 001b.542c.d530)

  Internet address is 172.100.10.10/24

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 2/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, media type is T

  output flow-control is XON, input flow-control is XON

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:00, output 00:00:00, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 1092000 bits/sec, 160 packets/sec

  5 minute output rate 229000 bits/sec, 116 packets/sec

     164226 packets input, 131733466 bytes, 0 no buffer

     Received 8136 broadcasts, 0 runts, 0 giants, 0 throttles

     1 input errors, 0 CRC, 0 frame, 0 overrun, 1 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     131598 packets output, 23265052 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 1 pause output

     0 output buffer failures, 0 output buffers swapped out

GigabitEthernet0/1 is up, line protocol is up

  Hardware is MV96340 Ethernet, address is 001b.542c.d531 (bia 001b.542c.d531)

  Internet address is 172.100.60.1/24

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, media type is T

  output flow-control is XON, input flow-control is XON

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:00, output 00:00:00, output hang never

  Last clearing of "show interface" counters never

  Input queue: 1/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 237000 bits/sec, 117 packets/sec

  5 minute output rate 999000 bits/sec, 139 packets/sec

     141359 packets input, 25140302 bytes, 0 no buffer

     Received 8076 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     157131 packets output, 131853487 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 pause output

     0 output buffer failures, 0 output buffers swapped out

Pro Inside global      Inside local       Outside local      Outside global

tcp 172.100.10.10:3283 172.100.60.1:3283  172.100.10.209:61218 172.100.10.209:61218

tcp 172.100.10.10:3283 172.100.60.1:3283  172.100.10.209:61219 172.100.10.209:61219

tcp 172.100.10.10:3283 172.100.60.1:3283  172.100.10.209:61220 172.100.10.209:61220

tcp 172.100.10.10:3283 172.100.60.1:3283  172.100.10.209:61222 172.100.10.209:61222

tcp 172.100.10.10:50037 172.100.60.66:50037 173.194.36.1:443 173.194.36.1:443

tcp 172.100.10.10:50058 172.100.60.66:50058 173.194.36.3:443 173.194.36.3:443

tcp 172.100.10.10:50059 172.100.60.66:50059 173.194.36.9:443 173.194.36.9:443

udp 172.100.10.10:53314 172.100.60.71:53314 64.4.23.157:40035 64.4.23.157:40035

udp 172.100.10.10:53314 172.100.60.71:53314 65.55.223.32:40001 65.55.223.32:40001

udp 172.100.10.10:53314 172.100.60.71:53314 100.68.217.129:34661 100.68.217.129:34661

udp 172.100.10.10:53314 172.100.60.71:53314 111.221.74.16:40001 111.221.74.16:40001

udp 172.100.10.10:53314 172.100.60.71:53314 111.221.74.21:40018 111.221.74.21:40018

udp 172.100.10.10:53314 172.100.60.71:53314 111.221.74.32:40001 111.221.74.32:40001

udp 172.100.10.10:53314 172.100.60.71:53314 111.221.77.142:40033 111.221.77.142:40033

udp 172.100.10.10:53314 172.100.60.71:53314 157.55.56.149:40046 157.55.56.149:40046

udp 172.100.10.10:53314 172.100.60.71:53314 157.55.56.160:40032 157.55.56.160:40032

Gold

Cisco 2821 router

Hi,

If you could answer my previous questions please? i.e.

Is Internet still working after the NAT statement change?

Have you tried changing speed and duplex to confirm the connection is completely dropping?

Currently i can see GigabitEthernet0/0 is auto negotiated to 100 full..Hope this is the interface you are using to connect to micro wave link. I would suggest you to set the speed and duplex manually and try the speed test..

Hope that helps

Regards

Najaf

Please rate when applicable or helpful !!!

New Member

Re: Cisco 2821 router

yes working

i tried manually change duplex to full and speed to 100 it will completly drop connections.

New Member

Cisco 2821 router

Anyone have another idea? please help..

Gold

Cisco 2821 router

Hi,

Is this link used only to access Internet? Or intranet as well?

Do you have any PC with two network card? If then we could try ICS by completly avoiding the router?

Another option you could try is upgrade the IOS image on the router to verify if that help.

Hope that helps

Regards

Najaf

Please rate when applicable or helpful !!!

New Member

Cisco 2821 router

Thanks all we solve this problem already , Firewall problem from the other side with the office.

483
Views
0
Helpful
11
Replies