Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 2901 and ARP

Hello, I recently purchased a 2901, I used to run an 1811. I'm trying to figure out if the reason I can't seem to get the ARP configuration working correctly.

I register to my Charter Fiber WAN using a static address 24.XXX.XXX.XXX. I have a static pool (68.XXX.XXX.100 - 68.XXX.XXX.105) assigned by Charter, used for servers. On my 1811 anyone attempting to reach my static pool has no issues. If I were to browse http://www.whatsmyip.org on this router, depending on what server i'm on, I will see an address of 68.XXX.XXX.XXX. This is what I expect to happen.

However, on my 2901 this fails. Internally the 68.XXX.XXX.XXX network works perfectly, I can echo and load any servers, however on the WAN side this network doesn't exist, and any attempt to use a 68 address server fails. If I were to browse http://www.whatsmyip.org, no matter what server i'm on, I will see an address of 24.XXX.XXX.XXX. Is this just a difference in models? It would seem by default ARP is setup on the 2901.

Cisco 2901 configuration

Building configuration...

Current configuration : 2350 bytes
!
! Last configuration change at 08:36:19 UTC Mon Oct 6 2014
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Cisco2901
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 supersecretpassword
enable password 7 supersecretpassword
!
no aaa new-model
!
ip cef
!
!
!         
ip dhcp excluded-address 68.XXX.XXX.100
!         
ip dhcp pool DHCP_Pool
 network 68.XXX.XXX.099 255.255.255.248
 default-router 68.XXX.XXX.100 
 dns-server 8.8.8.8 8.8.4.4 
 class DHCP_Class
  address range 68.XXX.XXX.100 68.XXX.XXX.105
!         
!         
ip dhcp class DHCP_Class
!         
!         
no ipv6 cef
!         
multilink bundle-name authenticated
!         
!         
!         
!         
license udi pid CISCO2921/K9 sn FTX1828AKAY
!         
!         
!         
redundancy
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
!         
interface Embedded-Service-Engine0/0
 no ip address
 shutdown 
!         
interface GigabitEthernet0/0
 ip address 24.XXX.XXX.XXX 255.255.255.252
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!         
interface GigabitEthernet0/1
 no ip address
 shutdown 
 duplex auto
 speed auto
!         
interface GigabitEthernet0/2
 no ip address
 shutdown 
 duplex auto
 speed auto
!         
interface GigabitEthernet0/1/0
 no ip address
!         
interface GigabitEthernet0/1/1
 no ip address
!         
interface GigabitEthernet0/1/2
 no ip address
!         
interface GigabitEthernet0/1/3
 no ip address
!         
interface GigabitEthernet0/1/4
 no ip address
!         
interface GigabitEthernet0/1/5
 no ip address
!         
interface GigabitEthernet0/1/6
 no ip address
!         
interface GigabitEthernet0/1/7
 no ip address
!         
interface Vlan1
 ip address 68.XXX.XXX.100 255.255.255.248
 ip nat inside
 ip virtual-reassembly in
!         
router rip
 network 68.0.0.0
!         
ip default-gateway 68.XXX.XXX.100
ip forward-protocol nd
!         
no ip http server
no ip http secure-server
!         
ip nat inside source list InternetAccessList interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
!         
ip access-list standard InternetAccessList
 permit 68.XXX.XXX.0 0.0.0.255
!         
!         
!         
snmp-server community WWM_Cisco2901 RO
snmp-server enable traps entity-sensor threshold
!         
control-plane
!         
!         
!         
line con 0
line aux 0
line 2    
 no activation-character
 no exec  
 transport preferred none
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 password 7 supersecretpassword
 login    
 transport input all
!         
scheduler allocate 20000 1000
!         
end 

 

Show arp

Internet  24.XXX.XXX.XXX -  f8c2.8869.fbe0  ARPA   GigabitEthernet0/0
Internet  68.XXX.XXX.100  -  f8c2.8869.fbe3  ARPA   Vlan1

  • WAN Routing and Switching
Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

The title of the post

The title of the post suggests that there might be issues about ARP. But I do not see anything in the text of the post that indicates any issue with ARP.

 

I do not know how your old router was configured or how it worked. But the cause of your current issue is pretty clear. You have configured the router to perform address translation for any 68.x.x.x traffic going out the Internet interface
ip nat inside source list InternetAccessList interface GigabitEthernet0/0 overload

ip access-list standard InternetAccessList
 permit 68.XXX.XXX.0 0.0.0.255

 

If you do not want the addresses to be translated on the way out then remove the ip nat statement.

 

HTH

 

Rick

2 REPLIES
Hall of Fame Super Silver

The title of the post

The title of the post suggests that there might be issues about ARP. But I do not see anything in the text of the post that indicates any issue with ARP.

 

I do not know how your old router was configured or how it worked. But the cause of your current issue is pretty clear. You have configured the router to perform address translation for any 68.x.x.x traffic going out the Internet interface
ip nat inside source list InternetAccessList interface GigabitEthernet0/0 overload

ip access-list standard InternetAccessList
 permit 68.XXX.XXX.0 0.0.0.255

 

If you do not want the addresses to be translated on the way out then remove the ip nat statement.

 

HTH

 

Rick

New Member

Thanks, it worked perfectly.

Thanks, it worked perfectly. I'm still learning Cisco ios, so forgive the noobness.

63
Views
0
Helpful
2
Replies