Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 2911 stops responding after a period of time

I have a Cisco 2911 router with 4 T1 connections.  Two are set as a multilink and the other two are for two other locations.  The router will run fine, but after a month I cannot ping the gigabit ethernet 0/0 interface.  I would have to manually reboot the router to get it to respond again.  Before I noticed a lot of interface discards which would shutdown the 2911 and a manual reboot would be needed, but for this time it isn't the case.  Where would I start with this the memory and cpu usage are fine.

Here is the config:

Current configuration : 2905 bytes

!

version 15.0

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname 2911

!

boot-start-marker

boot-end-marker

!

card type t1 0 0

card type t1 0 1

!

no aaa new-model

clock timezone gmt -5

clock summer-time cdt recurring

no network-clock-participate wic 0

no network-clock-participate wic 1

!

no ipv6 cef

ip source-route

ip cef

!

!

!

!

multilink bundle-name authenticated

!

!

!

!

license udi pid CISCO2911/K9 sn FTX1513ALLS

!

!

!

!

controller T1 0/0/0 -- Multilink

cablelength long 0db

channel-group 0 timeslots 1-24

!

controller T1 0/0/1 -- Multilink

clock source internal

cablelength long 0db

channel-group 0 timeslots 1-24

!

controller T1 0/1/0

clock source internal

cablelength long 0db

channel-group 3 timeslots 1-24

!

controller T1 0/1/1

clock source internal

cablelength long 0db

channel-group 2 timeslots 1-24

!

buffers middle permanent 200

buffers middle max-free 230

buffers middle min-free 50

buffers big permanent 75

buffers big max-free 200

buffers big min-free 15

buffers verybig permanent 20

buffers verybig max-free 20

buffers tune automatic

!

!

!

!

interface Multilink1

ip address 192.168.200.1 255.255.255.252

ip flow ingress

ip flow egress

load-interval 30

ppp multilink

ppp multilink group 1

ppp multilink fragment disable

no cdp enable

hold-queue 4000 out

!

interface GigabitEthernet0/0

ip address 10.10.99.1 255.255.255.0

ip flow ingress

ip flow egress

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

no fair-queue

hold-queue 40 out

!

interface Serial0/0/1:0

no ip address

encapsulation ppp

ppp multilink

ppp multilink group 1

no fair-queue

hold-queue 40 out

!

interface Serial0/1/0:3

ip address 192.168.1.2 255.255.255.0

ip flow ingress

ip flow egress

load-interval 60

no fair-queue

hold-queue 4000 out

!

interface Serial0/1/1:2

ip address 192.168.8.2 255.255.255.0

ip flow ingress

ip flow egress

load-interval 30

no fair-queue

hold-queue 4000 out

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

ip flow-cache timeout active 1

ip flow-export source GigabitEthernet0/0

ip flow-export version 5

ip flow-export destination 10.10.14.49 2055

!

ip route 0.0.0.0 0.0.0.0 10.10.99.10

ip route 10.10.17.0 255.255.255.0 192.168.1.1

ip route 10.10.25.0 255.255.255.0 192.168.8.1

ip route 10.10.94.0 255.255.254.0 192.168.200.2

!

!

!

snmp-server community ipBalance RO

snmp-server community SolarWinds RO

!

control-plane

!

!

line con 0

logging synchronous

line aux 0

line vty 0 4

session-timeout 60

privilege level 15

password 7

logging synchronous

login

transport input telnet

!

scheduler allocate 20000 1000

end

Everyone's tags (1)
3 REPLIES

Cisco 2911 stops responding after a period of time

First thing, to reduce the discards on the interface, please hard code the interface to whatever you want like 100/full-duplex

or 1000/full duplex if you are connecting with ethernet.

secondly, what IOS are you using. I guess there might be some memory leaks or some BUGs associated. Try to check in cisco website for bug toolkit. I heard that the new IOS's seem to have plenty of issues

thirdly i would suggest you send your syslogs to a syslog server. It would give you more idea of whats going on before the router dies.

Hope this helps

Regards

Kishore

New Member

Cisco 2911 stops responding after a period of time

Kishore,

I just hard coded the gigabit 0/0 to 1000 full duplex.  The interface errors were occuring on the serial interfaces due to someone doing videoconferencing and trying to use more than 1.5Mbps over the T1.  Once they throttled down the video conferencing equipment, the errors seemed to go away. 

IOS is

Cisco IOS Software, C2900 Software (C2900-UNI​VERSALK9-M​), Version 15.0(1)M4, RELEASE SOFTWARE (fc1)

For syslogs I enabled:

logging trap notifications

logging IP of syslog server

service timestamps debug datetime msec

service timestamps log datetime msec localtime show-timezone year

New Member

We have recently installed

We have recently installed some 2911's, after a few weeks we cant log into the consol, it comes up with a memory issue. THE IOS is version 15.2-4m3

It has serial cards and a voice card/ UC software

Any advice, this box failing is giving us big probelms

 

935
Views
0
Helpful
3
Replies