Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

cisco 3640 with 2 ISP & route-map load balancing

Hi,

I'm trying to setup 3640 router with 2 ISP's. I can't have BGP because one ISP is comcast running on simple SMC modem/router/firewall but is it perfectly fine to have "route-map " type balancing. I'd like to have 5 IP addresses to use T1 and the rest comcast. (in my config only 1 is set -192.168.30.151)

What am I missing in my current config:


version 12.4
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cisco3640
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
enable secret 5 $1$rpH4$/jrOUBf232342342b.
enable password 123xxxxxxxxx321
no aaa new-model
memory-size iomem 10
!
!
ip cef
ip name-server 4.2.2.2
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.30.1 192.168.30.150
!
ip dhcp pool 1
   network 192.168.30.0 255.255.255.0
   default-router 192.168.30.1
   dns-server 4.2.2.2 4.2.2.5
   domain-name mylocaldomain.com
   lease 1 1
!
!
!
!
!
!
!
interface FastEthernet0/0
description connected to localLAN
ip address 192.168.30.1 255.255.255.0
ip nat inside
ip virtual-reassembly
speed auto
half-duplex
!
interface Ethernet1/0
description T1 internet
ip address 69.x.x.98 255.255.255.240
ip nat outside
ip virtual-reassembly
full-duplex
!
interface TokenRing1/0
no ip address
shutdown
ring-speed 16
!
interface Ethernet2/0
description COMCAST internet
ip address 192.168.26.1 255.255.255.0
ip nat outside
ip virtual-reassembly
half-duplex
!
router rip
version 2
passive-interface Ethernet2/0
network 192.168.30.0
no auto-summary
!
ip http server
!
no ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.26.254
ip route 0.0.0.0 0.0.0.0 69.x.x.97
!
ip nat inside source route-map ISP-T1 interface Ethernet1/0 overload
ip nat inside source route-map ISP-comcast interface Ethernet2/0 overload
!
access-list 10 permit 192.168.30.0 0.0.0.255

access-list 11 permit 192.168.30.151


route-map ISP-comcast permit 10
match ip address 10
match interface Ethernet2/0
!
route-map ISP-T1 permit 11
match ip address 11
match interface Ethernet1/0
!

!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
password 123xxxxxxx321
login
!
!
end

2 REPLIES
New Member

Re: cisco 3640 with 2 ISP & route-map load balancing

I'm no expert in this but it looks like your route map statements have one too many match statements.  You are saying "Add the packet route route-map ISP-comcast if it matches access list 10 AND is comes in E2/0".  Try removing the second match statement.

Silver

Re: cisco 3640 with 2 ISP & route-map load balancing

Hi

In the given acl

access-list 10 permit 192.168.30.0 0.0.0.255 the ip .151 is also permitted. Could you add deny first for .151 in acl 10 then permit 192.168.30.0 0.0.0.255

regards

Shivlu Jain

http://www.mplsvpn.info

502
Views
0
Helpful
2
Replies