Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Cisco 7606 - cannot assign ports to VLAN

Hello all:

I have a Cisco 7606 that I am testing with and it has the following modules installed:

2 - WS-SUP720-3B

2 - WS-X6748-GE-TX

The interfaces are up and the VLAN's are configured and active.  The problem that I am running into is that when I assign a port to a VLAN it does not show up afterwards when I use the "show vlan brief" command.  The ports that I assign are not there.

Any thoughts on this?

Thanks for your help.

John

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Cisco 7606 - cannot assign ports to VLAN

Hello John,

check also the power supplies but all the first linecards are powered off by the supervisor

post show log as a text file in an attachment to find out the reasons for this.

Or the power is not enough to light on the modules or there is some incompatibility that caused the power deny

Hope to help

Giuseppe

18 REPLIES
Hall of Fame Super Silver

Re: Cisco 7606 - cannot assign ports to VLAN

Hello John,

C7600 and C6500 defaults to L3 interface

you need to use switchport command to make a port a L2 interface:

interface gix/y

switchport

switchport mode access

switchport access vlan N

Hope to help

Giuseppe

Community Member

Re: Cisco 7606 - cannot assign ports to VLAN

Hi Giuseppe:

I have done this and it works fine but the ports still do not show up when I use

the sh vlan brief command.  It just states that the VLAN is active.

There is nothing under the section output labeled ports.

Cisco Employee

Re: Cisco 7606 - cannot assign ports to VLAN

Hello John,

What does the output of the show int giX/Y switchport say?

Best regards,

Peter

Community Member

Re: Cisco 7606 - cannot assign ports to VLAN

Hi Peter:

The output is as follows:

Name: Gi3/1

Switchport: Enabled

Administrative Mode: static access

Cisco Employee

Re: Cisco 7606 - cannot assign ports to VLAN

Hello John,

Hmm, that is strange. Giuseppe, any idea about this? I find it strange that a port recognized as a static access port does not show up in the show vlan brief output.

John, one more experiment: what would the command show vlan id VID say? (Replace the VID with the access VLAN number)

Best regards,

Peter

Community Member

Re: Cisco 7606 - cannot assign ports to VLAN

Hey Peter:

Here is the output from the sh vlan id command:

Cat7606#show vlan id 10

VLAN   Name                                  Status    Ports

----        --------------------------------     ---------    -------------------------------

10         VLAN0010                         active

VLAN  Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2

----      -----    ----------     ----      ------    ------ -     -------         ----   --------          ------      ------

10        enet  100010   1500     -          -             -                 -       -                  0          0

Remote SPAN VLAN

----------------

Disabled

Primary Secondary Type              Ports

------- --------- ----------------- ------------------------------------------

Hall of Fame Super Blue

Re: Cisco 7606 - cannot assign ports to VLAN

John

What IOS are you running ?

If 12.2SR can you post output of "sh vlan all-ports"

also the output of "sh interface gi.. switchport" that you posted, was that the full output ?

Jon

Community Member

Re: Cisco 7606 - cannot assign ports to VLAN

Hey Jon:

I am running version 12.2(18)SX

The sh interface Gi output is the full output.  This is really

strange.

Hall of Fame Super Blue

Re: Cisco 7606 - cannot assign ports to VLAN

thejackalhas1 wrote:

Hey Jon:

I am running version 12.2(18)SX

The sh interface Gi output is the full output.  This is really

strange.

John

Actually, just checked and "sh vlan all-ports" is supported under 12.2SXF.

Can you post config of switchport.

Also, do you know if it actually works ie. does it actually place the port into the right vlan, just doesn't show it in the config ?

Finally can you post "sh module"

Jon

Community Member

Re: Cisco 7606 - cannot assign ports to VLAN

Jon:

I have tested the physical ports but they do not even light up when I physically connect them.  Here

is the output from the sh moduel command: see attached.

I really appreciate your help with this.

Hall of Fame Super Silver

Re: Cisco 7606 - cannot assign ports to VLAN

Hello John,

all the first three linecards are in power deny state and also the daughter cards DFC 3C. the Sup is 720 3B.

Try to reboot the system, there is a recent thread about this issue with mismatching type of PFC and DFCs on linecards

Clearly in this situation you are "provisioning" ports that are not alive.

the show module must provide status OK for the linecards and their associated DFCs

Hope to help

Giuseppe

Community Member

Re: Cisco 7606 - cannot assign ports to VLAN

Hi Giuseppe,

I think we three of us were typing messages at the same time...

You are correct as the modules are in pwrdeny state. Strange part is how is john able to configure those ports and put them in vlans... I think those ports should not be shown in running config.. rite?

Dear John,

Can you please post the output of entire "sh ip int brief"

Community Member

Re: Cisco 7606 - cannot assign ports to VLAN

Well this sounds a bit strange... Lets start by cheking the vlan.dat in the 7606 router. This file is stored in nvram. You can check it by :

# dir const_nvram:

If you have previous backup of this file and no new vlans are added then compare the file size of the existing file with the backup one.

Did you check this : when you assign a port in a particular vlan and connect a link onto that port, does that port stay amber or does it turn green?

You may also test this : create a svi with unique vlan id and check its status in "sh ip int brief" it will stay down unless you create a vlan in the database with the same id of which you created the svi. After you create the svi... create the vlan in the database and the svi should turn up if you have any trunk port on which this vlan is allowed, else for testing purpose go ahead and assign a port in this vlan and connect a machine in that port.

check the output of

"sh vlans"     ----- dont forget the 's' in vlans

"sh vlan brief"

"dir const_nvram:"

post these outputs if possible...

hope this helps...

Community Member

Re: Cisco 7606 - cannot assign ports to VLAN

Hello Talha:

There  is no light when I connect the ports I am using for the VLAN testing.  Attached is the output from

the following commands:

#sh vlans

#sh vlan brief

#dir const_nvram

Thank you for your help,

John

Community Member

Re: Cisco 7606 - cannot assign ports to VLAN

Talha:

I have connected the Gi3/1 port to a server that is on the network and there is no light / activity

on the NIC card or port.  Here is the output from the sh ip int brief command:

Cat7606#sh ip int brief

Interface IP-Address OK? Method Status Protocol

Vlan1 192.168.69.10 YES NVRAM down down

Vlan10 unassigned YES NVRAM administratively down down

TenGigabitEthernet2/1 unassigned YES NVRAM administratively down down

TenGigabitEthernet2/2 unassigned YES NVRAM administratively down down

TenGigabitEthernet2/3 unassigned YES NVRAM administratively down down

TenGigabitEthernet2/4 unassigned YES NVRAM administratively down down

TenGigabitEthernet2/5 unassigned YES NVRAM administratively down down

TenGigabitEthernet2/6 unassigned YES NVRAM administratively down down

TenGigabitEthernet2/7 unassigned YES NVRAM administratively down down

TenGigabitEthernet2/8 unassigned YES NVRAM administratively down down

GigabitEthernet3/1 unassigned YES unset down down

GigabitEthernet3/2 unassigned YES unset down down

GigabitEthernet3/3 unassigned YES NVRAM down down

GigabitEthernet3/4 unassigned YES NVRAM down down

GigabitEthernet3/5 unassigned YES NVRAM down down

GigabitEthernet3/6 unassigned YES NVRAM down down

GigabitEthernet3/7 unassigned YES NVRAM down down

GigabitEthernet3/8 unassigned YES NVRAM down down

GigabitEthernet3/9 unassigned YES NVRAM down down

GigabitEthernet3/10 unassigned YES NVRAM down down

GigabitEthernet3/11 unassigned YES NVRAM down down

GigabitEthernet3/12 unassigned YES NVRAM down down

GigabitEthernet3/13 unassigned YES NVRAM down down

GigabitEthernet3/14 unassigned YES NVRAM down down

GigabitEthernet3/15 unassigned YES NVRAM down down

GigabitEthernet3/16 unassigned YES NVRAM down down

GigabitEthernet3/17 unassigned YES NVRAM down down

GigabitEthernet3/18 unassigned YES NVRAM down down

GigabitEthernet3/19 unassigned YES NVRAM down down

GigabitEthernet3/20 unassigned YES NVRAM down down

GigabitEthernet3/21 unassigned YES NVRAM down down

GigabitEthernet3/22 unassigned YES NVRAM down down

GigabitEthernet3/23 unassigned YES NVRAM down down

GigabitEthernet3/24 unassigned YES NVRAM down down

GigabitEthernet3/25 unassigned YES NVRAM down down

GigabitEthernet3/26 unassigned YES NVRAM down down

GigabitEthernet3/27 unassigned YES NVRAM down down

GigabitEthernet3/28 unassigned YES NVRAM down down

GigabitEthernet3/29 unassigned YES NVRAM down down

GigabitEthernet3/30 unassigned YES NVRAM down down

GigabitEthernet3/31 unassigned YES NVRAM down down

GigabitEthernet3/32 unassigned YES NVRAM down down

GigabitEthernet3/33 unassigned YES NVRAM down down

GigabitEthernet3/34 unassigned YES NVRAM down down

GigabitEthernet3/35 unassigned YES NVRAM down down

GigabitEthernet3/36 unassigned YES NVRAM down down

GigabitEthernet3/37 unassigned YES NVRAM down down

GigabitEthernet3/38 unassigned YES NVRAM down down

GigabitEthernet3/39 unassigned YES NVRAM down down

GigabitEthernet3/40 unassigned YES NVRAM down down

GigabitEthernet3/41 unassigned YES NVRAM down down

GigabitEthernet3/42 unassigned YES NVRAM down down

GigabitEthernet3/43 unassigned YES NVRAM down down

GigabitEthernet3/44 unassigned YES NVRAM down down

GigabitEthernet3/45 unassigned YES NVRAM down down

GigabitEthernet3/46 unassigned YES NVRAM down down

GigabitEthernet3/47 unassigned YES NVRAM down down

GigabitEthernet3/48 unassigned YES NVRAM down down

GigabitEthernet4/1 unassigned YES NVRAM down down

GigabitEthernet4/2 unassigned YES NVRAM down down

GigabitEthernet4/3 unassigned YES NVRAM down down

GigabitEthernet4/4 unassigned YES NVRAM down down

GigabitEthernet4/5 unassigned YES NVRAM down down

GigabitEthernet4/6 unassigned YES NVRAM down down

GigabitEthernet4/7 unassigned YES NVRAM down down

GigabitEthernet4/8 unassigned YES NVRAM down down

GigabitEthernet4/9 unassigned YES NVRAM down down

GigabitEthernet4/10 unassigned YES NVRAM down down

GigabitEthernet4/11 unassigned YES NVRAM down down

GigabitEthernet4/12 unassigned YES NVRAM down down

GigabitEthernet4/13 unassigned YES NVRAM down down

GigabitEthernet4/14 unassigned YES NVRAM down down

GigabitEthernet4/15 unassigned YES NVRAM down down

GigabitEthernet4/16 unassigned YES NVRAM down down

GigabitEthernet4/17 unassigned YES NVRAM down down

GigabitEthernet4/18 unassigned YES NVRAM down down

GigabitEthernet4/19 unassigned YES NVRAM down down

GigabitEthernet4/20 unassigned YES NVRAM down down

GigabitEthernet4/21 unassigned YES NVRAM down down

GigabitEthernet4/22 unassigned YES NVRAM down down

GigabitEthernet4/23 unassigned YES NVRAM down down

GigabitEthernet4/24 unassigned YES NVRAM down down

GigabitEthernet4/25 unassigned YES NVRAM down down

GigabitEthernet4/26 unassigned YES NVRAM down down

GigabitEthernet4/27 unassigned YES NVRAM down down

GigabitEthernet4/28 unassigned YES NVRAM down down

GigabitEthernet4/29 unassigned YES NVRAM down down

GigabitEthernet4/30 unassigned YES NVRAM down down

GigabitEthernet4/31 unassigned YES NVRAM down down

GigabitEthernet4/32 unassigned YES NVRAM down down

GigabitEthernet4/33 unassigned YES NVRAM down down

GigabitEthernet4/34 unassigned YES NVRAM down down

GigabitEthernet4/35 unassigned YES NVRAM down down

GigabitEthernet4/36 unassigned YES NVRAM down down

GigabitEthernet4/37 unassigned YES NVRAM down down

GigabitEthernet4/38 unassigned YES NVRAM down down

GigabitEthernet4/39 unassigned YES NVRAM down down

GigabitEthernet4/40 unassigned YES NVRAM down down

GigabitEthernet4/41 unassigned YES NVRAM down down

GigabitEthernet4/42 unassigned YES NVRAM down down

GigabitEthernet4/43 unassigned YES NVRAM down down

GigabitEthernet4/44 unassigned YES NVRAM down down

GigabitEthernet4/45 unassigned YES NVRAM down down

GigabitEthernet4/46 unassigned YES NVRAM down down

GigabitEthernet4/47 unassigned YES NVRAM down down

GigabitEthernet4/48 unassigned YES NVRAM down down

GigabitEthernet5/1 unassigned YES NVRAM administratively down down

GigabitEthernet5/2 unassigned YES NVRAM administratively down down

GigabitEthernet6/1 unassigned YES NVRAM administratively down down

GigabitEthernet6/2 unassigned YES NVRAM administratively down down

Cat7606#

Hall of Fame Super Silver

Re: Cisco 7606 - cannot assign ports to VLAN

Hello John,

check also the power supplies but all the first linecards are powered off by the supervisor

post show log as a text file in an attachment to find out the reasons for this.

Or the power is not enough to light on the modules or there is some incompatibility that caused the power deny

Hope to help

Giuseppe

Community Member

Re: Cisco 7606 - cannot assign ports to VLAN

Gentlemen:

It was a power issue.  I rebooted the 7606 and reset the power supplies

and now the line cards are in an ok status when I use the sh module

command.  I am also able to see the ports assigned to the correct VLAN's

and the ports are active when connected.

Thank you for all your help.  What a day.

Sincerely,

John

Community Member

Re: Cisco 7606 - cannot assign ports to VLAN

Well then... I guess alls well that ends well.. yet better check for the "show environment" whether you have ample amount of power and as well as power supply status.... Good luck.. :)

2310
Views
5
Helpful
18
Replies
CreatePlease to create content