Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Cisco 819 DDR 3G with floating static route - 3G Flapping!

I have a new Cisco 819 router wtih Verizon 3G built in.  I want to use this router to provide 3G backup Internet access for a customer kiosk. 

The 3G is perfectly stable when I use it as a primary, static routed connection.  When I use a floating static route, the link goes up and down constantly. 

The 3G link works for a about 20-  30 seconds, then goes to reset, down, then dials up and reconnects. 

What am I missing? 

Attached is the config and debug log file.

Aaron Gabrielson

Everyone's tags (3)
2 REPLIES
Community Member

Re: Cisco 819 DDR 3G with floating static route - 3G Flapping!

Here is my config: 

version 15.1

service timestamps debug datetime msec
service timestamps log datetime msec

!

hostname Scale2_Cisco819
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 XXXXXXXXXXXXXXXXXXXXXX
!
no aaa new-model
!
clock timezone PCTime -7 0
clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
!
!
ip source-route
ip cef
!

ip domain name xxx.xxx
ip name-server 8.8.8.8
no ipv6 cef
!
!
multilink bundle-name authenticated
chat-script verizon3G "" "ATDT#777" TIMEOUT 60 "CONNECT"
license udi pid C819G-V-K9 sn XXXXXXXXXXX
!
!
username admin privilege 15 secret 5 XXXXXXXXXXXXXXXXXXXXXXXX
!

!
controller Cellular 0
!
!
track 234 ip sla 1 reachability
!
!
interface Cellular0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer in-band
dialer idle-timeout 2147483
dialer string verizon3G
dialer-group 1
async mode interactive
no ppp lcp fast-start
ppp chap password 0 cisco
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface GigabitEthernet0
description $ES_WAN$
ip address 10.2.1.170 255.255.0.0
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Serial0
ip address negotiated
shutdown
clock rate 2000000
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$
ip address 10.4.7.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1452
!
ip local policy route-map track-primary-if
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip nat inside source route-map nat2cell interface Cellular0 overload
ip nat inside source route-map nat2ge interface GigabitEthernet0 overload
ip route 0.0.0.0 0.0.0.0 10.2.1.1 track 234
ip route 0.0.0.0 0.0.0.0 Cellular0 10
!
ip sla 1
icmp-echo 10.2.1.171 source-interface GigabitEthernet0
ip sla schedule 1 life forever start-time now
access-list 1 permit any
access-list 101 permit ip 10.4.7.0 0.0.0.255 any
access-list 102 permit icmp any host 10.2.1.171
dialer-list 1 protocol ip list 1
no cdp run
!
!
!
!
route-map track-primary-if permit 10
match ip address 102
set interface GigabitEthernet0
!
route-map nat2ge permit 10
match ip address 101
match interface GigabitEthernet0
!
route-map nat2cell permit 10
match ip address 101
match interface Cellular0
!
!
control-plane
!
!
line con 0
login local
line aux 0
line 3
exec-timeout 0 0
password cisco
script dialer verizon3G
login
modem InOut
no exec
rxspeed 3100000
txspeed 1800000
line vty 0 4
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
end

Community Member

Re: Cisco 819 DDR 3G with floating static route - 3G Flapping!

I took the floating routes out and I am still getting the problem the cellular0 interface going up and down. 

I think it might have something to do with my NAT settings.  When I set the cellular0 connection for the only NAT entry, the connection is stable.  With the two NAT entries with the route-map policies I am having problems. 

Is there something wrong with my NAT setup in the above config? Or maybe with the access-lists referenced by the route-maps maybe? 

Aaron G. 

1446
Views
0
Helpful
2
Replies
CreatePlease to create content