Cisco Support Community
Community Member

Cisco 837 Configuration Help Request

Hello All. I just got my hands on a Cisco 837 router and was wondering if I could get assistance in configuring the device to work with my cable internet account. I need assistance in understanding how to set the E1 (wan connection to assign it self an IP address from my cable modem). I would also like to ask for assistance in setting up dhcp serving with the understanding the WAN connection is assigned dynamically.

I have my CCNA, however I do not have any experince with these router/switch combo devices. Any assistance would greatly be appreciated.


VIP Purple

Re: Cisco 837 Configuration Help Request

Hello Vinnie,

when you say ´E1 WAN Coonection´, I assume you are talking about PPPoE ?

Here is a basic PPPoE sample config which should work on your 837 (obviously you have to modify the IP addresses and username/password combinations).

Can you try to configure this on your router ? Let me know if you run into trouble...

no aaa new-model

ip subnet-zero

ip cef


vpdn enable


vpdn-group 1


protocol pppoe





interface Ethernet0

description Lan Interface

ip address

ip nat inside

no ip mroute-cache

no cdp enable


interface Ethernet1

description ADSL Interface

no ip address

no ip mroute-cache

pppoe enable

pppoe-client dial-pool-number 1

no cdp enable


interface Dialer1

description connection to Internet

p address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

no ip mroute-cache

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap callin

ppp chap hostname xxxxxxxx@adslprovider

ppp chap password 7 xxxxxxxxxxxxxxx

ppp pap sent-username xxxxxxx@adslprovider password 7 xxxxxx


ip nat inside source list 1 interface Dialer1 overload

no ip http server

ip classless

ip route Dialer1



access-list 1 permit

no cdp run


line con 0

line aux 0

transport input all

line vty 0 4

password 7 xxxxxxxx





Community Member

Re: Cisco 837 Configuration Help Request

Thank you GP for your assistance. However, is there a way for any ports on the 837 to gain its ip address through DHCP from the ISP? The ISP is a cable provider and does not use PPPoE. The Cable modem dishes out a IP address to the connected device via DHCP. I was just wondering if it was possible to set the 837 as a gateway type router. If not, I do understand...the product was free to me so I was just trying to find some use for it.


CreatePlease to create content