Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Cisco 837 NAT problem

Dear Sir,

I have cisco 837 ADSL router so sometimes suddenly no internet access (internet disconnect).

I entered to the router by console then ping to ISP's DNS ( public IP address) it's ok then ping to my laptop it's ok too but from my laptop to this public IP address no reply!!

I made continuous ping from my laptop to ISP's DNS ( public IP address) there was request timed out after I delete the NAT command and return it the ping changed from request timed out to reply !!  so what is the problem? it's IOS problem, Hardware problem or RAM or what?

This is the configuration and what I did to solve the problem:

sh run

Building configuration...

Current configuration : 2006 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

memory-size iomem 5

enable secret 5 $1$Idzo$jLBd.1OKb.acRpU8dhsqr/

!

aaa new-model

!

!

aaa authentication login default local

aaa authentication login sdm_vpn_xauth_ml_1 local

aaa authorization exec default local

--More--                           aaa authorization network sdm_vpn_group_ml_1 local

!

aaa session-id common

!

resource policy

!

ip subnet-zero

no ip dhcp use vrf connected

!

ip dhcp pool cisco

   network 192.168.0.0 255.255.255.0

   default-router 192.168.0.254

   dns-server 65.162.184.33 65.162.184.34

!

!

ip cef

no ip ips deny-action ips-interface

!

!

!

username test privilege 15 secret 5 $1$zISo$n1r4KtszsxxGM8ni/48bV/

!

!

--More--                           !

!

!

interface Ethernet0

ip address 192.168.0.254 255.255.255.0

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1412

hold-queue 100 out

!

interface Ethernet2

no ip address

hold-queue 100 out

!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

pvc 8/35

  pppoe-client dial-pool-number 1

!

--More--                           !

interface FastEthernet1

duplex auto

speed auto

!

interface FastEthernet2

duplex auto

speed auto

!

interface FastEthernet3

duplex auto

speed auto

!

interface FastEthernet4

duplex auto

speed auto

!

interface Dialer0

ip address negotiated

ip mtu 1452

ip nat outside

ip virtual-reassembly

encapsulation ppp

--More--                            dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname muneer1

ppp chap password 0 123456

ppp pap sent-username muneer1 password 0 123456

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

ip http server

ip http authentication local

no ip http secure-server

!

ip nat inside source list 1 interface Dialer0 overload

!

access-list 1 permit 192.168.0.0 0.0.0.255

!

control-plane

!

!

line con 0

no modem enable

line aux 0

--More--                           line vty 0 4

password 123456

!

scheduler max-task-time 5000

end

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#no ip nat inside source list 1 interface Dialer0 overload

Dynamic mapping in use, do you want to delete all entries? [no]: y

Router(config)#ip nat inside source list 1 interface Dialer0 overload

Router(config)#^Z

Router#

Regards.

Muneer

muneer@yemen.net.ye

2 REPLIES

Re: Cisco 837 NAT problem

Hi,

When Internet stops working from your computer can you test if you can still PING the internet from the router itself?

i.e

ping 4.2.2.2

If the router is not losing Internet and the problem is only with the internal LAN, then check if you can PING the default gateway of the router from the laptop.

From the computer: ping x.x.x.x -->  x.x.x.x is the IP from ''sh ip route''

Additionally, how many computers/hosts do you have behind the router getting out to the Internet?

I'm just wondering if there are too many translations/connections going through the router at any given time (NAT table getting full).

Federico.

Community Member

Re: Cisco 837 NAT problem

Dear Federico,

Thank you for your help.

When the internet hang in the laptop the ping still working from the router to outside because I was pinging to the ISP's DNS which has public IP address.

In the same time I can entered to the router by telnet from the laptop which mean I can ping from the laptop to the router.

About ping from the laptop to the gateway of the router I didn't try it so I will try to do it when it hang another time.

The computers behind the router just my laptop but do you think the viruses can make this problem?

Regards

756
Views
0
Helpful
2
Replies
CreatePlease to create content