Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

cisco 857w wireless and adsl2+ configuration

Hi I'm trying to configure my cisco 857w router for wireless access through an ADSL2+ connection. The following is the configuration, It's not connecting wireless devices or to the ADSL connection. What I'm I missing.

Building configuration...

Current configuration : 2049 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ROUTER

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool my-pool

   import all

   network 10.10.10.0 255.255.255.0

   default-router 10.10.10.1

   domain-name wr

   dns-server 8.8.8.8

   lease 0 2

!

!

ip cef

ip domain name me.local

ip name-server 8.8.8.8

!

!

!

!

!

vtp mode transparent

username me password 7 075E740C440812040216030D

!

!

!

bridge irb

!

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

pvc 8/35

  pppoe-client dial-pool-number 1

!

dsl operating-mode auto

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Dot11Radio0

no ip address

!

encryption vlan 1 mode ciphers tkip

!

encryption mode ciphers tkip

!

ssid ME-WIFI

    vlan 1

    authentication open

    guest-mode

    wpa-psk ascii 7 07022D434206170218

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

!

interface Vlan1

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

ip route-cache flow

ip tcp adjust-mss 1452

bridge-group 1

!

interface Dialer0

no ip address

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname myispusername

ppp chap password 7 15051E030A253C2126626C7544

ppp pap sent-username myispusername password 7 08365941071612121C5A55537D

!

interface BVI1

ip address 10.10.10.1 255.255.255.0

!

ip route 0.0.0.0 0.0.0.0 Dialer0

!

no ip http server

no ip http secure-server

!

dialer-list 1 protocol ip permit

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

!

line con 0

no modem enable

line aux 0

line vty 0 4

password 7 030E5A00071A25444F

login

!

scheduler max-task-time 5000

end

ROUTER#

Everyone's tags (4)
2 ACCEPTED SOLUTIONS

Accepted Solutions
Cisco Employee

cisco 857w wireless and adsl2+ configuration

Hi Elijah, Leo,

There are more issues than just those two. Elijah, your configuration is incomplete in many places. Please try to paste the following lines into your configuration mode:

! Begin here

interface Dot11radio0

  ssid ME-WIFI

    authentication key-management wpa

    exit

  channel least-congested

  no shutdown

  bridge-group 1

!

interface BVI1

  ip nat inside

!

interface Vlan1

  no ip nat inside

  no ip tcp adjust-mss

  no ip route-cache flow

!

interface Dialer0

  no ppp authentication chap pap callin

  ip mtu 1492

  ip tcp adjust-mss 1452

  no dialer-group 1

ip access-list standard NAT

  permit 10.10.10.0  0.0.0.255

!

ip nat inside source list NAT interface Dialer0 overload

!

no dialer-list 1 protocol ip permit

! End here

Best regards,

Peter

Cisco Employee

cisco 857w wireless and adsl2+ configuration

Hi Elijah,

Umm, sorry, I forgot the

ip address negotiated

on the Dialer0 interface. Please add it there.

Best regards,

Peter

13 REPLIES
Hall of Fame Super Gold

cisco 857w wireless and adsl2+ configuration

1.  Your NAT is missing;

2.  Your Dialer Pool is missing.

Cisco Employee

cisco 857w wireless and adsl2+ configuration

Hi Elijah, Leo,

There are more issues than just those two. Elijah, your configuration is incomplete in many places. Please try to paste the following lines into your configuration mode:

! Begin here

interface Dot11radio0

  ssid ME-WIFI

    authentication key-management wpa

    exit

  channel least-congested

  no shutdown

  bridge-group 1

!

interface BVI1

  ip nat inside

!

interface Vlan1

  no ip nat inside

  no ip tcp adjust-mss

  no ip route-cache flow

!

interface Dialer0

  no ppp authentication chap pap callin

  ip mtu 1492

  ip tcp adjust-mss 1452

  no dialer-group 1

ip access-list standard NAT

  permit 10.10.10.0  0.0.0.255

!

ip nat inside source list NAT interface Dialer0 overload

!

no dialer-list 1 protocol ip permit

! End here

Best regards,

Peter

Hall of Fame Super Gold

cisco 857w wireless and adsl2+ configuration

Elijah,

Peter's right.  There's alot of missing parts to your config.  Go here.  Look at the attachment I made with configs for a router and an AP.

Have a look at those if you have the chance.

Community Member

cisco 857w wireless and adsl2+ configuration

Hi Peter/Guys,

Thanks for the quick response. I copied the configs and have the following output from the sh ip int b

ROUTER(config)#do sh ip int b

Interface                  IP-Address      OK? Method Status                Protocol

Dot11Radio0                unassigned      YES TFTP   up                    up     

FastEthernet0              unassigned      YES unset  up                    down   

FastEthernet1              unassigned      YES unset  up                    down   

FastEthernet2              unassigned      YES unset  up                    down   

FastEthernet3              unassigned      YES unset  down                  down   

ATM0                       unassigned      YES NVRAM  up                    up     

Vlan1                      unassigned      YES manual up                    down   

Dialer0                    unassigned      YES manual up                    up     

Virtual-Access1            unassigned      YES unset  up                    up     

Virtual-Dot11Radio0        unassigned      YES TFTP   down                  down   

Virtual-Access2            unassigned      YES unset  up                    up     

BVI1                       10.10.10.1      YES manual up                    up     

NVI0                       unassigned      NO  unset  up                    up     

ROUTER(config)#

The wireless access is still not working so I want to check out Leo's config.

Cisco Employee

cisco 857w wireless and adsl2+ configuration

Hi Elijah,

Umm, sorry, I forgot the

ip address negotiated

on the Dialer0 interface. Please add it there.

Best regards,

Peter

Community Member

cisco 857w wireless and adsl2+ configuration

Hi Peter,

Thanks...looks like it's working coz sh ip int b shows an IP address on the Dialer0 Interface. Now if only I could get the Wireless working. Thanks heaps.

Cisco Employee

cisco 857w wireless and adsl2+ configuration

Elijah,

Can you post the output of the show run int dot11radio0 please?

Best regards,

Peter

Community Member

cisco 857w wireless and adsl2+ configuration

ROUTER(config-if)#do sh run int dot11radio0

Building configuration...

Current configuration : 547 bytes

!

interface Dot11Radio0

no ip address

!

encryption vlan 1 mode ciphers tkip

!

encryption mode ciphers tkip

!

ssid ME-WIFI

    vlan 1

    authentication open

    guest-mode

    wpa-psk ascii 7 07022D434206170218

!

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

end

ROUTER(config-if)#

Cisco Employee

cisco 857w wireless and adsl2+ configuration

Elijah,

You still seem to be missing the authentication key-management wpa in the "ssid ME-WIFI" subsection. Have you entered that command? It is possible that it is the default but I want to be sure.

Best regards,

Peter

Community Member

cisco 857w wireless and adsl2+ configuration

Hi Peter,

I have added that line, I had it before but still no connection. The physical interfaces seem to be picking the DHCP addresses but the wireless is not.

Thanks

Re: cisco 857w wireless and adsl2+ configuration

Hi,

Try adding this line under dot11radio0 interface:

encryption mode cipher aes-ccm

Sent from Cisco Technical Support iPhone App

Cisco Employee

cisco 857w wireless and adsl2+ configuration

Hi Elijah,

Has there been any improvement in the meantime?

Best regards,

Peter

Community Member

cisco 857w wireless and adsl2+ configuration

Hi Guys,

Thank you so much I was able to have everything working using the configs Peter gave me and the configs Leo posted on another post. Everything is working now...now to play around with VPN and ACLs. Thanks guys.

2106
Views
0
Helpful
13
Replies
CreatePlease to create content