Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Cisco 870 ISDN problem

Hi,

I have a HQ site able to bring up a Dialer connection to a remote site (Site-BB). It also works in reverse i.e. Site-BB can make the connection into HQ. Now I have a requirement to get a 3rd site connecting into Site-BB. But when I create a new Dialer interface the original connection won't come up.

Here are the details:

!

hostname Site-BB

!

ip cef

no ip bootp server

ip name-server 192.168.1.105

!

!

isdn switch-type basic-net3

!

!

username SIte-HQ password xxxxxxxxxx

!

!

interface BRI0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

encapsulation ppp

dialer pool-member 2

isdn switch-type basic-net3

isdn point-to-point-setup

!

interface ATM0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

no atm ilmi-keepalive

!

interface FastEthernet0

!

interface FastEthernet1

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$

ip address 192.168.4.250 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

!

interface Dialer0

no ip address

!

interface Dialer1

no ip address

encapsulation ppp

dialer pool 1

dialer idle-timeout 20

dialer string 0191730044

dialer string 0191730066

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname Site-BB

ppp chap password xxxxxxxxx

ppp pap sent-username Site-BB password xxxxxxx

!

interface Dialer3

ip address 10.0.4.1 255.255.255.0

encapsulation ppp

dialer pool 2

dialer string 0191730044

dialer string 0191730066

dialer-group 2

no cdp enable

ppp authentication chap pap callin

ppp chap hostname Site-BB

ppp chap password xxxxx

ppp pap sent-username Site-BB password xxxxxxxxxx

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer3

ip route 192.168.1.1 255.255.255.255 192.168.4.254

ip route 192.168.1.4 255.255.255.255 192.168.4.254

ip route 192.168.1.5 255.255.255.255 192.168.4.254

ip route 192.168.1.6 255.255.255.255 192.168.4.254

ip route 192.168.1.105 255.255.255.255 Dialer3

ip route 192.168.1.151 255.255.255.255 192.168.4.254

ip route 192.168.1.153 255.255.255.255 192.168.4.254

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip nat inside source list 1 interface Dialer0 overload

ip nat outside source static network 192.168.1.105 192.168.4.250 /32

!

ip access-list extended OutSIte-HQ

remark out to SIte-HQ

remark SDM_ACL Category=1

remark out to HQ

permit ip 192.168.4.0 0.0.0.255 10.0.4.0 0.0.0.255

ip access-list extended inboundSIte-HQ

remark inboundSIte-HQ

remark SDM_ACL Category=1

permit ip 10.0.4.0 0.0.0.255 192.168.4.0 0.0.0.255

!

logging trap debugging

access-list 1 remark INSIDE_IF=Vlan1

access-list 1 remark SDM_ACL Category=3

access-list 1 permit 192.168.4.0 0.0.0.255

dialer-list 1 protocol ip permit

dialer-list 2 protocol ip permit

no cdp run

!

!

control-plane

!

banner login ^CCCCCCCCCCCCCCCCCAuthorized access only!

no inservice

!

end

______________

So above works fine both ways; when I add the new details below for the new site - it stops working

!

username Site-BB password xxx

!

interface BRI0

dialer pool-member 3

! (now BRI0 has pool-member 2 and 3)

!

!

interface Dialer99

description ISDN_to_New-site

ip address 192.168.99.74 255.255.255.0

encapsulation ppp

dialer pool 3

dialer string 0167115500

dialer-group 2

pulse-time 0

ppp authentication chap pap callin

ppp chap hostname Site-BB

ppp chap password 0 xxx

ppp pap sent-username Site-BB password 0xxx

!

!

ip route 192.168.200.0 255.255.255.0 dialer99

!___________________________________

Obviously I now need to be able to have ISDN access Site-BB from both HQ-Site and New-site. Any help appreciated. Thanks

_____________

June 7th...

I understand I will need to add the new subnet to the access list; however, the problem is that once the new Dialer99 is added to the config the HO router cannot access Site-BB (using Dialer3). I need to have this working as normal before testing access from the New-site (using Dialer99).

15 REPLIES
Hall of Fame Super Silver

Re: Cisco 870 ISDN problem

Hello T.connor,

I suspect that the BRI can be pool member of only one dialer pool at the same time.

No, actually it is supported see DIAL command reference

http://www.cisco.com/en/US/docs/ios/dial/command/reference/dia_d1.html#wp1033489

So the second dialer that you add dialer99 might use the same dialer pool 2 as the first dialer dialer3.

The dialer pool defines a set of resources that in your case are the two B channels of the BRI interface.

There is another aspect that needs to be addressed: if a call is in place it can take both B channels of the BRI leaving no chance to place the second call.

You could add to both dialer the command

dialer load-threshold 255

in order to reduce the chance that the second B channel is used in the call

There is a specific command to specify the max number of calls

http://www.cisco.com/en/US/docs/ios/dial/command/reference/dia_d1.html#wp1033489

dialer max-call 1

in your case to indicate only one B channel to be used. Configure it only on this router not on the other ones.

Hope to help

Giuseppe

New Member

Re: Cisco 870 ISDN problem

Hi,

Thanks for the reply. From Cisco ...

http://www.cisco.com/en/US/docs/ios/12_0/dial/command/reference/drdiprof.html#wp4903

interface BRI1

encapsulation ppp

dialer pool-member 1 priority 50

dialer pool-member 2 priority 50

!BRI 1 has a reserved channel in dialer pool 3; the channel remains

inactive

!until BRI 1 uses it to place calls.

dialer pool-member 3 min-link 1

ppp authentication chap

Regards,

Terry O'Connor

From:

giuslar

To:

Terry O'Connor1/Ireland/IBM@IBMIE

Date:

06/06/2012 14:58

Subject:

- Re: Cisco 870 ISDN problem

Home

Re: Cisco 870 ISDN problem

created by Giuseppe Larosa in WAN, Routing and Switching - View the full

discussion

Hello T.connor,

I suspect that the BRI can be pool member of only one dialer pool at the

same time.

So the second dialer that you add dialer99 should use the same dialer pool

2 as the first dialer dialer3.

There is another aspect that needs to be addressed: if a call is in place

it can take both B channels of the BRI leaving no chance to place the

second call.

You could add to both dialer the command

dialer load-threshold 255

in order to reduce the chance that the second B channel is used in the

call

Hope to help

Giuseppe

Reply to this message by going to Home

Start a new discussion in WAN, Routing and Switching at Home

Hall of Fame Super Silver

Cisco 870 ISDN problem

Hello T.conner

yes I have seen the command reference

however, the suggestion to limit to one B channel each dialer interface might be helpful

see

dialer max-call 1

http://www.cisco.com/en/US/docs/ios/dial/command/reference/dia_d1.html#wp1013853

to be put in each dialer interface configuration to allow space for the second call

Hope to help

Giuseppe

New Member

Re: Cisco 870 ISDN problem

Hi,

OK - I will change both Dialers to be in the same dialer pool (pool 2).

Also, do you think I need to configure the original Dialer3 and new

Dialer99 with both these commands?

dialer load-threshold 255

dialer max-call 1

Regards,

Terry O'Connor

From:

giuslar

To:

Terry O'Connor1/Ireland/IBM@IBMIE

Date:

06/06/2012 15:12

Subject:

- Re: Cisco 870 ISDN problem

Home

Re: Cisco 870 ISDN problem

created by Giuseppe Larosa in WAN, Routing and Switching - View the full

discussion

Hello T.conner

yes I have seen the command reference

however, the suggestion to limit to one B channel each dialer interface

might be helpful

see

dialer max-call 1

http://www.cisco.com/en/US/docs/ios/dial/command/reference/dia_d1.html#wp1013853

to be put in each dialer interface configuration to allow space for the

second call

Hope to help

Giuseppe

Reply to this message by going to Home

Start a new discussion in WAN, Routing and Switching at Home

New Member

Re: Cisco 870 ISDN problem

OK - still no joy - dialer load threshold & dialer max-calls entered ...

would the access list be an issue here ?

Regards,

Terry O'Connor

Hi,

OK - I will change both Dialers to be in the same dialer pool (pool 2).

Also, do you think I need to configure the original Dialer3 and new

Dialer99 with both these commands?

dialer load-threshold 255

dialer max-call 1

Regards,

Terry O'Connor

From:

giuslar

To:

Terry O'Connor1/Ireland/IBM@IBMIE

Date:

06/06/2012 15:12

Subject:

- Re: Cisco 870 ISDN problem

Home

Re: Cisco 870 ISDN problem

created by Giuseppe Larosa in WAN, Routing and Switching - View the full

discussion

Hello T.conner

yes I have seen the command reference

however, the suggestion to limit to one B channel each dialer interface

might be helpful

see

dialer max-call 1

http://www.cisco.com/en/US/docs/ios/dial/command/reference/dia_d1.html#wp1013853

to be put in each dialer interface configuration to allow space for the

second call

Hope to help

Giuseppe

Reply to this message by going to Home

Start a new discussion in WAN, Routing and Switching at Home

New Member

Re: Cisco 870 ISDN problem

Here is the ISDN debug after I add the new Dialer interface. The HQ site

attempts connection on the original Dialer3 but fails;

Hall of Fame Super Silver

Cisco 870 ISDN problem

Hello t.oconnor,

I don't see the debug output use the attach file option to attach a txt file with the debug output.

In any case the dialer list have to be more specific now, as you want to dial to new remote site only when traffic to remote site IP subnet 192.168.200.0 is present.

access-list 102 permit ip any 192.168.200.0 0.0.0.255

dialer-list 2 protocol ip 102

There is a way to invoke an IP extended access-list like in the example above (check the syntax I have written on the fly)

For the other site you can invoke an ACL that is made in the following manner

access-list 101 deny ip any 192.168.200.0 0.0.0.255

access-lit 101 permit ip any any

Notice that in this way whatever packet your router has to send it will dial. So you may need to tune this.

Hope to help

Giuseppe

New Member

Cisco 870 ISDN problem

I have attached the ISDn debug. I understand I will need to add the new subnet to the access list;  however, the problem is that once the new Dialer99 is added to the  config the HO router cannot access Site-BB (using Dialer3). I need to  have this working as normal before testing access from the New-site  (using Dialer99).

Hall of Fame Super Silver

Re: Cisco 870 ISDN problem

Hello t.connor,

from ISDN debug output when both dialer interfaces are configured the router rejects the incoming call with error

>> Cause i = 0x8095 - Call rejected

the following document describes the ISDN error codes that appear in the output of debug isdn q931

http://www.cisco.com/en/US/tech/tk801/tk379/technologies_tech_note09186a008012e95f.shtml

The first byte (most significant) after 0x indicates the point in the       circuit path where the disconnect cause code appears

80—the router

The next byte (9F in the sample output) that follows the cause code       origination point byte is the Disconnect Cause Code

85

Misdialled trunk prefix.

The remote number you dialed is not reachable.

Check the number you dial. Verify if you need any prefixes to                 access the network. For example, you need to dial 9 for outbound calls through                 a PBX. Contact your telco/PBX administrator for details.

The problem is that the router is not able to bind a BRI channel when both dialer interfaces are configured and enabled.

Edit:

your configuration looks like incomplete it is good for calling out not for receiving.

i think you would need some

dialer map

command in order to discriminate incoming calls on the two dialer interfaces

I remember I have used dialer map commands on receiving side in interface dialer.

The command is also useful when you want to call different destinations with a single dialer interface.

see

http://www.cisco.com/en/US/docs/ios/dial/command/reference/dia_d1.html#wp1013440

Hope to help

Giuseppe

Hall of Fame Super Silver

Cisco 870 ISDN problem

Hello,

yes dialer map ip commands on ISDN Hub router should be the way to go

Router(config-if)# dialer map protocol  next-hop-address name hostname

For any host calling in to the local router or access server, maps its  host name (case-sensitive) to the next hop address used to reach it.

Repeat this step for each host calling in to this interface.

see

http://www.cisco.com/en/US/docs/ios/dial/configuration/guide/dia_cfg_ddr_hubs_ps6441_TSD_Products_Configuration_Guide_Chapter.html#wp1001105

The problem you face is that the router is not able to understand what dialer interface to use when answering the call when two dialer interfaces are configured and running. This should be the reason for the ISDN error seen in the debug isdn q931 not bindable.

Hope to help

Giuseppe

New Member

Cisco 870 ISDN problem

Hi, Dialer Maps are for "legacy" DDR. I am using Dialer Profiles and cannot configure dialer maps on the Dialer interface.

Hall of Fame Super Silver

Cisco 870 ISDN problem

Hello T.oconnor,

I have used dialer-maps with dialer interfaces in the past it is a way to provide a resolve mechanism to allow the router to decide which dialer should answer the incoming call when multiple interface dialer are defined.

What can tell the router in your configuration what dialer to use when answering an incoming call? This is why you have troubles with two dialer interfaces

In my configuration I needed to map incoming call to a different MPLS VPN based on dialer map VRF aware feature.

I was using C7200 as PE ISDN and these were backup links for MPLS VPN. The C7200 had ISDN E1 and calling CE nodes had BRI interface.

Hope to help

Giuseppe

New Member

Cisco 870 ISDN problem

The following points describe several design factors you should decide on before configuring a DDR link.

  • DDR Implementation: You can use dialer maps (legacy DDR) or dialer   profiles. For more information on the differences between these two   implementations, refer to "Configuring ISDN DDR with Dialer Profiles"  In this configuration we use dialer maps.

  • above fron Cisco

When I am in config mode on interface dialer99 there are no  commands available to configure dialer maps...can you provide an  example?

Building configuration...

Current configuration : 279 bytes

!

interface Dialer99

description ISDN_to_New-site

ip address 10.0.73.99 255.255.255.0

encapsulation ppp

dialer pool 3

pulse-time 0

ppp authentication chap pap callin

ppp chap hostname Site-bb

ppp chap password 0 xxx

ppp pap sent-username Site-bb password 0 xxx

end

Site-bb#

Site-bb#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Site-bb(config)#int d99

Site-bb(config-if)#?

Interface configuration commands:

  access-expression       Build a bridge boolean access expression

  appletalk               Appletalk interface subcommands

  arp                     Set arp type (arpa, probe, snap) or timeout

  autodetect              Autodetect Encapsulations on Serial interface

  bandwidth               Set bandwidth informational parameter

  bridge-group            Transparent bridging interface parameters

  carrier-delay           Specify delay for interface transitions

  cdp                     CDP interface subcommands

  clock                   Configure serial interface clock

  compress                Set serial interface for compression

  cpp                     Combinet Proprietary Protocol

  custom-queue-list       Assign a custom queue list to an interface

  decnet                  Interface DECnet config commands

  default                 Set a command to its defaults

  delay                   Specify interface throughput delay

  description             Interface specific description

  dialer                  Dial-on-demand routing (DDR) commands

  dialer-group            Assign interface to dialer-list

  down-when-looped        Force looped serial interface down

  dxi                     ATM-DXI configuration commands

  encapsulation           Set encapsulation type for an interface

  exit                    Exit from interface configuration mode

  fair-queue              Enable Fair Queuing on an Interface

  full-duplex             Configure full-duplex operational mode

  half-duplex             Configure half-duplex and related commands

  help                    Description of the interactive help system

  hold-queue              Set hold queue depth

  ip                      Interface Internet Protocol config commands

  ipx                     Novell/IPX interface subcommands

  keepalive               Enable keepalive

  lapb                    X.25 Level 2 parameters (Link Access Procedure,

                          Balanced)

  line-power              Provide power on the line.

  llc2                    LLC2 Interface Subcommands

  load-interval           Specify interval for load calculation for an

                          interface

  logging                 Configure logging for interface

  loopback                Configure internal loopback on an interface

  mac-address             Manually set interface MAC address

  max-reserved-bandwidth  Maximum Reservable Bandwidth on an Interface

  mop                     DEC MOP server commands

  mtu                     Set the interface Maximum Transmission Unit (MTU)

  multilink               Configure multilink parameters

  multilink-group         Put interface in a multilink bundle

  netbios                 Use a defined NETBIOS access list or enable

                          name-caching

  network-clock-priority  Configure clock source priority

  no                      Negate a command or set its defaults

  ntp                     Configure NTP

  peer                    Peer parameters for point to point interfaces

  ppp                     Point-to-Point Protocol

  priority-group          Assign a priority group to an interface

  pulse-time              Force DTR low during resets

  random-detect           Enable Weighted Random Early Detection (WRED) on an

                          Interface

  rate-limit              Rate Limit

  serial                  serial interface commands

  service-policy          Configure QoS Service Policy

  shutdown                Shutdown the selected interface

  smds                    Modify SMDS parameters

  smrp                    Simple Multicast Routing Protocol interface

                          subcommands

  snapshot                Configure snapshot support on the interface

  snmp                    Modify SNMP interface parameters

  source                  Get config from another source

  timeout                 Define timeout values for this interface

  transmit-interface      Assign a transmit interface to a receive-only

                          interface

  trunk-group             Configure interface to be in a trunk group

  tx-ring-limit           Configure PA level transmit ring limit

Site-bb(config-if)#dialer ?

  callback-secure        Enable callback security

  called                 Specify called telephone number to be screened

  caller                 Specify calling telephone number to be screened

  enable-timeout         Set length of time an interface stays down before it

                         is available for dialing

  fast-idle              Set idle time before disconnecting line with an

                         unusually high level of contention

  hold-queue             Configure output hold queue

  idle-timeout           Specify idle timeout before disconnecting line

  in-band                Set v.25bis dialing for interface

  load-threshold         Specify threshold for placing additional calls

  max-call               Specify maximum number of calls

  pool                   Specify dialer pool to be used

  redial                 Configure redial for this interface

  remote-name            Configure a remote name

  rotor                  Set outbound rotor order

  snapshot               Enable snapshot address for dialer profile

  string                 Specify telephone number to be passed to DCE device

  vpdn                   Enable vpdn dial

  wait-for-carrier-time  How long the router will wait for carrier

  watch-disable          Time to wait before bringing down watched route link

  watch-group            Assign interface to dialer-watch-list

--More--

Hall of Fame Super Silver

Cisco 870 ISDN problem

Hello T.oconnor,

try to enable

dialer in-band

first,

It is present in my configurations.

Hope to help

Giuseppe

New Member

Re: Cisco 870 ISDN problem

Hi Giuseppe,

http://www.cisco.com/en/US/docs/ios/12_0/dial/command/reference/drspoke.html

LEGACY DDR SPOKES COMMANDS

You must be using Legacy DDR - I cannot use Legacy as I have > 50 sites already configured with Dialer Profiles...

Site-bb(config)#int d1

Site-bb(config-if)#dialer in

Site-bb(config-if)#dialer in-band

%Remove dialer profile config first

Site-bb(config-if)#

      

I am attaching the latest debig from both sites - the "headoffice" and remote "site-bb"; the isdn is tryingf to connect from headoffice - I believe the authentication is failing...

801
Views
0
Helpful
15
Replies
CreatePlease to create content