Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Cisco 877 as a router with /29 IP block

Dear all,

I'm lost on how to get a Cisco 877M-K9 to work with a DSL connection. We have been allocated the network 84.a.b.120/29 and have been given the network 83.x.y.216/30 for routing. The external interface of our cisco is supposed to have the IP 83.x.y.217 and our default gateway i.e. the ISP DSLAM has the IP 83.x.y.218.

If I use a cheap consumer DSL in bridging mode and give my laptop the IP 83.x.y.217 with netmask 255.255.255.252 and let my default gateway be 83.x.y.218, then I can access the internet without a problem. Hence, the line works. The same DSL link also works if I put the cisco in bridging mode, so the problems seems to be getting the IP packets where they belong in routing mode.

Thanks in advance.

- Edvard

The configuration for my Cisco is as follows:

Current configuration : 1205 bytes
!
! Last configuration change at 18:28:18 EET Sat Feb 20 2010
! NVRAM config last updated at 18:29:19 EET Sat Feb 20 2010
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cisco877mk9
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
clock timezone EET 2
clock summer-time EEST recurring
!
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
username ....
!
!
interface ATM0
ip address 83.x.y.217 255.255.255.252
no atm ilmi-keepalive
dsl operating-mode adsl2+ annex M
pvc 0/100
  protocol ip 83.x.y.218 (I've also tried without this line)
  encapsulation aal5snap
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
ip address 84.a.b.121 255.255.255.248
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 83.x.y.218
!
!
!
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
login
!
scheduler max-task-time 5000
end

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Re: Cisco 877 as a router with /29 IP block

First config is preferable.

Most important:

atm route-bridged

4 REPLIES
Community Member

Re: Cisco 877 as a router with /29 IP block

I should probably add the following:

1. I can ping 84.a.b.121 by attaching my laptop to one of the LAN ports.

2. I can ping 83.x.y.217 form the LAN

3. I CAN'T ping 83.x.y.217 from the IOS console (strange because 2 works)

4. I CAN'T ping 83.x.y.218 from either IOS console or LAN.

#sh int atm0
ATM0 is up, line protocol is up
  Hardware is MPC ATMSAR (with Alcatel ADSL Module), address is 0026.cb25.31ca (
bia 0026.cb25.31ca)
  Description: 24M/3M adsl2+M, IPv4andIPv6
  Internet address is 83.x.y.217/30
  MTU 4470 bytes, sub MTU 4470, BW 2087 Kbit/sec, DLY 170 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ATM, loopback not set
  Keepalive not supported
  Encapsulation(s): AAL5
  10 maximum active VCs, 1024 VCs per VP, 1 current VCCs
  VC Auto Creation Disabled.
  VC idle disconnect time: 300 seconds
  Last input never, output 01:19:34, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: Per VC Queueing
  5 minute input rate 1000 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     40455 packets input, 3534560 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     2716 packets output, 86912 bytes, 0 underruns
     0 output errors, 0 collisions, 46 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out

Community Member

Re: Cisco 877 as a router with /29 IP block

No ideas yet? Any help would be appreciated as the site this router is for is currently without connectivity. I was also wondering why most configurations use something along the lines of:

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode adsl2+ annex M

!

interface ATM0.1  point-to-point

ip address 83.x.y.217 255.255.255.252

pvc 0/100

  protocol ip 83.x.y.218

  encapsulation aal5snap

instead of just:


interface ATM0
ip address 83.x.y.217 255.255.255.252
no atm  ilmi-keepalive
dsl operating-mode adsl2+ annex M
pvc 0/100
   protocol ip 83.x.y.218
   encapsulation aal5snap

What's the point of having this ATM0.1 point-to-point interface if you only have one ATM link from your router? Are you supposed to configure the router this way without specifying the IP address information for the ATM0 interface itself? I haven't tried the above configuration with the router yet (I don't have physical access to it).

I would appreciate any input on this.

Hall of Fame Super Gold

Re: Cisco 877 as a router with /29 IP block

First config is preferable.

Most important:

atm route-bridged

Community Member

Re: Cisco 877 as a router with /29 IP block

So where should I put this config option? Under ATM0? Do you refer with "first config" to the original config in my first post or the first of the two options in my previous post?

Anyway thanks for the help. I'll try that tomorrow.

698
Views
0
Helpful
4
Replies
CreatePlease to create content