Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 877, Cisco 7960, Sipgate.co.uk - Not working

Hello All,

As you can probably tell from the title i have a Cisco 877 connected to my ISP with two static addresses and have hanging of that a Cisco 7960 phone configured to connected directly to a VOIP provider sipgate.co.uk.

I have configured the phone no problem and have the SIP firmware reloaded but no matter what i do the phone is unable to make or recive calls saying Reorder.

Now i am at the point where i am unsure as to whether the config error is with the phone itself or indeed the router config, so please find below the configs of each and if anyone can help it would be greatly appreciated.

NOTE: I have confirmed the SIP account functions using a Softphone, however it did have a STUN setting.

[running-config-c877]


Current configuration : 11430 bytes
!
version 15.1
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service internal
service sequence-numbers
!
hostname GLA1-GW01
!
boot-start-marker
boot-end-marker
!
!
logging buffered 51200
logging console critical
enable secret 5 $1$419I$iXFzf.y9YpWB7lXAmjCE/.
enable password 7 052A0A1F294D185D40
!
aaa new-model
!
!
aaa authentication login local_authen local
aaa authorization exec local_author local
!
!
!
!
!
aaa session-id common
clock timezone London 0 0
clock summer-time London date Mar 30 2003 1:00 Oct 26 2003 2:00
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-431638806
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-431638806
revocation-check none
rsakeypair TP-self-signed-431638806
!
!
crypto pki certificate chain TP-self-signed-431638806
certificate self-signed 01
  30820229 30820192 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 34333136 33383830 36301E17 0D303230 33303230 36353732
  355A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
  532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3433 31363338
  38303630 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
  DA064A56 B7AA0784 5D88B25C 1C6E92A0 EC1EB10F 9D840839 7DA9261B 27F571C7
  663D2247 74BF4554 0560A8A9 BF53EF31 1587C741 2F577C37 309EB1F1 6131F835
  29BC083B 0217F56C 529C1058 97BA556E 0B01CB3B 6D35C5B3 AE802CA1 E4DDA324
  B50E1033 FA339B79 3715620C 9EFAF6B5 0721E421 DA6A89EB 8E03FD0A 648BC7AB
  02030100 01A35330 51300F06 03551D13 0101FF04 05300301 01FF301F 0603551D
  23041830 168014FD E623F19C 30270220 9C5474B3 C7B8570C BAAAE530 1D060355
  1D0E0416 0414FDE6 23F19C30 2702209C 5474B3C7 B8570CBA AAE5300D 06092A86
  4886F70D 01010505 00038181 00A96727 0A9A26A1 C75CBF84 41E185EF 91F6817B
  CD1EBB33 F1DB8397 DD645EB2 72592797 786FF30F AE4B1B63 01322790 63CFE9AF
  11C4EFA7 04032B32 07684313 E3176F12 E2F1CC48 7AD23890 ADCFA5C4 A22DFA00
  B29ED396 9FFE8522 3E89A118 19BCF28B 10ADF4E9 8B4F9C2C 9E271B70 79944C92
  101BA87C 5D902824 692826AB 80
   quit
dot11 syslog
no ip source-route
ip dhcp excluded-address 192.168.75.1 192.168.75.99
ip dhcp excluded-address 192.168.75.201 192.168.75.254
!
ip dhcp pool Guestnet
import all
network 192.168.75.0 255.255.255.0
domain-name guestnet.local
dns-server 192.168.75.1
!
!
ip port-map user-rdp port tcp 3389 description Remote Desktop
!
ip cef
ip inspect WAAS flush-timeout 10
no ip bootp server
ip domain name dns
ip name-server ip2
ip name-server ip1
!
!
parameter-map type regex ccp-regex-nonascii
pattern [^\x00-\x80]

parameter-map type protocol-info yahoo-servers
server name scs.msg.yahoo.com
server name scsa.msg.yahoo.com
server name scsb.msg.yahoo.com
server name scsc.msg.yahoo.com
server name scsd.msg.yahoo.com
server name cs16.msg.dcn.yahoo.com
server name cs19.msg.dcn.yahoo.com
server name cs42.msg.dcn.yahoo.com
server name cs53.msg.dcn.yahoo.com
server name cs54.msg.dcn.yahoo.com
server name ads1.vip.scd.yahoo.com
server name radio1.launch.vip.dal.yahoo.com
server name in1.msg.vip.re2.yahoo.com
server name data1.my.vip.sc5.yahoo.com
server name address1.pim.vip.mud.yahoo.com
server name edit.messenger.yahoo.com
server name messenger.yahoo.com
server name http.pager.yahoo.com
server name privacy.yahoo.com
server name csa.yahoo.com
server name csb.yahoo.com
server name csc.yahoo.com

parameter-map type protocol-info aol-servers
server name login.oscar.aol.com
server name toc.oscar.aol.com
server name oam-d09a.blue.aol.com
parameter-map type protocol-info msn-servers
server name messenger.hotmail.com
server name gateway.messenger.hotmail.com
server name webmessenger.msn.com
!
!
username Administrator password 7 153A5A1F063F7A28291B
!
!
ip tcp synwait-time 10
ip ssh time-out 60
ip ssh authentication-retries 2
!
class-map type inspect match-any ccp-cls-protocol-im
match protocol ymsgr yahoo-servers
match protocol msnmsgr msn-servers
match protocol aol aol-servers
class-map type inspect match-any ccp-cls-insp-traffic
match protocol dns
match protocol ftp
match protocol https
match protocol icmp
match protocol imap
match protocol pop3
match protocol netshow
match protocol shell
match protocol realmedia
match protocol rtsp
match protocol smtp
match protocol sql-net
match protocol streamworks
match protocol tftp
match protocol vdolive
match protocol tcp
match protocol udp
class-map type inspect match-any SDM_SSH
match access-group name SDM_SSH
class-map type inspect match-any Adepteo
match protocol sip
match protocol tftp
class-map type inspect match-any SDM_HTTPS
match access-group name SDM_HTTPS
class-map type inspect match-any SDM_SHELL
match access-group name SDM_SHELL
!
!
!
!
!
!
!
!
interface Null0
no ip unreachables
!
interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
no atm ilmi-keepalive
dsl operating-mode adsl2+
dsl noise-margin 3
dsl bitswap both
!
interface ATM0.1 point-to-point
no ip redirects
no ip unreachables
no ip proxy-arp
pvc 0/38
encapsulation aal5mux ppp dialer
  dialer pool-member 1
!
!
interface FastEthernet0
switchport mode trunk
no ip address
!
interface FastEthernet1
switchport mode trunk
no ip address
duplex full
speed 100
!
interface FastEthernet2
switchport mode trunk
no ip address
duplex full
speed 100
!
interface FastEthernet3
switchport access vlan 100
no ip address
duplex full
speed 100
!
interface Vlan1
description $FW_INSIDE$
ip address 172.16.0.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly in
!
interface Vlan100
ip address 172.16.100.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Dialer0
description $FW_OUTSIDE$
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip flow egress
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname username
ppp chap password 7 06020A2D584F5B4C53
!
ip forward-protocol nd
ip http server
ip http access-class 1
ip http secure-server
ip flow-top-talkers
top 20
sort-by bytes
!
no ip nat service sip udp port 5060
ip nat pool Mail-Server 172.16.0.20 172.16.0.20 netmask 255.255.255.0
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source static tcp 172.16.0.20 443 interface Dialer0 443
ip nat inside source static tcp 172.16.0.20 25 interface Dialer0 25
ip nat inside source static tcp 172.16.0.20 80 interface Dialer0 80
ip nat inside source static tcp 172.16.0.20 143 interface Dialer0 143
ip nat inside source static tcp 172.16.0.10 3389 interface Dialer0 3389
ip nat inside source static tcp 172.16.0.20 587 interface Dialer0 587
ip nat inside source static tcp 172.16.0.20 110 interface Dialer0 110
ip nat inside source static tcp 172.16.0.111 5060 interface Dialer0 5060
ip nat inside source static udp 172.16.0.111 5060 interface Dialer0 5060
ip nat inside source static tcp 172.16.0.111 5061 interface Dialer0 5061
ip nat inside source static udp 172.16.0.111 5061 interface Dialer0 5061
ip nat inside source static udp 172.16.0.111 5004 interface Dialer0 5004
ip nat inside source static udp 172.16.0.111 10000 interface Dialer0 10000
ip nat inside source static udp 172.16.0.111 3478 interface Dialer0 3478
ip nat inside source static udp 172.16.0.111 8001 interface Dialer0 8001
ip nat inside source static udp 172.16.0.111 8002 interface Dialer0 8002
ip nat inside source static udp 172.16.0.111 8003 interface Dialer0 8003
ip nat inside source static udp 172.16.0.111 8004 interface Dialer0 8004
ip nat inside source static udp 172.16.0.111 8005 interface Dialer0 8005
ip nat inside source static udp 172.16.0.111 8006 interface Dialer0 8006
ip nat inside source static udp 172.16.0.111 8007 interface Dialer0 8007
ip nat inside source static udp 172.16.0.111 8008 interface Dialer0 8008
ip nat inside source static udp 172.16.0.111 8009 interface Dialer0 8009
ip nat inside source static udp 172.16.0.111 8010 interface Dialer0 8010
ip nat inside source static udp 172.16.0.111 8011 interface Dialer0 8011
ip nat inside source static udp 172.16.0.111 8012 interface Dialer0 8012
ip nat inside source static udp 172.16.0.111 8013 interface Dialer0 8013
ip nat inside source static udp 172.16.0.111 8014 interface Dialer0 8014
ip nat inside source static udp 172.16.0.111 8015 interface Dialer0 8015
ip nat inside source static udp 172.16.0.111 8016 interface Dialer0 8016
ip nat inside source static udp 172.16.0.111 8017 interface Dialer0 8017
ip nat inside source static udp 172.16.0.111 8018 interface Dialer0 8018
ip nat inside source static udp 172.16.0.111 8019 interface Dialer0 8019
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 172.0.0.0 255.0.0.0 172.16.0.3 permanent
!
ip access-list extended Exchange
remark CCP_ACL Category=128
permit ip any host 172.16.0.20
ip access-list extended Inbound-Rdp
remark CCP_ACL Category=128
permit ip any host 172.16.0.20
ip access-list extended SDM_HTTPS
remark CCP_ACL Category=1
permit tcp any any eq 443
ip access-list extended SDM_SHELL
remark CCP_ACL Category=1
permit tcp any any eq cmd
ip access-list extended SDM_SSH
remark CCP_ACL Category=1
permit tcp any any eq 22
ip access-list extended SMTP-Inbound
remark Inbound SMTP Email Traffic
remark CCP_ACL Category=2
permit tcp any eq smtp host 172.16.0.20 eq smtp
!
logging esm config
logging trap debugging
access-list 1 remark CCP_ACL Category=3
access-list 1 permit 172.16.0.0 0.0.0.255
dialer-list 1 protocol ip permit
!
!
!
!
!
!
control-plane
!
banner login ^CRESTRICTED ACCESS - ACCESS LOGGED : ^C
!
line con 0
no modem enable
transport output telnet
line aux 0
transport output telnet
line vty 0 4
password 7 0523571C23591F05182D
authorization exec local_author
login authentication local_authen
transport input telnet ssh
!
scheduler allocate 4000 1000
scheduler interval 500
ntp server 194.35.252.7 prefer source Dialer0
ntp server 81.168.77.149 source Dialer0
ntp server 130.159.248.123 source Dialer0
end

Now for the phone configuration

[SIPDefault.cnf]

image_version : "P0S3-8-12-00"
network_media_type : Auto
network_port2_type : Hub/Switch

proxy1_address: "sipgate.co.uk"
proxy2_address: ""
proxy3_address: ""
proxy4_address: ""
proxy5_address: ""
proxy6_address: ""

proxy1_port: 5060
proxy2_port: 5060
proxy3_port: 5060
proxy4_port: 5060
proxy5_port: 5060
proxy6_port: 5060

proxy_register: 1
timer_register_expires: 300

preferred_codec: g711ulaw
tos_media: 5
dial_template: dialplan
tftp_cfg_dir: ""
sip_retx : 10
sip_invite_retx : 6
sip_max_forwards : 70
rfc_2543_hold : 0
timer_t1 : 500
timer_t2 : 4000
timer_invite_expires : 180
timer_register_expires : 3600

sntp_mode: "directedbroadcast"
sntp_server: "uk.pool.ntp.org"
time_zone: "GMT"
time_format_24hr: "1"
dst_offset: "1"
dst_start_month: "March"
dst_start_day: ""
dst_start_day_of_week: "Sunday"
dst_start_week_of_month: "8"
dst_start_time: "2"
dst_stop_month: "October"
dst_stop_day: ""
dst_stop_day_of_week: "Sunday"
dst_stop_week_of_month: "8"
dst_stop_time: "2"
dst_auto_adjust: "1"

cnf_join_enable: 1
call_hold_ringback: 1
semi_attended_transfer: 0
call_waiting: 1
dnd_control: 0
callerid_blocking: 0
anonymous_call_block: 0
remote_party_id: 0
call_stats : 1
nat_enable: 1
nat_address: 81.168.47.75
nat_received_processing: 1
voip_control_port : 5061
start_media_port : 16384
end_media_port : 32766

http_proxy_addr : UNPROVISIONED
http_proxy_port : 80

outbound_proxy: "sipgate.co.uk"
outbound_proxy_port: 5060

messages_uri: "*1"
#services_url: "http://example.domain.ext/services/menu.xml"
#directory_url: "http://example.domain.ext/services/directory.php"
#logo_url: "http://example.domain.ext/services/displayimage.bmp"

[SIPMACADDRESS.cnf]

line1_name: "0141xxxxxxx"
line1_shortname: "0141xxxxxxx"
line1_displayname: "0141xxxxxxx"
line1_authname: "14xxxxxx"
line1_password: "RAxxxxx"

outbound_proxy: "sipgate.co.uk"
outbound_proxy_port: 5082

voip_control_port: 5060
start_media_port: 16348
end_media_port: 20134
nat_received_processing: 1

phone_label: "IP Phone  "
phone_password: "ciscocisco"
phone_prompt: "Cisco 7960"
telnet_level: 2
enable_vad: 0
network_media_type: "auto"
user_info: phone

I hope that is enough information to get started but if it isnt please just ask and i will be more than happy to provide any info you need.

Thanks in advance

Andrew Vint

1634
Views
0
Helpful
0
Replies