Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 877-k9 ADSL Router configuration and Upgrade of IOS to 15

Dear All,

Below is the configuration which connects (PPP light comes) but no browsing.

01.Please corret me if any mistake in configuration (pls reply with which command to remove or which to add)

also the ios version is old  ( version version 12.4 )

or some bugs or some hardware issue?

02. I beleive if the configuration below is correct then if i upgrade the ios to latest stable version then i hope things

will work fine? Which stable latest version is feasible? please advise.Also will cisco give it FREE of cost?

03.Is it true that if the router that we bought could be refurbished and then issue could be with hardware or software etc?

04.How should i Check that router is not refurbished?

05.The same below configuration is working fine on other router of same model/same ios , if  I not wrong.

Thanx to all in advance.Happy new year!

User Access Verification

Username: khan

Password:

shukry#show ip int br

Interface                  IP-Address      OK? Method Status                Protocol

ATM0                       unassigned      YES NVRAM  up                    up

ATM0.1                     unassigned      YES unset  up                    up

Dialer0                    2.88.225.150    YES IPCP   up                    up

FastEthernet0              unassigned      YES unset  up                    up

FastEthernet1              unassigned      YES unset  up                    up

FastEthernet2              unassigned      YES unset  up                    down

FastEthernet3              unassigned      YES unset  up                    up

NVI0                       unassigned      YES unset  administratively down down

Virtual-Access1            unassigned      YES unset  up                    up

Vlan1                      192.168.1.254   YES NVRAM  up                    up

shukry#show run

Building configuration...

Current configuration : 3770 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname shukry

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

!

no aaa new-model

!

crypto pki trustpoint TP-self-signed-985750308

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-985750308

revocation-check none

rsakeypair TP-self-signed-985750308

!

dot11 syslog

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.10.1

ip dhcp excluded-address 192.168.1.1

ip dhcp excluded-address 192.168.1.254

!

ip dhcp pool khan

   import all

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.254

   dns-server 8.8.8.8 8.8.4.4

   domain-name wr

   lease 0 2

!

!

no ip domain lookup

ip domain name yourdomain.com

!

!

!

username khan privilege 15 secret xxxxxxxxxxxx

!

!

archive

log config

  hidekeys

!

!

!

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

pvc 0/35

  pppoe-client dial-pool-number 1

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$

ip address 192.168.1.254 255.255.255.0

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

!

interface Dialer0

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap chap callin

ppp chap hostname user@16m.saudi.net.sa

ppp chap password 1234

ppp pap sent-username user@16m.saudi.net.sa password 1234

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer0

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source list 1 interface Dialer0 overload

!

access-list 1 permit 192.168.1.0 0.0.0.255

no cdp run

!

!

!

control-plane

!

!

line con 0

privilege level 15

login local

no modem enable

line aux 0

line vty 0 4

access-class 23 in

privilege level 15

login local

transport input telnet ssh

!

scheduler max-task-time 5000

end

shukry#

  • WAN Routing and Switching
3 REPLIES
Hall of Fame Super Gold

Cisco 877-k9 ADSL Router configuration and Upgrade of IOS to 1

I won't recommend what version you can use.   My 871 has 130 DRAM and 24 Flash and it's running 15.1(4)M1.

New Member

Cisco 877-k9 ADSL Router configuration and Upgrade of IOS to 1

thnx alot regarding version information. What about configuration?Any mistake in it?

thanx again

Cisco 877-k9 ADSL Router configuration and Upgrade of IOS to 1

hi,

your config looks fine.

are you able to ping 192.168.1.254 and 8.8.8.8 from a PC connected on your 877 FE port?

1421
Views
0
Helpful
3
Replies
This widget could not be displayed.