Cisco Support Community
Community Member

Cisco 877 PPPoE Connection Assistance


I typically only configure ASA5505s or RV042s, but I currently have to fix an issue with a Cisco 877.

When it tries to connect I get. "Di1: No free dialer - starting fast idle timer"

Here is the current config: (Changes made only to protect security)

Thanks in advance!


version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
hostname myhostname
no logging buffered
enable secret 5 *****
no aaa new-model
resource policy
clock timezone EST -5
clock summer-time EDT recurring
ip subnet-zero
no ip source-route
ip cef
ip tcp synwait-time 10
no ip bootp server
no ip domain lookup
ip name-server
ip name-server
vpdn enable
vpdn-group 2
! Default PPTP VPDN group
  protocol pptp
  virtual-template 1
async-bootp dns-server
crypto pki trustpoint TP-self-signed-4264ss83450
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-4ss4083450
revocation-check none
rsakeypair TP-self-signed-426s083450
crypto pki certificate chain TP-self-signed-426ss3450
certificate self-signed 01
  30820246 308201AF A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 34323634 30383334 3530301E 170D3032 30333031 30303234
  34335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D34 32363430
  38333435 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  810095B8 1703BE06 82444E29 9A1AD7CB 2EDE1D43 2C2601EB C5F065C1 FFEE60B7
  DDEF9D84 941C1BDE 6A622A2A E536C7EF B99AE5B1 DA0823E1 4B152F07 343CD8F3
  5627721D DFF65088 FEF998B6 BBC7B58F EB5B177C 9BA314B5 95E41A9E 677C1EE2
  6FA218A9 93B74A9D 883510C8 8DEB0625 125AF3F8 DA6FC52C FF2C5B8B 3C615B72
  DE9F0203 010001A3 6E306C30 0F060355 1D1F0101 FF040530 030101FF 30190603
  551D1104 12301082 0E616361 70756C63 6F706F6F 6C732E30 1F060355 1D230418
  30168014 4836DCEE AFE63EB5 77E65870 221B6B1F A60CE011 301D0603 551D0E04
  16041448 36DCEEAF E63EB577 E6587022 1B6B1FA6 0CE0e130 0D06092A 864886F7
  0D010104 05000381 81001463 BC986F45 3FA4131C 56E4DDEE 35FC0C5C 484B3358
  8046FA6F 9F59C186 B8weF10A FA99F00C 6618690C 65A55D9E C1Dws3123 8430753A
  1AAF996B F9F94A8D 579FF772 2411A2AB 715BAD13 2AC33F1C 9CCDF002 7947C513
  5C65E99D 1EC6892C 927FEB0C 63F9FCFA C0CF1B31 B2641B88 0F258DD4 56AEDCBF
7B8085BF 7B09A7F3 A69C
username *****secret 5 *****
interface Loopback0
ip address
interface ATM0
mtu 1492
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
no atm ilmi-keepalive
atm ilmi-pvc-discovery
pvc 0/35
  pppoe-client dial-pool-number 1
dsl operating-mode auto
dsl enable-training-log
interface FastEthernet0
interface FastEthernet1
interface FastEthernet2
interface FastEthernet3
interface Virtual-Template1
ip unnumbered Loopback0
peer default ip address pool pptp
ppp encrypt mppe 128
ppp authentication pap chap ms-chap
interface Vlan1
description DMZ ports
ip address 64.XX.XX.XX secondary
ip address
ip access-group 110 in
no ip redirects
no ip unreachables
no ip proxy-arp
ip accounting output-packets
ip nat inside
ip virtual-reassembly
ip route-cache flow
ip tcp adjust-mss 1452
hold-queue 100 out
interface Dialer1
ip address 216.XX.XX.XX
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip route-cache flow
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication pap callin
ppp pap sent-username ************* password 7 ******
ip local pool pptp
ip classless
ip route Dialer1
no ip http server
ip http access-class 1
ip http authentication local
ip http secure-server
ip nat inside source list 101 interface Dialer1 overload
ip nat inside source static tcp 110 216.XX.XX.XX110 extendable
ip nat inside source static tcp 443 216.XX.XX.XX 443 extendable
ip nat inside source static tcp 3389 216.XX.XX.XX 3389 extendable
ip nat inside source static tcp 4123 216.XX.XX.XX4123 extendable
ip nat inside source static udp 4123 216.XX.XX.XX 4123 extendable
ip access-list extended addr-pool
ip access-list extended protocol
ip access-list extended service
access-list 1 remark HTTP Access-class list
access-list 1 remark SDM_ACL Category=1
access-list 1 permit 209.XX.XX.0
access-list 1 permit
access-list 1 deny   any
access-list 98 permit 199.XX.XX.XX
access-list 98 permit 209.XX.XX.0
access-list 98 permit
access-list 98 permit 64.XX.XX.XX
access-list 98 deny   any log
access-list 101 permit ip any
access-list 110 permit tcp host eq smtp any
access-list 110 deny   tcp eq smtp any
access-list 110 permit ip any
access-list 110 permit ip 64.XX.XX.XX any
dialer-list 1 protocol ip permit
no cdp run
banner login ^CCCCUnauthorized Access Prohibited

Unauthorized access to any program or data on this system is not
permitted, and any unauthorized access beyond this point may lead
to prosecution. This system may be monitored at any time for
operational reasons, therefore, if you are not an authorized user,
line con 0
logging synchronous
no modem enable
transport output telnet
stopbits 1
line aux 0
transport output telnet
stopbits 1
line vty 0 4
access-class 98 in
privilege level 15
password 7 03085E1F0B0A2842
logging synchronous
login local
transport input telnet
transport output all
scheduler max-task-time 5000
scheduler allocate 4000 1000
scheduler interval 500
sntp server 199.XX.XX.XX

Community Member

Cisco 877 PPPoE Connection Assistance

Could you try and create a new dialer interface and bind it to your dialing profile and test it out.

the below arcticle also is gold:

CreatePlease to create content