Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 877 pure bridge mode

I need to configure my Cisco877 just in bridge mode between ATM interface and interface VLAN1 so my PC would get public ISP IP address. I think this is done just setting my windows xp network interface for DHCP client. Could anyone send me or post this configuration file?

Thanks a lot!!!

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Cisco 877 pure bridge mode

Hello Adis,

it should take an ip address by DHCP to give your PC a chance to telnet successfully.

You have ip routing disabled so the router can behave just as a PC.

Hope to help

Giuseppe

10 REPLIES
Hall of Fame Super Silver

Re: Cisco 877 pure bridge mode

Hello Adis,

use the following

this mode of operation is called RFC 1483 bridged mode

http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a008071a816.shtml

adapt the configuration to your needs use the document as a template

Hope to help

Giuseppe

New Member

Re: Cisco 877 pure bridge mode

I tried this last night, buy it did not work. I was waiting for my windows xp network interface card to get the ISP IP address but nothing happened.

May be I was too tired to see the solution.

I will try your configuration one more time this evening.

Thanks a lot again!

Seba

Hall of Fame Super Silver

Re: Cisco 877 pure bridge mode

Hello Seba,

check what the ISP is giving you: if it is PPPoE you need a PPPoE client on your PC instead of DHCP

note: I've linked a document in the cisco web site

Hope to help

Giuseppe

New Member

Re: Cisco 877 pure bridge mode

No, it is not PPPoE o PPPoA.

It is just Ethernet.

Is it OK???

Seba

Hall of Fame Super Silver

Re: Cisco 877 pure bridge mode

Hello Seba,

>> No, it is not PPPoE o PPPoA.

then you need DHCP on the PC indeed

the configuration is fine because bridging doesn't care of upper layer protocols

Hope to help

Giuseppe

New Member

Re: Cisco 877 pure bridge mode

OK. I will try it this afternoon.

Thanks!

New Member

Re: Cisco 877 pure bridge mode

It works!

I tried this configuration this afternoon and it worked. I also defined DHCP client on my PC network card.

You can have a look at it:

Router#sh running-config

Building configuration...

Current configuration : 903 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

!

!

dot11 syslog

ip source-route

no ip routing

!

!

no ip cef

!

!

!

!

!

!

!

archive

log config

hidekeys

!

!

!

!

!

interface ATM0

no ip address

no ip route-cache

no atm ilmi-keepalive

pvc x/x

encapsulation x

!

dsl operating-mode x

bridge-group 1

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

no ip address

no ip route-cache

bridge-group 1

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

!

!

!

!

control-plane

!

bridge 1 protocol ieee

!

line con 0

no modem enable

line aux 0

line vty 0 4

login

!

scheduler max-task-time 5000

end

Router#

Thanks a lot for your help!

Adis

Hall of Fame Super Silver

Re: Cisco 877 pure bridge mode

Hello Adis,

nice news it worked

be aware that in this way you have configured the router as a bridge and you can access it only via console.

Hope to help

Giuseppe

New Member

Re: Cisco 877 pure bridge mode

Yes, I know that.

In that case, is it enough to add an IP address to VLAN1?

Thanks!

Hall of Fame Super Silver

Re: Cisco 877 pure bridge mode

Hello Adis,

it should take an ip address by DHCP to give your PC a chance to telnet successfully.

You have ip routing disabled so the router can behave just as a PC.

Hope to help

Giuseppe

2540
Views
0
Helpful
10
Replies