Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 877W and DSL

I am new to the 877 routers and I am having a really hard time getting an IP address from SBC ("Sticky IP"). I have tried changing the DSL operating-mode but to no avail. I have uploaded a copy of my current config, as I have it set up. I can bring my ATM interfaces up but am unable to "grab" my IP. Any thoughts greatly appreciated. --Josh--

1 REPLY
VIP Purple

Re: Cisco 877W and DSL

Hello,

try to add the changes marked with an arrow (-->), try the 'dialer-group 1' on the dialer interface first, if that doesn't help, try the ' ip address dhcp' command. By the way, did you get that PVC from your provider ? Usually, PVC 0/38, or 0/35, are being used, you might want to try those as well if the above doesn't work:

Using 3465 out of 131072 bytes

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname #######################3

!

boot-start-marker

boot-end-marker

!

enable secret 5 #################################

enable password #################################

!

clock timezone PCTime -8

no aaa new-model

ip subnet-zero

no ip source-route

ip cef

ip dhcp excluded-address ###########################

ip dhcp excluded-address ###########################

!

ip dhcp pool pool1

import all

network ###########################

dns-server ###########################

default-router ###########################

domain-name ###########################

netbios-name-server ###########################

lease 1 1

!

!

no ftp-server write-enable

password encryption aes

!

!

!

!

!

crypto isakmp policy 1

encr aes

hash md5

authentication pre-share

crypto isakmp key ########################### address ###########################

!

!

crypto ipsec transform-set aes128 esp-aes esp-md5-hmac

!

crypto map acl_110 1 ipsec-isakmp

description mymap

set peer ###########################

set transform-set aes128

match address acl_111

!

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode ansi-dmt

!

interface ATM0.1 point-to-point

pvc 19/59

pppoe-client dial-pool-number 1

!

!

interface FastEthernet0

no ip address

no cdp enable

!

interface FastEthernet1

no ip address

no cdp enable

!

interface FastEthernet2

no ip address

no cdp enable

!

interface FastEthernet3

no ip address

no cdp enable

!

interface Dot11Radio0

no ip address

shutdown

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0

54.0

no cdp enable

!

interface Vlan1

description ###########################

ip address ###########################

no ip redirects

no ip unreachables

no ip proxy-arp

ip virtual-reassembly

ip route-cache flow

ip tcp adjust-mss 1452

!

interface Dialer0

ip address negotiated

no cdp enable

!

interface Dialer1

ip address negotiated

--> ip address DHCP (2)

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

--> dialer-group 1 (1)

no cdp enable

ppp pap sent-username ########################### password 0 ###########################

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 600 life 86400 requests 10000

ip nat inside source list 1 interface Dialer1 overload

!

ip access-list extended acl_111

permit ip ###########################

permit ip ###########################

deny ip any any

!

access-list 1 remark INSIDE_IF=VLAN1

access-list 1 permit ###########################

access-list 103 deny ###########################

access-list 103 permit ###########################

access-list 103 deny ###########################

dialer-list 1 protocol ip permit

no cdp run

!

control-plane

!

banner login ###########################

line con 0

login local

no modem enable

transport preferred all

transport output telnet

line aux 0

login local

transport preferred all

transport output telnet

line vty 0 4

privilege level 15

login local

transport preferred all

transport input telnet ssh

transport output all

!

scheduler max-task-time 5000

scheduler allocate 4000 1000

scheduler interval 500

end

99
Views
0
Helpful
1
Replies