Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Cisco 877W - bind IP's to VLAN or BVI interfaces?

I am currently working on a new Teleworker configuration and upgrading my field routers from 831/837 models to 871W/877W models.

I currently have setup three VLANs, the default / native (VLAN1) for Data, VLAN2 for Voice, and VLAN3 for Untrusted traffic (Only traffic to internet that bypasses DMVPN corporate resources).

I am currious if anyone can speak to a best practice or explain why it would be better to bind IP's to the BVI interfaces or VLAN interfaces.

Currently, I have a similar setup.

interface FastEthernet0

switchport mode trunk

switchport voice vlan 2

switchport priority extend trust

!

interface FastEthernet1

switchport access vlan 3

!

interface FastEthernet2

switchport access vlan 3

!

interface FastEthernet3

switchport access vlan 3

interface Vlan1

no ip address

bridge-group 1

!

interface Vlan2

ip address 10.50.25.129 255.255.255.128

ip nat inside

ip virtual-reassembly

!

interface Vlan3

no ip address

bridge-group 2

bridge-group 2 spanning-disabled

interface BVI1

ip address 10.50.25.1 255.255.255.128

ip access-group Inside_Inbound in

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

ip route-cache flow

ip tcp adjust-mss 1452

!

interface BVI2

ip address 192.168.100.1 255.255.255.0

ip access-group Untrusted_Inbound in

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

ip route-cache flow

ip tcp adjust-mss 1452

bridge 1 protocol ieee

bridge 1 route ip

bridge 2 protocol ieee

bridge 2 route ip

Is it there any reason to bind all of the IP's to VLAN vs. BVI interfaces? I would like to stay consistant across the board.

-Matthew

1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Re: Cisco 877W - bind IP's to VLAN or BVI interfaces?

Hi,

When using IRB-type configurations, it is more conventional to put the IP on the BVI. However, your situation is a bit different. Do you experience any problems at all with the IP on the VLAn interface. If not, then just go ahead and do that.... If both work, there is no real issue in using one over the other.

Hope that helps - pls rate the post if it does.

Paresh

3 REPLIES
Purple

Re: Cisco 877W - bind IP's to VLAN or BVI interfaces?

Hi Matthew,

The only reason I would use BVIs instead of VLAN interfaces is when I was also bridging traffic on non-switched ports. For example, if you were bridging some of the traffic coming from your switch ports over to your ATM (DSL) port then you would need to configure a bridge-group. If you are not, you can just use VLAN interfaces.

Hope that helps - pls rate posts that help.

Regards,

Paresh

New Member

Re: Cisco 877W - bind IP's to VLAN or BVI interfaces?

I think what I am more trying to figure out is where it's best to place the IP addresses, and if it matters. In this case, I need to use bridging for the two wireless networks I have created and am briding them onto VLAN's. I am just going for consistancy and ease of configuration. I would rather put all the IP's on the VLAN's or on the BVI's, for consistancies sake, unless there was a specific issue on why to use one more then the other.

Does this make sense?

Matt

Purple

Re: Cisco 877W - bind IP's to VLAN or BVI interfaces?

Hi,

When using IRB-type configurations, it is more conventional to put the IP on the BVI. However, your situation is a bit different. Do you experience any problems at all with the IP on the VLAn interface. If not, then just go ahead and do that.... If both work, there is no real issue in using one over the other.

Hope that helps - pls rate the post if it does.

Paresh

2191
Views
0
Helpful
3
Replies
CreatePlease to create content