Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Cisco 877W Router - Line Open, Drops PPP, Will Not Reestablish

I’m having problems with a Cisco 877W router connected to Zen Internet in the United Kingdom; what I see happen is the router boot up, establish a connection (CD light on, PPP light on) and then after a random period of time drop the connection (CD light on, PPP light off) without being able to re-establish a connection.

The router is running Cisco IOS Software, C870 Software (C870-ADVSECURITYK9-M), Version 12.4(24)T5, RELEASE SOFTWARE (fc3). The embedded firmware is 3.0.014_no_bist.bin, however I upgraded it to adsl_alc_20190_4.0.017.bin as it tends to behave with BT ADSL lines somewhat better than the factory installed version.

Just to grab two random examples:

000033: *Nov 11 15:54:33.455 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to up

000034: *Nov 11 15:55:56.378 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to down

And...

000034: *Nov 11 16:34:30.175 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to up

000035: *Nov 11 16:41:31.039 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to down

On the first one, I turned on PPP debugging and the following errors were logged:

000245: *Nov 11 16:08:50.033 UTC: Vi2 PPP: Phase is ESTABLISHING, Passive Open

000246: *Nov 11 16:08:50.033 UTC: Vi2 LCP: State is Listen

000247: *Nov 11 16:08:50.037 UTC: Di0 IPCP: Remove route to 62.xx.yy.zz

000248: *Nov 11 16:08:50.301 UTC: Vi2 PPP: Outbound ip packet dropped

000249: *Nov 11 16:08:51.034 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to down

000250: *Nov 11 16:08:52.050 UTC: Vi2 LCP: Timeout: State Listen

000251: *Nov 11 16:08:52.050 UTC: Vi2 PPP: No remote authentication for call-out

000252: *Nov 11 16:08:52.050 UTC: Vi2 LCP: O CONFREQ [Listen] id 147 len 10

000253: *Nov 11 16:08:52.050 UTC: Vi2 LCP: MagicNumber 0x1C672C6B (0x05061C672C6B)

000254: *Nov 11 16:08:54.066 UTC: Vi2 LCP: Timeout: State REQsent

[repeats]

000497: *Nov 11 16:10:40.466 UTC: Vi2 LCP: Timeout: State REQsent

000498: *Nov 11 16:10:40.466 UTC: Vi2 LCP: O CONFREQ [REQsent] id 171 len 10

000499: *Nov 11 16:10:40.466 UTC: Vi2 LCP: MagicNumber 0x1C68B478 (0x05061C68B478)

000500: *Nov 11 16:10:40.891 UTC: Vi2 PPP: Outbound ip packet dropped

I have an 857W currently running on the line (that works without problem) until I can solve this issue but, in a nutshell, it looks like it drops the connection, keeps the line “up” but will not re-establish PPP. I’m happy that the overall configuration is okay because until it suddenly and randomly drops the line, it behaves as it should but will post the config if it's useful.

Here's what I believe to be the relevant part of the config:

interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
!

interface Vlan1
description $FW_INSIDE$
ip address 192.168.192.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip nat inside
ip virtual-reassembly
zone-member security in-zone
!
interface Dialer0
description $FW_OUTSIDE$
ip address 82.xx.yy.254 255.255.255.248
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip nat outside
ip virtual-reassembly
zone-member security out-zone
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname [zen-hostname]
ppp chap password 7 [zen-password]

ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0 permanent

As I've mentioned, it seems to be quite happy on the 857W currently running on that circuit. As soon as I put the 877W in place, it connects once, drops then refuses to re-connect.

Any pointers?

Regards, Ade.

Everyone's tags (4)
5 REPLIES
New Member

Cisco 877W Router - Line Open, Drops PPP, Will Not Reestablish

Hi Ade,

Seeing something very similar here with an SR520 connected to Zen. Did you ever get a resolution to this problem?

Cheers, Ian.

Hall of Fame Super Gold

Cisco 877W Router - Line Open, Drops PPP, Will Not Reestablish

Post "show dsl interface".

New Member

Re: Cisco 877W Router - Line Open, Drops PPP, Will Not Reestabli

Here it is! I.           

SR520#show dsl interface ATM0
Alcatel 20190 chipset information
                ATU-R (DS)                      ATU-C (US)
Modem Status:    Showtime (DMTDSL_SHOWTIME)
DSL Mode:        ITU G.992.1 (G.DMT) Annex A
ITU STD NUM:     0x03                            0x1
Vendor ID:       'STMI'                          'IFTN'
Vendor Specific: 0x0000                          0x82B1
Vendor Country:  0x0F                            0xB5
Chip ID:         C196 (0)
DFE BOM:         DFE3.0 Annex A (1)
Capacity Used:   100%                            53%
Noise Margin:     5.5 dB                         22.0 dB
Output Power:    19.5 dBm                        12.5 dBm
Attenuation:     46.0 dB                         26.0 dB
FEC ES Errors:    0                               0
ES Errors:        9                               0
SES Errors:       0                               0
LOSES Errors:     0                               0
UES Errors:       0                               0
Defect Status:   None                            None                       
Last Fail Code:  None
Watchdog Counter: 0x77
Watchdog Resets: 0
Selftest Result: 0x00
Subfunction:     0x00
Interrupts:      4128 (0 spurious)
PHY Access Err:  0
Activations:     1
LED Status:      ON
LED On Time:     100
LED Off Time:    100
Init FW:         init_AMR-3.0.014_no_bist.bin
Operation FW:    AMR-3.0.014.bin
FW Source:       embedded
FW Version:      3.0.14

                 Interleave             Fast    Interleave              Fast
Speed (kbps):          6048                0           448                 0
Cells:               188843                0        377867                 0
Reed-Solomon EC:          0                0             0                 0
CRC Errors:              15                0             0                 0
Header Errors:            9                0             0                 0
Total BER:                3405E-10               0E-0
Leakage Average BER:      3405E-10               0E-0
                        ATU-R (DS)      ATU-C (US)
Bitswap:               enabled            enabled
Bitswap success:          0                   0
Bitswap failure:          0                   0

LOM Monitoring : Disabled


DMT Bits Per Bin
000: 0 0 0 0 0 0 2 3 4 6 6 7 7 7 8 7
010: 8 7 8 7 7 7 7 6 6 6 6 6 5 4 4 2
020: 0 B B C C C C C C C C C C B 7 B
030: B B B B B B B B B B B B B B B B
040: 0 B B B A B B B B B 2 A A A A A
050: A A A A A A A A A A A A A A A A
060: A 9 A A A 9 A 9 9 9 9 9 A 9 9 9
070: 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9 9
080: 9 9 9 9 9 0 9 9 9 9 8 9 9 9 8 9
090: 8 0 0 0 0 0 0 0 0 0 0 9 8 8 8 7
0A0: 0 0 5 7 7 6 8 8 8 8 8 7 8 8 8 8
0B0: 8 7 7 7 7 8 8 8 7 8 8 8 6 8 8 7
0C0: 7 7 7 6 5 4 0 0 4 5 5 4 2 2 5 6
0D0: 6 6 3 0 6 6 6 6 6 6 6 5 6 6 6 5
0E0: 6 5 5 5 5 5 5 5 5 5 5 5 4 5 4 4
0F0: 4 3 2 0 0 0 2 3 3 4 4 3 2 2 3 3

DSL: Training log buffer capability is not enabled

Hall of Fame Super Gold

Re: Cisco 877W Router - Line Open, Drops PPP, Will Not Reestabli

You should update IOS to latest, or DSL firmware, to 4.0.17.

New Member

Cisco 877W Router - Line Open, Drops PPP, Will Not Reestablish

Can you help me with where to obtain the latest IOS and DSL firmware?

Thanks, Ian.

1869
Views
0
Helpful
5
Replies
CreatePlease to create content