Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Cisco 877W with IPoEoATM

Hello Everybody,

Up till Friday the 8th of May in one of our remote locations we had BT as ISP and the 877W was working fine.

We change the provider to “Be Un limited” and since then we are unable to configure the 877W.

Below is a guide to Be* members wanting to use a 3rd party modem/router.

Who is this guide for?

For all Be* members configuring and wanting to use a 3rd Party Modem to connect to our broadband service.

“Be* technical support can only provide help for the Bebox and support for connection/speed problems to customers using the BeBox. It is necessary for the Bebox to be connected and the issue reproduced before raising a ticket or contacting support.”

Guide:

In order to use a 3rd party modem it has to be compliant with ADSL2+ service (has to support g.dmt.992.5 Annex A/Annex M(for BE* Pro members only) modulation)

If you have any such device that you feel more comfortable with, you will need to input the

following values:

1) vci=101 and vpi=0.

2) ADSL bridging should enabled (as per RFC 1483).

3) When configuring the WAN (DSL interface), you would get an option asking whether your ISP authenticates with user/pass or not - you have to choose NO in there, as we require no username and/or password for access to our network.

4) Connection type is IPoEoATM.

5) Multiplexing is LLC-based. If you are able to choose the LLC type it should be set to SNAP.

This should be sufficient for you to set up any 3rd party modem with our service. For more information in regards to third party modems, please refer to our forum where you can find solutions and opinions from fellow-members using third party hardware.

Please note that our hotline agents do not support third party hardware and can only give settings provided above.

The old configuration of the 877W is:

boot system flash c870-advipservicesk9-mz.124-6.T2.bin

interface ATM0

no ip address

no ip mroute-cache

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

no snmp trap link-status

pvc 0/101

dialer pool-member 1

protocol ppp dialer

!

!

interface Dialer0

no ip address

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

no cdp enable

ppp authentication ms-chap callin

ppp chap hostname xxx@btbroadband.com

ppp chap password 7 xxx

!

ip route 0.0.0.0 0.0.0.0 Dialer0

Can somebody help me to configure the 877W to work with the new ISP?

I also attach a user.ini file that is the current configuration of the new ISP's Modem Router.

Thanks,

George Govotsis

2 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Silver

Re: Cisco 877W with IPoEoATM

Hello George,

RFC1483 bridged means that ethernet frames are bridged over the ATM/ADSL.

The router has to behave as a bridge with one interface that is the lan interface and one that is the ATM.

The specificity of 877 is to use an SVI Vlan1 interface instead of eth0/0 of older routers.

I guess you would like to access the device remotely so you need IRB integrated routing and bridging

ip routing

bridge 1 protocol ieee

bridge 1 route ip

! these for all FE ports

! that are members of vlan1

int vlan1

no ip addr

bridge-group 1

!

int atm0

no shut

int atm0.1 point-to-point

no ip addr

bridge-group 1

pvc 0/101

enc aal5snap

!

! virtual L3 interface for bridge-group 1

interface BVI1

ip address dhcp

no shut

ip route 0.0.0.0 0.0.0 bvi1

notes:

I'm not sure the config of BVI is correct for you ISP.

note2:

if the ios image allows to use a second vlan (vlan2)

you can have vlan2 configured as ip nat inside and BVI as ip nat outside

you can associate some FE port to vlan2 as:

int fasx/y

switchport

switchport mode access

switchport access vlan2

see

for RFC1483 bridged

http://www.cisco.com/en/US/tech/tk39/tk48/technologies_configuration_example09186a008009455f.shtml

for bridging on vlans on 877

http://www.cisco.com/en/US/docs/routers/access/800/850/software/configuration/guide/wireless.html#wp999748

Hope to help

Giuseppe

Hall of Fame Super Gold

Re: Cisco 877W with IPoEoATM

Have you tried "atm route-bridged" as well ?

Please do not low rate posts without a valid reason.

6 REPLIES
Hall of Fame Super Gold

Re: Cisco 877W with IPoEoATM

Remove PPP, it is not needed.

Configure ip address or dhcp under subif, together with "atm route-bridged".

Hall of Fame Super Silver

Re: Cisco 877W with IPoEoATM

Hello George,

RFC1483 bridged means that ethernet frames are bridged over the ATM/ADSL.

The router has to behave as a bridge with one interface that is the lan interface and one that is the ATM.

The specificity of 877 is to use an SVI Vlan1 interface instead of eth0/0 of older routers.

I guess you would like to access the device remotely so you need IRB integrated routing and bridging

ip routing

bridge 1 protocol ieee

bridge 1 route ip

! these for all FE ports

! that are members of vlan1

int vlan1

no ip addr

bridge-group 1

!

int atm0

no shut

int atm0.1 point-to-point

no ip addr

bridge-group 1

pvc 0/101

enc aal5snap

!

! virtual L3 interface for bridge-group 1

interface BVI1

ip address dhcp

no shut

ip route 0.0.0.0 0.0.0 bvi1

notes:

I'm not sure the config of BVI is correct for you ISP.

note2:

if the ios image allows to use a second vlan (vlan2)

you can have vlan2 configured as ip nat inside and BVI as ip nat outside

you can associate some FE port to vlan2 as:

int fasx/y

switchport

switchport mode access

switchport access vlan2

see

for RFC1483 bridged

http://www.cisco.com/en/US/tech/tk39/tk48/technologies_configuration_example09186a008009455f.shtml

for bridging on vlans on 877

http://www.cisco.com/en/US/docs/routers/access/800/850/software/configuration/guide/wireless.html#wp999748

Hope to help

Giuseppe

Hall of Fame Super Gold

Re: Cisco 877W with IPoEoATM

Giuseppe,

You do not necessarily need IRB. Atm route-bridged provides an easier alternative.

Community Member

Re: Cisco 877W with IPoEoATM

Dear All,

Thanks for your replies.

I found through the IRC of Be the following config that I implemented

single static IP

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname c837-be*

!

boot-start-marker

boot-end-marker

!

enable secret cisco

!

no aaa new-model

ip subnet-zero

!

bridge irb

!

!

interface Ethernet0

ip address 192.168.1.254 255.255.255.0

ip nat inside

ip tcp adjust-mss 1452

hold-queue 100 out

!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

bridge-group 1

pvc 0/101

encapsulation aal5snap

!

!

interface BVI1

ip address [static ip] [subnet mask]

ip access-group 101 in

ip nat outside

!

ip nat inside source list 1 interface BVI1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 [gateway]

no ip http server

no ip http secure-server

!

access-list 1 permit 192.168.1.0 0.0.0.255

access-list 101 permit ip any any

!

bridge 1 protocol ieee

bridge 1 route ip

line con 0

no modem enable

stopbits 1

line aux 0

stopbits 1

line vty 0 4

password 123

login

!

scheduler max-task-time 5000

!

end

and it resolve the issue.

Thanks,

George Govotsis

Hall of Fame Super Gold

Re: Cisco 877W with IPoEoATM

Have you tried "atm route-bridged" as well ?

Please do not low rate posts without a valid reason.

Hall of Fame Super Silver

Re: Cisco 877W with IPoEoATM

Hello Paolo, George

Paolo is right RBE can be a good solution as well, indeed has been developed for this kind of scenarios.

http://www.cisco.com/en/US/docs/ios/12_1t/12_1t2/feature/guide/dtatmrbe.html#wp1023284

I'm more used with IRB because RBE had been introduced later and because I have little experience with it.

Hope to help

Giuseppe

578
Views
2
Helpful
6
Replies
CreatePlease to create content