Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 881 inter VLAN routing via trunk port

Hello my fellow network specialists an experts

I need your help

I have tried to configure inter VLAN routing on Cisco 881, but I failed.

Vlans were connected via trunk port which is connected with a switch.

Configuring Vlan interfaces doesn't work, because they are in down state as no cables are directly connected to the router.

Then I tried to configure sub interfaces on a trunk port, but there is no such option in command line.

In final, I made a conclusion that this router model does not support inter vlan routing with trunk port.

Am I right? Or there are other ways to accomplish it?

Thank you in advance.

4 REPLIES
Hall of Fame Super Gold

Cisco 881 inter VLAN routing via trunk port

Yes it can, create the vlan and when it comes up it will route.

Silver

Re: Cisco 881 inter VLAN routing via trunk port

It would look something like this:

SWITCH:

interface F1/0/1

switchport mode trunk

VLAN1

VLAN2

etc.

ROUTER:

interface F0/0.1

encapsulation dot1q 1

ip address 10.0.0.1 255.255.255.0

interface F0/0.2

encapsulation dot1q 2

ip address 10.0.2.1 255.255.255.0

Hall of Fame Super Gold

Cisco 881 inter VLAN routing via trunk port

mfurnival wrote:

It would look something like this:

SWITCH:

interface F1/0/1

switchport mode trunk

VLAN1

VLAN2

etc.

ROUTER:

interface F0/0.1

encapsulation dot1q 1

ip address 10.0.0.1 255.255.255.0

interface F0/0.2

encapsulation dot1q 2

ip address 10.0.2.1 255.255.255.0

This assumes the router uses a Layer 3 interface for connecting the switch. But if it connects using a switch port, the only vlan interfaces ae configred, not subinterfaces.

New Member

Cisco 881 inter VLAN routing via trunk port

Thank you guys for your answers!

I found the solution:

In the configuration of VLAN interface it is required to add

no autostate

This will enable VLAN interface even if there are no ports in it, and you can ping it.

474
Views
5
Helpful
4
Replies