Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

Cisco 881G Router

Hi All,

My customer proposed to buy Cisco 881G Router.

Our Requirements is to terminate both UMTS and DSL connections and is able to switch to UMTS if the DSL line fails.

And configure site to site DMVPN.

Can any one please suggest me about the UMTS configuration and how it will be switch to UMTS if the DSL line fails.

And site to site DMVPN should be up on UMTS if DSL failes visa versa.

Regards,

Naidu.

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Cisco 881G Router

Hello Naidu,

the 3G UMTS interface can act as a backup for primary DSL interface

the use of the 3G interface can be done with classid DDR dial on demand routing

>> And site to site  DMVPN should be up on UMTS if DSL failes visa versa.

This point is more difficult to achieve, it may be easier to build a second DMVPN cloud using the UMTS links unless you have a single provider for both the DSL and the UMTS link you will have different public IP addresses

look for HWIC 3G configuration guide in CCO it should help

http://www.cisco.com/en/US/docs/routers/access/1800/1861/software/feature/guide/3ghwic.html

Hope to help

Giuseppe

Edit:

added link to mentioned configuration guide

13 REPLIES
Hall of Fame Super Silver

Re: Cisco 881G Router

Hello Naidu,

the 3G UMTS interface can act as a backup for primary DSL interface

the use of the 3G interface can be done with classid DDR dial on demand routing

>> And site to site  DMVPN should be up on UMTS if DSL failes visa versa.

This point is more difficult to achieve, it may be easier to build a second DMVPN cloud using the UMTS links unless you have a single provider for both the DSL and the UMTS link you will have different public IP addresses

look for HWIC 3G configuration guide in CCO it should help

http://www.cisco.com/en/US/docs/routers/access/1800/1861/software/feature/guide/3ghwic.html

Hope to help

Giuseppe

Edit:

added link to mentioned configuration guide

Re: Cisco 881G Router

Hi Giuseppe,

Thanks for your response.

Actually I am new to Cisco 881G, even not yet seen what kind of interfaces will be there and how to setup also.

Tomorrow I have to configure this router as there is internet connection available with 3G.

And I have to configure site to site VPN tunnel with 3G fow now.

If you have any example configuration, could you please share to me.

It will be great help to me as I am at strange now.

Regards,

Naidu.

Hall of Fame Super Silver

Re: Cisco 881G Router

Hello Naidu,

the configuration guide has some examples

http://www.cisco.com/en/US/docs/routers/access/1800/1861/software/feature/guide/3ghwic.html#wp1178422

I would suggest to use a tunnel GRE protected by IPSec

you will need to pick from all examples to build a working complete configuration because some aspects are covered only in the basic example

Hope to help

Giuseppe

Re: Cisco 881G Router

HI Giuseppe,

I looked at the link which you sent, it is so big and feeling typical to pick right examples.

The present scenario is, there is 3G card and Router 881G available. Today I have to complete the configuration.

It would be great if you could provide the sample configuration like how to activate the 3G card and how to configure the interface (I think cellular interface)

Once 3G card activated and router interface able to communicate with public, then I can form tunnel between sites.

Please your help is most precious.

Regards,

Naidu.

Hall of Fame Super Silver

Re: Cisco 881G Router

Hello Naidu,

an older thread on the same issue can be of help it contains also details on the chat script config for the 3G modem

https://supportforums.cisco.com/message/3008300#3008300

Hope to help

Giuseppe

Rate useful posts to help Haiti

Re: Cisco 881G Router

Hi Giuseppe,

You are great, I am getting good suggestions from you...:-)

Deffnitely I will rate all the posts so far what are there once I achive this job..... Because it is very urgent to get done.

I saw the post before posted this thread, but still some unconfident about the configuration will get work.

If I configure my 881G router as like below.... will it work out? I hope it will work out.... If not what are the modifications...could you please suggest.

And how I have to activate the GSM sim (3G data card) in the router?

interface Cellular0
no ip address

!
interface Vlan1
ip address 10.31.xx.xxx 255.255.255.0
!
interface Cellular0/0/0
ip address negotiated
encapsulation ppp
dialer in-band
dialer string gsm
dialer-group 1
async mode interactive
ppp chap hostname cisco@wwan.ccs
ppp chap password 0 cisco
ppp ipcp dns request
!
ip route 0.0.0.0 0.0.0.0 Cellular0/0/0
!
access-list 1 permit any
dialer-list 1 protocol ip list 1
!
line 0/0/0
exec-timeout 0 0
script dialer gsm
login
modem InOut

Regards,

Naidu

Hall of Fame Super Silver

Re: Cisco 881G Router

Hello Naidu,

>> And how I have to activate the GSM sim (3G data card) in the router?

to check if the USIM is enabled for data services contact the provider support, they will tell you if you need  to activate it and how (you may need to insert it in cell phone)

part of the GSM scipt may be provider specific check with them also this aspect.

Hope to help

Giuseppe

Hall of Fame Super Silver

Re: Cisco 881G Router

Hello Naidu,

looking at configuration guide of HWIC 3G-GSM there is a step that is different from CDMA that is the activation of a data modem profile

cellular  gsm profile create 
<profile number>

see

http://www.cisco.com/en/US/docs/routers/access/1800/1861/software/feature/guide/3ghwic.html#wp1119164

this part is made in a totally different way on HWIC CDMA

Have you been able to setup the 881G connection?

Hope to help

Giuseppe

Re: Cisco 881G Router

Hi Giuseppe,

I completed the basic configuration and sent the router to onsite.

I have not heard any update from them to look into...

I will update you once I get hold the router...

Regards,

Naidu.

Re: Cisco 881G Router

Hi Giuseppe,

The updated setup is like this...

3G & DSL lines terminated on 881G router to get internet access.

ASA 5505 connected to 881G router. Will did easy vpn with 5505.

Easy vpn seems working over DSL, have to cross check.

My present task is to configure failover between 3G & DSL (if DSL down internet should available over 3G)

Could you please guide me how to configure the failover between 3G & DSL in 881G router.

Regards,

Naidu.

Hall of Fame Super Silver

Re: Cisco 881G Router

Hello Naidu,

the 3G HWIC configuration guide contains a good config example:

see

http://www.cisco.com/en/US/docs/routers/access/1800/1861/software/feature/guide/3ghwic.html#wp1178422

you may need to change something but this gives you a complete picture of what you need to do

You need to make the appropriate changes for easy VPN.

If I remember correctly Lei Tian had provided a link to easy VPN configuration in another thread of yours.

Hope to help

Giuseppe

Community Member

Re: Cisco 881G Router

Hello Giuseppe,

I read many of your post, thakn you for all of them. They are so helpfull. I need your quik look, thank you in advance..

I am trying to configure 3G backup line with primary ADSL on Cisco router 887G at branch office.

DSL line is point to point. When I just finished the DSL config, line uses ISP's MPLS vpn, and we can work on as  site-to-site VPN.

3G line I configured few days ago. And I configured DMVPN on the 3G line. Until here everything is ok.

One by one each line works fine. But when I try to configure 3G line as a backup line of DSL, I can not reach to the head office.

Today I read more about tracking. I can send my last configuration by now. But, I can only try this config successfull or not unfortunately on monday.

Can you please check my config ? Any thing look wrong...

x.x.x.x head quarter real ip

x.x.x.z track ip

!

! Last configuration change at 14:04:58 UTC Tue Feb 8 2011 by dpcmerkez

!

version 15.1

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname IST_DPC

!

boot-start-marker

boot system flash c880data-universalk9-mz.151-2.T2a.bin

boot-end-marker

!

!

logging buffered 51200 warnings

enable secret 5 $1$Hgd4$F/8kIIGAwxl7lS2kLetnJ.

!

no aaa new-model

!

memory-size iomem 10

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-2733612712

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-2733612712

revocation-check none

rsakeypair TP-self-signed-2733612712

!

!

ip source-route

!

!

!

!

!

ip cef

no ip domain lookup

ip domain name yourdomain.com

no ipv6 cef

!

!

multilink bundle-name authenticated

chat-script internet "" "ATDT*99#" TIMEOUT 60 "CONNECT"

!

username ****  password *****

!

!

!

!

controller Cellular 0

!

ip ftp source-interface Vlan1

ip ftp username ozgur

ip ftp password 7 1418080C1916

!

!

crypto isakmp policy 10

hash md5

authentication pre-share

group 2

crypto isakmp key cisco123 address x.x.x.x

!

crypto ipsec transform-set *** esp-3des esp-md5-hmac

!

crypto ipsec profile   ****

set transform-set ****

!

!

!

!

!

interface Tunnel1

ip address 192.168.168.2 255.255.255.0

no ip redirects

ip mtu 1440

ip nhrp authentication cisco123

ip nhrp map multicast dynamic

ip nhrp map multicast x.x.x.x

ip nhrp map 192.168.168.1 x.x.x.x

ip nhrp network-id 5

ip nhrp nhs 192.168.168.1

ip nhrp registration no-unique

tunnel source Dialer1

tunnel mode gre multipoint

tunnel key 5

tunnel protection ipsec profile ******

!

interface ATM0

no ip address

no atm ilmi-keepalive

pvc 8/35

  pppoe-client dial-pool-number 2

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Cellular0

description "### 3g interface ###"

no ip address

ip virtual-reassembly in

encapsulation ppp

load-interval 60

dialer in-band

dialer pool-member 1

async mode interactive

no fair-queue

!

interface Vlan1

description "### LAN baglantilari ###"

ip address 172.25.190.1 255.255.255.0

ip virtual-reassembly in

ip tcp adjust-mss 1452

!

interface Dialer0

ip address negotiated

backup interface dialer1    

ip directed-broadcast

encapsulation ppp

ip tcp adjust-mss 1300

dialer pool 2

ppp authentication chap pap callin

ppp chap hostname *********

ppp chap password  ****

ppp pap sent-username *****   password *******

no cdp enable

!

interface Dialer1

ip address negotiated

ip flow ingress

ip virtual-reassembly in

encapsulation ppp

shutdown

dialer pool 1

dialer idle-timeout 0

dialer string internet

dialer persistent

dialer-group 1

ppp authentication chap callin

ppp chap refuse

ppp pap refuse

ppp ipcp dns request

no cdp enable

!

!

router eigrp 5

network 172.25.190.0 0.0.0.255

network 192.168.168.0

!

ip forward-protocol nd

no ip http server

ip http access-class 23

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

ip local policy route-map track-primary-if
ip route 0.0.0.0 0.0.0.0 Dialer0 2

ip route 0.0.0.0 0.0.0.0 Dialer1 254

ip sla 1

icmp-echo x.x.x.z  source-interface Dialer0

ip sla schedule 1 life forever start-time now

logging esm config

access-list 1 permit any

access-list 120 permit icmp any host x.x.x.z

dialer-list 1 protocol ip permit

no cdp run

!

!

!

!

route-map track-primary-if permit 10

match ip address 120

set interface Dialer0

!

!

control-plane

!

!

line con 0

login local

no modem enable

line aux 0

line 3

exec-timeout 0 0

script dialer internet

modem InOut

no exec

transport input all

speed 237000

line vty 0 4

privilege level 15

login local

transport input telnet ssh

!

end

Community Member

Cisco 881G Router

I change my static route a bit ..than backup line  works fine. When DSL goes down 3G line becomes main connection.

I just need to another 2 route lines according to track config.Everything works as I planed.

7931
Views
0
Helpful
13
Replies
CreatePlease to create content