Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Silver

Cisco 887 ADSL setup - please help the stupid.

Folks.

I'm going nucking futs trying to get this to work - I know it's something stupidly simple, and I know I should remember how to do this, but it's been 10 years since I set one of these up from scratch, and it's been a long week.

Work has an ADSL service - it's used for a backup in the event of a catostrophic failure of our normal infrastructure (in reality, it gets used for testing and not much else) which has been running on this crappy old billion router which fails about a dozen times a day.

I've got a bunch of 887's hanging around from another project, so I finally went "Stuff it, I'm putting in an 887".

I configured it, got it talking to ADSL, got it talking to the wireless point hanging off it, got the wireless working and getting IP allocation, I can telnet into the router and PING outside addresses - but I can't make NAT work for addresses on VLAN1.

I plead for assistence. I don't care if you laugh in my face and say "Darren, you idiot, you forgot <this miniscule command>" I just need to fix it and get on with other things which I'm currently stressing about (don't get me started on integrating Juniper and Cisco, or Microsoft bl***dy Lync, trust me).

Redacted/abbreviated config posted below - please, someone tell me what I've done wrong.

version 15.0

hostname router

no aaa new-model

memory-size iomem 10

clock timezone AEST 10

clock summer-time ADST recurring 1 Sun Oct 2:00 1 Sun Apr 3:00

!

ip source-route

!

!

!

ip dhcp pool 192.168.25.0/24

   network 192.168.25.0 255.255.255.0

   default-router 192.168.25.254

   dns-server 139.130.4.4 203.50.2.71

   lease 5

!

!

ip cef

ip name-server 139.130.4.4

ip name-server 203.50.2.71

no ipv6 cef

!

!

!

!

ip ssh version 2

!

!

!

!

!

!

!

interface BRI0

no ip address

encapsulation hdlc

shutdown

isdn termination multidrop

!

interface ATM0

no ip address

ip virtual-reassembly

no atm ilmi-keepalive

pvc 8/35

  encapsulation aal5snap

  pppoe-client dial-pool-number 1

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

description Local LAN

ip address 192.168.25.254 255.255.255.0

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1420

hold-queue 100 out

!

interface Dialer0

ip address negotiated

ip mtu 1462

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap callin

ppp chap hostname <redacted>

ppp chap password <redacted>

ppp ipcp route default

!

ip forward-protocol nd

ip http server

ip http secure-server

!

ip nat source list 10 interface Dialer0 overload

!

access-list 10 permit 192.168.25.0 0.0.0.255

dialer-list 1 protocol ip permit

!

!

!

!

!

control-plane

!

!

line con 0

no modem enable

line aux 0

line vty 0 4

access-class 20 in

exec-timeout 0 0

login local

transport input telnet ssh

!

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Cisco 887 ADSL setup - please help the stupid.

Hi,

"ip nat source list 10 interface Dialer0 overload"  should be "ip nat inside source list 10 interface Dialer0 overload"

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
2 REPLIES
Purple

Cisco 887 ADSL setup - please help the stupid.

Hi,

"ip nat source list 10 interface Dialer0 overload"  should be "ip nat inside source list 10 interface Dialer0 overload"

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Silver

Cisco 887 ADSL setup - please help the stupid.

Thanka Alain - I *knew* it was something stupidly simple - I just couldn't see the forest for the trees!

486
Views
0
Helpful
2
Replies