Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 887 playing well with Cisco 3750

I have obtained the above equipment and I am trying to get it all working together nicely.

Essentially I want the Cisco 887 router (which only has L2 interfaces) to route all the vlans defined on the 3750 out through the DSL line Dialer0

When I connect various laptops in various vlans to the the 3750 i can ping each other.

So for example:

laptop on vlan 10 with ip 192.168.10.10 can ping laptop on vlan 20 with ip 192.168.20.10. Good news.

The 887 is on vlan 1 (i know it is bad to be vlan1 dont shout at me) with IP 192.168.0.254

If i have a laptop on 192.168.0.10 it can ping the 887 and the other vlans but I cannot get a laptop on 192.168.20.10 (vlan1) to ping 192.168.0.254 the router.

I can emulate this also by pinging 192.168.0.254 source vlan 10 from the 3750.

Now if I create vlans on the 887 like this.

int vlan 10

ip address 192.168.10.254

no shut

then it works.

But I was just expecting the 3750 to handle all the intervlan routing and to forward it onto the router to pass it out through to the internet.

Am I missing somthing fundamental in my knowledge / expectations.?

Many thanks

N

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Re: Cisco 887 playing well with Cisco 3750

I would but I know my config is wrong as it doesnt work.

Well that's why i asked for it to see what is wrong with it

For inter-vlan routing with a 3750 and 887 assuming you are doing the inter-vlan routing on the 3750 then you simply create all your vlans and the L3 vlan interfaces on the 3750. Then if you are using a L2 port on the 887 you simply have a common vlan between the 3750 and 887. You would then need a L3 vlan interface on the 3750 and an equivalent interface on the 887 eg. -

3750

====

int gi0/1  <--- connects to 887

switchport

switchport mode access

switchport access vlan 20

int vlan 20

ip address 192.168.10.1 255.255.255.252

887

===

L2 interface eg.

int fa0/1

switchport

switchport mode access

switchport access vlan 20

int vlan 20

ip address 192.168.10.2 255.255.255.252

Note i have use a dedicated vlan ie.vlan 20 for the 3750 to 887 connectivity and hence i only used a /30 subnet ie. 192.168.10.0/30.

then you need to take care of routing -

on the 3750 you simply need a default-route pointing to the 887 eg.

ip route 0.0.0.0 0.0.0.0 192.168.10.2

on the 887 you need routes for all subnets/vlans that are on the 3750 eg.

ip route 192.168.1.0 255.255.255.0 192.168.10.1

ip route 192.168.2.0 255.255.255.0 192.168.10.1

etc..

or you could just use a summary route eg.

ip route 192.168.0.0 255.255.0.0 192.168.10.1 <-- this assumes all 192.168.x.0 networks are on the 3750 ie. they are not reached via any other device.

You can if you want run a routing protocol between the 3750 and the 887 but it depends on the IOS feature set on your 3750.

Jon

3 REPLIES
Hall of Fame Super Blue

Cisco 887 playing well with Cisco 3750

Neil

Can you post configs of 3750 and the 887 ?

Jon

New Member

Cisco 887 playing well with Cisco 3750

I would but I know my config is wrong as it doesnt work.

Essentially I am asking more about the principal of intervlan routing from a 3750 to a 887.

At present I have pretty much flattened the environment to start again.

Hall of Fame Super Blue

Re: Cisco 887 playing well with Cisco 3750

I would but I know my config is wrong as it doesnt work.

Well that's why i asked for it to see what is wrong with it

For inter-vlan routing with a 3750 and 887 assuming you are doing the inter-vlan routing on the 3750 then you simply create all your vlans and the L3 vlan interfaces on the 3750. Then if you are using a L2 port on the 887 you simply have a common vlan between the 3750 and 887. You would then need a L3 vlan interface on the 3750 and an equivalent interface on the 887 eg. -

3750

====

int gi0/1  <--- connects to 887

switchport

switchport mode access

switchport access vlan 20

int vlan 20

ip address 192.168.10.1 255.255.255.252

887

===

L2 interface eg.

int fa0/1

switchport

switchport mode access

switchport access vlan 20

int vlan 20

ip address 192.168.10.2 255.255.255.252

Note i have use a dedicated vlan ie.vlan 20 for the 3750 to 887 connectivity and hence i only used a /30 subnet ie. 192.168.10.0/30.

then you need to take care of routing -

on the 3750 you simply need a default-route pointing to the 887 eg.

ip route 0.0.0.0 0.0.0.0 192.168.10.2

on the 887 you need routes for all subnets/vlans that are on the 3750 eg.

ip route 192.168.1.0 255.255.255.0 192.168.10.1

ip route 192.168.2.0 255.255.255.0 192.168.10.1

etc..

or you could just use a summary route eg.

ip route 192.168.0.0 255.255.0.0 192.168.10.1 <-- this assumes all 192.168.x.0 networks are on the 3750 ie. they are not reached via any other device.

You can if you want run a routing protocol between the 3750 and the 887 but it depends on the IOS feature set on your 3750.

Jon

222
Views
0
Helpful
3
Replies