Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Cisco 887 router with URL Filtering (Websense) issue

Hi there,

Thanks in advance for any help on this.  I have a cisco 887 router that connects to a websense server for url filtering.  The configuration used looks like this:

 

ip inspect name fw_url http urlfilter

ip urlfilter allow-mode on

ip urlfilter server vendor websense 10.10.10.1

 

 

interface Vlan33

ip inspect fw_url in

 

Vlan 33 is the LAN, default route is by dialer interface.  There is a VPN configured and it works as expected, the websense server is on the remote side of the VPN and I can see that it is filtering URL's and specifying what is allowed and denied by the debugs on the router.

 

From the router all appears to be working correctly.

 

Problem is, when URL filtering is enabled the PC's really struggle to get to websites and it runs dog slow - take the inspection off the VLAN 33 and browsing is fine but not filtered.

We have exactly the same configuration on some older 877 routers and it works without any problems - I am thinking something changed on the 887 that needs configuring or possibly a bug?

The version of code is: Cisco IOS Software, C880 Software (C880DATA-UNIVERSALK9-M), Version 15.2(4)M6, RELEASE SOFTWARE (fc2)

 

System image file is "flash:c880data-universalk9-mz.152-4.M6.bin"

Your help is much appreciated.

Cheers,

Charlie.

 

 

 

 

57
Views
0
Helpful
0
Replies
CreatePlease to create content