Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 887VA ADSL Setiup

Hi,

I have a new C887VAM-W-E-K9 to replace my existing 837 ISR.

I have been looking through the forums to try to fin the correct setup for the ADSL part and it's a little confusing on whether to use VDSL, ATM Ethernet0 etc.. Having read through as many articles as I can digest I came to conculsion that;

For ADSL2+ I need to configure the ATM0 / ATM0.1 to work with the Dialer0 interface and not VDSL/Ethernet0.

Is that correct? I dont understand why some threads talk about "show controller vdsl 0" for testing whether the ADSL line is working correctly?

I have tried to get the router to talk to the ISP and cannot get it working; the current config for the interfaces is below but this doesn't even get the PPP light on nor can I ping 4.2.2.2 from the CCP tool. Any help appreciated?

controller VDSL 0

!

no ip ftp passive

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

!

interface ATM0.1 point-to-point

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

!

interface Ethernet0

no ip address

shutdown

!

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

shutdown

!

interface FastEthernet2

no ip address

shutdown

!

interface FastEthernet3

no ip address

shutdown

!

interface Wlan-GigabitEthernet0

description Internal switch interface connecting to the embedded AP

no ip address

!

interface wlan-ap0

description Embedded Service module interface to manage the embedded AP

no ip address

!

interface Vlan1

description $FW_INSIDE$

ip address 192.168.2.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

!

interface Dialer0

ip address negotiated

ip mtu 1452

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

ppp authentication chap callin

ppp chap hostname bthomehub@btbroadband.com

ppp chap password 0 BT

no cdp enable

!

ip forward-protocol nd

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip nat inside source list 101 interface Dialer0 overload

ip route 0.0.0.0 0.0.0.0 Dialer0

!

access-list 101 permit ip 192.168.2.0 0.0.0.255 any

!

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

Re: Cisco 887VA ADSL Setiup

Your router has a Broadcom 'multimode' chipset that supports both ADSL2+ and VDSL2. Athough you are correct that ADSL is configured under ATM and VDSL under Ethernet0, the command show controller vdsl 0 is used for both modes, and replaces the command show dsl interface atm 0 used in older models with a different chipset.

In order to troubleshoot, please post the output of show controller vdsl 0 and your full config.

2 REPLIES
Bronze

Re: Cisco 887VA ADSL Setiup

Your router has a Broadcom 'multimode' chipset that supports both ADSL2+ and VDSL2. Athough you are correct that ADSL is configured under ATM and VDSL under Ethernet0, the command show controller vdsl 0 is used for both modes, and replaces the command show dsl interface atm 0 used in older models with a different chipset.

In order to troubleshoot, please post the output of show controller vdsl 0 and your full config.

New Member

Re: Cisco 887VA ADSL Setiup

Thanks,

I have managed to get it working now, I reset back to factory and started again. This time I configured the ATM and a Dialer interface, then set the vdsl to auto mode, I think the issue was that I had configured a vdsl connection using CCP and even removing it didn't make any difference.



Sent from Cisco Technical Support iPad App

827
Views
0
Helpful
2
Replies