Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Cisco 887VA-M not running at ADSL2+ speeds

Hello

We just changed a basic dsl modem for a Cisco 887VA DSL router and the throughput is very bad.the line and profile support ADSL2+.  We have checked with the provider and there are not line faults and the profile applied by the provider is 2mb/12Mb [the line can support 2.5Mb/26Mb] up and down.

DSL-internet#show atm pvc interface atM 0

           VCD /                                                                    Peak Av/Min Burst

Interface  Name         VPI   VCI Type    Encaps     SC          Kbps   Kbps Cells St

0             1                  8    35 PVC      SNAP       UBR        2044                   UP

DSL-internet#

We are running the following IOS: c880data-universalk9-mz.152-4.M3.bin

When we run ISP speed tests we are getting about about 500Kb/3Mb up/down with about 240ms ping tests.

Do you know if there is an issue with the ADSL2+ operation on this Cisco DSL router. It should be transparent, as regards configuration, as far as I am aware.

Thanks

Nick

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Community Member

Cisco 887VA-M not running at ADSL2+ speeds

Can you post the info from this command:

sh controllers vdsl 0

What is your ISP for this line?

7 REPLIES
Community Member

Cisco 887VA-M not running at ADSL2+ speeds

What ISP are you using?  I had the same issue with when I replaced an a standard router on a BT line with a Cisco 877 and it was terrible and BY said they don't support Cisco (what!!).  I then found out that Cisco had a newer modem version not IOS for the 877 to deal with ADSL+2 and the Annex M, well as soon as I upgraded this and rebooted it was an istand success and bu VPN was stable and much faster.

Community Member

Cisco 887VA-M not running at ADSL2+ speeds

Hello Andy. this is a brand new router, hot off the shelf. Surely I must be able to apply a Cisco update to it, if required.

Community Member

Cisco 887VA-M not running at ADSL2+ speeds

Can you post the info from this command:

sh controllers vdsl 0

What is your ISP for this line?

Community Member

Cisco 887VA-M not running at ADSL2+ speeds

Hello Andy

My pro vider is eir com in Ire land

Thanks again

DSL-internet#show controllers vdSL 0
Controller VDSL 0 is UP

Daemon Status:           Up

                        XTU-R (DS)              XTU-C (US)
Chip Vendor ID:         'BDCM'                   'BDCM'
Chip Vendor Specific:   0x0000                   0xA325
Chip Vendor Country:    0xB500                   0xB500
Modem Vendor ID:        'CSCO'                   '    '
Modem Vendor Specific:  0x4602                   0x0000
Modem Vendor Country:   0xB500                   0x0000
Serial Number Near:    FCZ17259108 887VA-M 15.2(4)M
Serial Number Far:
Modem Version Near:    15.2(4)M
Modem Version Far:     0xa325

Modem Status:            TC Sync (Showtime!)
DSL Config Mode:         AUTO
Trained Mode:            G.992.5 (ADSL2+) Annex M
TC Mode:                 ATM
Selftest Result:         0x00
DELT configuration:      disabled
DELT state:              not running
Trellis:                 ON                       ON
SRA:                     disabled                        disabled
SRA count:              0                       0
Bit swap:                enabled                         enabled
Bit swap count:         0                       17571
Line Attenuation:        14.5 dB                  9.9 dB
Signal Attenuation:      15.3 dB                  9.6 dB
Noise Margin:            21.8 dB                 17.0 dB
Attainable Rate:        26812 kbits/s            2593 kbits/s
Actual Power:            13.6 dBm                12.8 dBm
Total FECC:             0                        0
Total ES:               0                        0
Total SES:              0                        0
Total LOSS:             0                        0
Total UAS:              60                       60
Total LPRS:             0                        0
Total LOFS:             0                        0
Total LOLS:             0                        0

Full inits:             1
Failed full inits:      1
Short inits:            1
Failed short inits:     0

Firmware        Source          File Name (version)
--------        ------          -------------------
VDSL            embedded        VDSL_LINUX_DEV_01212008 (1)

Modem FW  Version:      120306_1254-4.02L.03.A2pv6C035j.d23j
Modem PHY Version:      A2pv6C035j.d23j
Vendor Version:         Ap6v35j.23j 68


                  DS Channel1     DS Channel0   US Channel1       US Channel0
Speed (kbps):             0            12286             0              2044
SRA Previous Speed:       0                0             0                 0
Previous Speed:           0                0             0                 0
Total Cells:              0       2120766691             0         352819395
User Cells:               0        103356576             0          16839525
Reed-Solomon EC:          0                0             0                 0
CRC Errors:               0                0             0                 0
Header Errors:            0                0             0                 0
Interleave (ms):       0.00            10.70          0.00              6.98
Actual INP:            0.00             5.80          0.00              0.93

Training Log :  Stopped
Training Log Filename : flash:vdsllog.bin

Community Member

Cisco 887VA-M not running at ADSL2+ speeds

So it looks like you are getting 12mb downlaod and 2mb upload?  Is is stable atleast?

Your IOS seems quite up-to-date I think you modem version is from 2012 and there is a newer version so you coudl perhaps try updating that to:

A2pv6C035l.d23j

http://software.cisco.com/download/release.html?mdfid=283122154&catid=268437899&softwareid=282821780&release=A2pv6C035l.d23j&relind=AVAILABLE&rellifecycle=&reltype=latest

Thanks

Community Member

Cisco 887VA-M not running at ADSL2+ speeds

Hello Andy

It is working quite well now, considering it is ADSL.  I just did a speed test and we are getting a 26ms ping/ 7.3 MB down and 1.7MB up. I will look at the modem software shortly. Thanks for the input and best of luck [ we removed some firewalling on the router, so am wondering if it was slowing in down also]. Anyhow, case closed. Cheers Nick

Community Member

Cisco 887VA-M not running at ADSL2+ speeds

Thanks, yeah check the CPU output.

Please rate if I was any help.

Kind regards

1524
Views
0
Helpful
7
Replies
CreatePlease to create content