Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 887VA PPPoA BT ADSL setup?

Hi,

Sorry to bother you all.

Im new to Cisco equipment and weve just upgraded to a all singing 8000 series (887VA) to be precise.

i'm having difficultys in setting the router to connect to our BT ADSL2 business broadband, we have a static IP but on normal cheaper routers you just input a Chap username and password. and the router sorts the rest.

i've followed the tech support from cisco website inputted the configure commands to create the ATM0 and a Dialer0 but still having no joy.

this is the link to what i followed http://bit.ly/xLN3iB

when you log into the gui it only shows you a enable PPPoE tick box. no signs of PPPoA?

i can supply config file if you can help?

Regards

Kevin

  • WAN Routing and Switching
Everyone's tags (3)
20 REPLIES
Bronze

Cisco 887VA PPPoA BT ADSL setup?

Ensure that the RJ11 cale is connected to the atm interface on the router

information below mentioned in italic has to be either given by ISP or you can configure your own self

Router>en

Router#conf t

Router(config)#interface Vlan1

Router(config-if)#description internal interface

Router(config-if)#ip address 192.168.0.1 255.255.255.0

Router(config-if)#ip nat inside

Router(config-if)#no shut

OR (if you are using configurable internal Ethernet interface)

Router(config)#interface FastEthernet 0/1

Router(config-if)#description internal interface

Router(config-if)#ip address 192.168.0.1 255.255.255.0

Router(config-if)#ip nat inside

Router(config-if)#no shut

Router(config)#interface ATM0

Router(config-if)#no ip address

Router(config-if)#no atm ilmi-keepalive

Router(config-if)#dsl operating-mode auto ( check the mode with isp )

Router(config)#interface ATM0.1 point-to-point

Router(config-subif)#pvc 0/35(Either 0/35 or 8/35 depending upon the ISP)

Router(config-if-atm-vc)#pppoe-client dial-pool-number 1

( this is for binding ATM interface with a particular dialer interface )

Router(config)#interface dialer 0

Router(config-if)#ip address negotiated  (you need to know the ip is static is via dhcp from isp)

Router(config-if)#ip mtu 1492

Router(config-if)#ip nat outside

Router(config-if)#encapsulation ppp

Router(config-if)#dialer pool 1

Router(config-if)#ppp authentication chap pap callin ( Multiple options are there..we can choose auth method according to the situation )

Router(config-if)ppp pap sent-username USERNAME password P@ssw0rd (ISP given)

Router(config-if)#ppp chap hostname HOSTNAME (Username given by ISP)

Router(config-if)ppp chap password P@ssw0rd(password given by ISP)

Router(config-if)#no shut

Router(config)#access-list 101 permit ip 192.168.0.0 0.0.255.255 any

Router(config)#ip nat inside source list 101 interface dialer 0 overload

Router(config)#ip dhcp pool sdm-pool

Router(dhcp-config)#network 192.168.0.0 255.255.255.0

Router(dhcp-config)#dns-server Primary DNS IP address Secondary DNS IP address (obtained from your ISP)

Router(dhcp-config)#default-router 192.168.0.1 (internal VLAN or Ethernet interface Ip address)

Router(dhcp-config)#import all

Router(config)#ip route 0.0.0.0 0.0.0.0 dialer 0

Thank you

Ambuj

**Rate this doc if you find it helpful and help the community**

Bronze

Cisco 887VA PPPoA BT ADSL setup?

Also ensure that the BT device is set to bridge mode as the cisco router will do the layer 3 functionality and BT router will only act as a bridge to connect cisco router to the ISP.

New Member

Cisco 887VA PPPoA BT ADSL setup?

well i tried that and have more lights on the cisco. PPP light etc. but no internet.

"Also ensure that the BT device is set to bridge mode as the cisco router will do the layer 3 functionality and BT router will only act as a bridge to connect cisco router to the ISP."

i thought this router has a modem in it so i didnt need a BT modem????

Config file bellow......

Building configuration...

Current configuration : 6979 bytes

!

! Last configuration change at 11:32:16 PCTime Mon Mar 5 2012 by admin

version 15.1

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

service sequence-numbers

!

hostname cisco887va

!

boot-start-marker

boot-end-marker

!

!

security authentication failure rate 3 log

security passwords min-length 6

logging buffered 51200

enable secret 5 $1$9rXK$owX21yb5tqUbxBcGWqQal.

!

no aaa new-model

clock timezone PCTime 0 0

clock summer-time PCTime date Mar 30 2003 1:00 Oct 26 2003 2:00

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-281403735

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-281403735

revocation-check none

rsakeypair TP-self-signed-281403735

!

!

crypto pki certificate chain TP-self-signed-281403735

certificate self-signed 01

  30820229 30820192 A0030201 02020101 300D0609 2A864886 F70D0101 05050030

  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 32383134 30333733 35301E17 0D313230 32323331 35313532

  345A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F

  532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3238 31343033

  37333530 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100

  E466BC6A 54918147 BDE8C2D5 6A76BC80 A1345602 F2BA37CD 566DC853 29B706D2

  C7F8C29D AEE97447 24D29ADE 8B13E148 92DB224B C6B44C04 D43F4451 F307574F

  E3A91DAF DF190622 F83C5338 C8EF7BC3 075D702B CCC9FE15 F8B747B7 6FDB42D5

  66DE2833 27E01B04 DBC10F04 37B42916 956E8E71 3CEE9F42 AD07929E 7FB2796D

  02030100 01A35330 51300F06 03551D13 0101FF04 05300301 01FF301F 0603551D

  23041830 168014E1 6D333CE0 FCA77CA0 A1998D9C E08C8D94 7C8D8230 1D060355

  1D0E0416 0414E16D 333CE0FC A77CA0A1 998D9CE0 8C8D947C 8D82300D 06092A86

  4886F70D 01010505 00038181 008F31D1 8E5368E7 1838D3CC 111751E1 587B17A1

  24112A77 D90B7A70 30178A2E 6D65AA93 76FAAA41 83827500 72C69878 B9BDBB44

  3C62FCE9 51B3319D 0F3989C2 BBA2DEFB 40F00FE7 6DAE1A1D 65547428 DC7DD75B

  4A41BFB4 D85626C2 130424DD AD834673 E92E5FEE 737A89CC 50D5E5CC 927AAEDB

  18143149 E38E2E7C 6DB15EC1 01

            quit

no ip source-route

ip cef

!

!

!

ip dhcp excluded-address 192.168.222.1 192.168.222.200

ip dhcp excluded-address 192.168.222.4

!

ip dhcp pool ccp-pool1

import all

network 192.168.222.0 255.255.255.0

dns-server 208.67.222.222 208.67.220.220

default-router 192.168.222.4

!

ip dhcp pool almailing

default-router 192.168.222.4

dns-server 208.67.222.222 208.67.220.220

!

ip dhcp pool sdm-pool

import all

default-router 192.168.222.4

!

!

no ip bootp server

ip domain name al-mailing.co.uk (not sure)

ip name-server 208.67.222.222

ip name-server 208.67.220.220

no ipv6 cef

!

!

license udi pid C887VA-W-E-K9 sn FCZ1606C0A1

!

!

username admin privilege 15 secret 5 $1$MrNS$1xkjb5XPv.lelb/EG00HK1

!

!

!

!

controller VDSL 0

!

ip tcp synwait-time 10

ip ssh time-out 60

ip ssh authentication-retries 2

!

!

!

!

!

!

!

interface ATM0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

no atm ilmi-keepalive

pvc 0/38

  encapsulation aal5mux ppp dialer

  dialer pool-member 1

!

!

interface ATM0.1 point-to-point

!

interface Ethernet0

description $FW_OUTSIDE$$ES_WAN$

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

ip virtual-reassembly in

pppoe-client dial-pool-number 2

!

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface Wlan-GigabitEthernet0

description Internal switch interface connecting to the embedded AP

no ip address

!

interface wlan-ap0

description Embedded Service module interface to manage the embedded AP

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$

ip address 192.168.222.4 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

ip tcp adjust-mss 1412

!

interface Dialer0

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

ppp authentication chap pap callin

ppp chap hostname "ISP USERNAME"

ppp chap password 7 0305570607062D45400E48

ppp pap sent-username "ISP USERNAME password 7 094D4204180C1B1B050B55

no cdp enable

!

interface Dialer1

no ip address

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

ppp chap hostname "ISP USERNAME"

ppp chap password 7 0607032C4D4705100B1043

ppp pap sent-username "ISP USERNAME" password 7 0305570607062D45400E48

no cdp enable

!

interface Dialer2

ip address negotiated

ip mtu 1452

encapsulation ppp

dialer pool 2

dialer-group 1

ppp authentication chap callin

ppp chap hostname "ISP USERNAME"

ppp chap password 7 020708560A0F0328424958

no cdp enable

!

ip forward-protocol nd

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip nat inside source list 1 interface Dialer1 overload

ip nat inside source list 101 interface Dialer0 overload

ip route 0.0.0.0 0.0.0.0 Dialer0

ip route 0.0.0.0 0.0.0.0 Dialer1

!

logging trap debugging

access-list 1 permit 192.168.222.4

access-list 101 permit ip 192.168.0.0 0.0.255.255 any

access-list 101 permit ip 0.0.0.0 255.255.255.0 any

dialer-list 1 protocol ip permit

no cdp run

!

!

!

!

banner exec ^CCCC

% Password expiration warning.

-----------------------------------------------------------------------

Cisco Configuration Professional (Cisco CP) is installed on this device

and it provides the default username "cisco" for  one-time use. If you have

already used the username "cisco" to login to the router and your IOS image

supports the "one-time" user option, then this username has already expired.

You will not be able to login to the router with this username after you exit

this session.

It is strongly suggested that you create a new username with a privilege level

of 15 using the following command.

username privilege 15 secret 0

Replace and with the username and password you

want to use.

-----------------------------------------------------------------------

^C

banner login ^CCCCAuthorized access only!

Disconnect IMMEDIATELY if you are not an authorized user!^C

!

line con 0

login local

transport output telnet

line aux 0

login local

transport output telnet

line 2

no activation-character

no exec

transport preferred none

transport input all

stopbits 1

line vty 0 4

privilege level 15

login local

transport input telnet ssh

!

scheduler allocate 20000 1000

scheduler interval 500

end

Hall of Fame Super Gold

Re: Cisco 887VA PPPoA BT ADSL setup?

You have entered a PPPoA configuration. I'm not aware of BT using PPPoA

Search for PPPoE configuration, and change to it.

Otherwise, take "show dsl interface",

New Member

Cisco 887VA PPPoA BT ADSL setup?

The only information BT will provide me as Cisco is a third party router is my settings should be:

1. ATM Encapsulation PPPoA/VCMUX

2. Modulation-G.DMT

3. VPI-0

4. VCI-38

5. Authentication Method-CHAP

Kevin

Hall of Fame Super Gold

Cisco 887VA PPPoA BT ADSL setup?

Please take "show dsl interface" and "debug ppp negotiation" "debug ppp authentication" with "term mon". For these, reset the line, eg shut/no shut atm interfacce.

Bronze

Cisco 887VA PPPoA BT ADSL setup?

1.remove the atm interface config first

en

conf t

default int atm0

2.paste the config below.

interface Dialer0

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

ppp authentication chap pap callin

ppp chap hostname "ISP USERNAME"

ppp chap password 7 0305570607062D45400E48

ppp pap sent-username "ISP USERNAME password 7 094D4204180C1B1B050B55

no cdp enable

!

interface ATM0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

no atm ilmi-keepalive

dsl operating-mode auto

interface ATM0.1 point-to-point

  pvc 0/38

  encapsulation aal5mux ppp dialer

  dialer pool-member 1

3.check if the dialer has Ip , if it has ip ping 4.2.2.2 from the router .

4.if dialer do not have ip , do debug ppp negotiaion and see if it is receiving confack (I) alsong with sending confreq (O)

If it doesnt work , call cisco Tac and open up a case , it should be 10 minutes job , once we have webex to your router.

New Member

Cisco 887VA PPPoA BT ADSL setup?

Hi Kevin Rock

I was wondering if you managed to get your Cisco router working with your BT connection as I have similar issues that you experienced up to your original post.  I'm fairly new to the configuration of the Cisco routers especially the Cisco 887VA but thanks to your posts I have been able to get the device connected with our BT ADSL2+ connection but we are not able to browse external websites.  We have contacted BT who have verified the device is connected and synchronised on their network and they are unsure as to why we are experiencing issues.  BT have provided us with 194.72.9.34 and 194.72.9.38 as the DNS server addresses for our connection but we are still unable to access sites.

Does anyone know from the configuration below why we would be experiencing these issues?

Thanks

version 15.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

logging buffered 51200 warnings

!

no aaa new-model

memory-size iomem 10

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-1532457153

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1532457153

revocation-check none

rsakeypair TP-self-signed-1532457153

!

!

crypto pki certificate chain TP-self-signed-1532457153

certificate self-signed 01

  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 31353332 34353731 3533301E 170D3132 30363138 31343232

  35335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 35333234

  35373135 3330819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  81009858 4796F26F 5F75079F DDDE1798 72B9DB04 C6F43166 423539AC F1F7F9A8

  A2197CD8 EE8296CF AA92F33C BB8B35B8 BF4F95B7 78631694 5F159102 46D98254

  78EF9FD3 CE922C81 DD91F9B6 079BFEE0 811E27E6 47136C85 C7B4F60C 41F3E225

  7E3A36E3 5C368194 C369A713 622E972E 52E657F0 6294F0E6 6B6A270F 0F45B936

  9A8B0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603

  551D2304 18301680 142B01F3 5D46E646 A116F705 CA54ACBA 5D511086 42301D06

  03551D0E 04160414 2B01F35D 46E646A1 16F705CA 54ACBA5D 51108642 300D0609

  2A864886 F70D0101 05050003 81810045 42DB1E4A 1F315511 6FD01294 1FD85143

  FC2BBE42 F12994FF 8F382B39 1C766261 D147902D DE14346A 73735870 7A0038C9

  7782F54C 70C063A7 7460F71D 4C0DAAF2 1C37F9A8 203E1558 D9D79593 72BE1656

  CB08DD09 8068869A 4D704596 6CE48B7F D48C5D10 E756D149 42F8BC4E 59DFB04B

  2EEBFE3B 0B87723D 7AFC36E9 D268C2

                quit

!

!

!

ip dhcp excluded-address 192.168.2.1

!

ip dhcp pool ccp-pool

network 192.168.2.0 255.255.255.0

default-router 192.168.2.1

!

ip dhcp pool ccp-pool1

!

!

ip name-server 194.72.9.34

ip name-server 194.72.9.38

ip cef

no ipv6 cef

!

!

license udi pid CISCO887VA-K9 sn FCZ161993JL

!

!

username ************* privilege 15 secret 5 **************

!

!

!

!

!

controller VDSL 0

operating mode adsl2+

!

no ip ftp passive

!

!

!

!

!

!

!

!

!

interface Ethernet0

no ip address

!

interface ATM0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

no atm ilmi-keepalive

!

interface ATM0.1 point-to-point

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

!

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface Vlan1

ip address 192.168.2.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

!

interface Dialer0

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

  ppp authentication chap callin

ppp chap hostname ***********@hg7.btclick.com

ppp chap password 0 ***********

ppp pap sent-username **********@ht7.btclick.com password 0 *********

no cdp enable

!

interface Dialer1

no ip address

ip nat outside

ip virtual reassembly in

encapsulation ppp

dialer pool 1

ppp chap hostname **********@hg7.btclick.com

ppp chap password 0 **********

ppp pap sent-username **********@ht7.btclick.com password 0 *********

no cdp enable

!

interface Dialer2

ip address negotiated

ip mtu 1452

encapsulation ppp

dialer pool 2

dialer-group 1

ppp authentication chap callin

ppp chap hostname *******@hg7.btclick.com

ppp chap password 0 **********

no cdp enable

!

ip forward-protocol nd

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip nat inside source list 1 interface Dialer1 overload

ip nat inside source list 101 interface Dialer0 overload

ip route 0.0.0.0 0.0.0.0 Dialer0

ip route 0.0.0.0 0.0.0.0 Dialer1

!

logging trap debugging

access-list 1 permit any

access-list 2 remark INSIDE_IF=Vlan1

access-list 2 remark CCP_ACL Category=2

access-list 2 permit 192.168.2.0 0.0.0.255

dialer-list 1 protocol ip permit

no cdp run!

!

line con 0

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet

!

end

Hall of Fame Super Gold

Cisco 887VA PPPoA BT ADSL setup?

Remove all dialer interfaces except one, remove one NAT access-list, change NAT ACL to list your internal network, try again.

27023
Views
8
Helpful
20
Replies