Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 888 router clients internet access problem

Hi All,

I have a Cisco 888 router that is connected to a 8 port  non-cisco switch. I have WAN/DHCP configured on the router and the switch is non smart and programmable..

The issus that none of the client machines can access the Internet.They can take an ip from router but doesn t have internet.I try to ping 8.8.8.8 etc but doesn t work. From within the router console, I am able to ping external domain names, my ISP DNS servers.We have static ip from the ISP

Client machines can ping the Cisco router IP.

I have checked google looking for an answer on why, but I am missing something I just don't know why. Any help would be helpful.

Thanks,

Here is the config

ip source-route

!

!

ip dhcp excluded-address 192.168.1.1 192.168.1.10

!

ip dhcp pool akk

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.1

   dns-server 195.175.39.39 195.175.39.40

   lease 0 1 50

!

!

ip cef

ip name-server 195.175.39.39

ip name-server 195.175.39.40

no ipv6 cef

!

!

license udi pid CISCO888-K9 sn FCZ1516C02R

!

!

username xx privilege 15 password 0 cisco

!

!

controller DSL 0

mode atm

dsl-mode shdsl symmetric annex B

line-rate 2048

!

!

!

!

!

!

!

!

interface BRI0

no ip address

encapsulation hdlc

shutdown

isdn termination multidrop

!

interface ATM0

no ip address

no atm ilmi-keepalive

pvc 8/35

pppoe-client dial-pool-number 1

!

!

interface ATM0.1 point-to-point

ip address 88.222.222.22 255.255.255.248

atm route-bridged ip

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSID

ip address 192.168.1.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

!

interface Dialer0

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication pap callin

ppp pap sent-username aaaa@net password 0 1111

ppp ipcp dns request

no cdp enable

!

ip forward-protocol nd

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip dns server

ip nat inside source list 1 interface Dialer0 overload

ip route 0.0.0.0 0.0.0.0 Dialer0

!

access-list 1 permit 192.168.1.0 0.0.0.255

access-list 1 remark INSIDE_IF=vlan1

access-list 1 remark CCP_ACL category=2

access-list 100 permit ip 192.168.1.0 0.0.0.255 any

dialer-list 1 protocol ip permit

no cdp run

!

!

!

!

!

control-plane

!

!

line con 0

no modem enable

line aux 0

line vty 0 4

privilege level 15

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Cisco 888 router clients internet access problem

Hello Kubilay,

>> We have static ip from the ISP

if you access the internet using ATM0.1 subinterface you need to change your NAT statement in :

ip nat inside source list 1 interface ATM0.1 overload

interface ATM0.1

ip nat outside

but you would need also a default  static route using ATM0.1 instead of dialer0

ip route 0.0.0.0 0.0.0.0 ATM0.1

it is not clear.How do you access the internet?

with PPPoE over ATM on pvc8/35 or by using subinterface ATM0.1?

Hope to help

Giuseppe

5 REPLIES
Hall of Fame Super Silver

Re: Cisco 888 router clients internet access problem

Hello Kubilay,

>> We have static ip from the ISP

if you access the internet using ATM0.1 subinterface you need to change your NAT statement in :

ip nat inside source list 1 interface ATM0.1 overload

interface ATM0.1

ip nat outside

but you would need also a default  static route using ATM0.1 instead of dialer0

ip route 0.0.0.0 0.0.0.0 ATM0.1

it is not clear.How do you access the internet?

with PPPoE over ATM on pvc8/35 or by using subinterface ATM0.1?

Hope to help

Giuseppe

New Member

Cisco 888 router clients internet access problem

Hello Giuseppe,

Thanks for your replay.Actualy  I'm not sure about whichone we are using for access internet.ISP sent a examp. config for me and i applied it to us.I'll try your suggest and replay back.

Thank you

New Member

Cisco 888 router clients internet access problem

Thank you soo much Dear Giuseppe..

Best Wishes

Hall of Fame Super Silver

Cisco 888 router clients internet access problem

Hello Kubilay,

thanks for rating, just for information your internet access is via the ATM0.1 subinterface?

Because the changes i have proposed were done under this hyphotesis starting from your note about static IP address from ISP.

Best Regards

Giuseppe

New Member

Cisco 888 router clients internet access problem

Dear Giuseppe,

yess our internet access is via ATM0.1 subinterface.And i added your suggested ip nat as"ip nat inside source list 101 interface Dialer0 overload".After that everyhthing working fine.

1303
Views
0
Helpful
5
Replies