Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco EHWIC-4G-LTE-G

Hi,

I was wondering if anyone has managed to sucessfully configure the EHWIC-4G-LTE-G network module for use on the O2-UK network?

I am succesfully registering to o2 (network 10) in the uk (country 234) without roaming (home):

#sh cellular 0/0/0 network
Current Service Status = Normal
Current Service = Packet switched
Current Roaming Status = Home
Network Selection Mode = Automatic
Mobile Country Code (MCC) = 234
Mobile Network Code (MNC) = 10
Packet switch domain(PS) state = Attached
Registration(EMM) state = Registered

And I have a really good 3G (UMTS) signal (-31dBm is like 5 bars):

#sh cellular 0/0/0 radio
Radio power mode = ON
Current RSSI(RSCP) = -31 dBm
LTE Technology Preference = AUTO
LTE Technology Selected = UMTS

But the profile won't stay active.

If I ping an address on the internet like 8.8.8.8, the default route and chat-script bring the modem online and if I very quickly view the profile it does become active:

#sh cellular 0/0/0 profile
Profile 1 = ACTIVE*
--------
PDP Type = IPv4
PDP address = 10.122.1.178
Access Point Name (APN) = mobile.o2.co.uk
Authentication = Unknown
Username: bypass
Password:
        Primary DNS address = 82.132.254.2
        Secondary DNS address = 82.132.254.3

However, after a few seconds it always reverts back to the inactive state:

#sh cellular 0/0/0 profile
Profile 1 = INACTIVE*
--------
PDP Type = IPv4
Access Point Name (APN) = mobile.o2.co.uk
Authentication = Unknown
Username: bypass
Password:

This is repeatable and I have tried vertigo, bypass and o2web as different APNs. Here is the profile configuration I'm using:

#cellular 0/0/0 lte profile create 1 mobile.o2.co.uk pap bypass password ipv4

I have also tried a variety of chat-scripts like:

chat-script modem "" "AT!CALL1" TIMEOUT 30
chat-script modem "" "ATDT*99*1#" TIMEOUT 60 "OK"
chat-script modem "" "ATDT*99*1#" TIMEOUT 60 "CONNECT"
chat-script modem "" "ATDT*99***1#" TIMEOUT 60 "CONNECT"

To no avail. Here is the debug output that does not look good:

*Dec 23 16:10:56.907: CHAT0/0/0: Attempting async line dialer script
*Dec 23 16:10:56.907: CHAT0/0/0: process started
*Dec 23 16:10:56.907: CHAT0/0/0: Asserting DTR
*Dec 23 16:10:56.907: TTY0/0/0: no timer type 1 to destroy
*Dec 23 16:10:56.907: TTY0/0/0: no timer type 0 to destroy
*Dec 23 16:10:56.907: TTY0/0/0: no timer type 2 to destroy
*Dec 23 16:10:57.063: TTY0/0/0: DSR was dropped
*Dec 23 16:10:57.063: tty0/0/0: Modem: READY->(unknown).
*Dec 23 16:10:58.063: TTY0/0/0: dropping DTR, hanging up
*Dec 23 16:10:58.063: TTY0/0/0: Async Int reset: Dropping DTR

For reference, here is the rest of the configuration:

interface Cellular0/0/0
ip address negotiated
encapsulation slip
dialer in-band
dialer idle-timeout 0
dialer string modem
dialer-group 1
async mode interactive
end
!
ip route 0.0.0.0 0.0.0.0 Cellular0/0/0
!
dialer-list 1 protocol ip permit
!
line 0/0/0
exec-timeout 0 0
script dialer modem
modem InOut
no exec
!

Any suggestions much appreciated.

Many thanks,
Jonny

7 REPLIES
New Member

Re: Cisco EHWIC-4G-LTE-G

For anyone who is interested, below is my working solution. The trick was to create a dialer interface with PPP encpasulation and join it to the cellular interface which has SLIP encapsulation:

!

ip dhcp pool LAN

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 8.8.8.8 8.8.4.4

!

chat-script lte "" "AT!CALL1" TIMEOUT 30 "OK"

!

interface GigabitEthernet0/0

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

duplex auto

speed auto

!

interface Cellular0/0/0

ip address negotiated

ip nat outside

ip virtual-reassembly in

encapsulation slip

dialer in-band

dialer pool-member 1

dialer-group 1

async mode interactive

routing dynamic

!

interface Dialer1

ip address negotiated

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

dialer idle-timeout 0

dialer string lte

dialer persistent

dialer-group 1

ppp authentication pap callin

ppp pap sent-username o2web password 0 password

ppp ipcp dns request

!

ip nat inside source list 1 interface Dialer1 overload

ip route 0.0.0.0 0.0.0.0 Dialer1

!

access-list 1 permit ip any

dialer-list 1 protocol ip permit

!

line 0/0/0

script dialer lte

modem InOut

no exec

transport input all

transport output all

rxspeed 100000000    <-- Max LTE download speed populated automatically

txspeed 50000000     <-- Max LTE upload speed populated automatically

!

      

As you can see the 10.x address assigned by o2 goes onto the Dialer interface instead:

GigabitEthernet0/0         192.168.1.1     YES NVRAM  up                    up

Cellular0/0/0              unassigned      YES NVRAM  up                    up

Cellular0/0/1              unassigned      YES unset  down                  down

Cellular0/0/2              unassigned      YES unset  down                  down

Cellular0/0/3              unassigned      YES unset  down                  down

Dialer1                    10.65.98.14     YES IPCP   up                    up

NVI0                       192.168.1.1     YES unset  up                    up

These lines are also required but are the same as before:

#cellular 0/0/0 lte profile create 1 mobile.o2.co.uk pap o2web password ipv4
#cellular 0/0/1 lte profile create 1 mobile.o2.co.uk pap o2web password ipv4  <-- Necessary for some reason

#(config)interface cellular 0/0/0
#(config-if)#no shutdown
#(config)interface cellular 0/0/1
#(config-if)#shutdown

New Member

This configuration works

This configuration works better than the cellular based one, however, i'm working with the 881G-4G /LTE version, and when CEF is configured, packets from a PC connected to the LAN or routed port are erratic (bellow 50% success).

Turning off CEF, works fine.

I've tried several IOS including major and training version with the same result.

has anyone have this issue? help?

New Member

I have also experienced 50%

I have also experienced 50% packet loss over Cisco 4G modems before (normally after initial config) and never got to the bottom of it but a reboot always resolved it and it didn't normally return. Are you sure, re-enabling CEF brings the problem back? My packet loss was almost exactly 50% so I knew it was probably the router and not the radio link being flaky. 

New Member

Hi, Jonathan.Thank you very

Hi, Jonathan.

Thank you very much for your input.

By rebooting the router it doesn't improve. The symptom is the same.

If CEF is enabled, the PING responds close to 50% (one ok, one nok).

CEF improves routing performance and with 4G bandwitdh available, when it's disabled (CEF), it could mean some performance degradation.

I dind't open a case yet, but I'm affraid that Cisco will recomend to remove dialer configuration.

Dialer configuration allows "allways on" configuration in 4G access. For a provider, that's relevant.

 

Regards,

Hi Santosnun, Did you get

Hi Santosnun,

 

Did you get anywhere with the case? I have the same thing and reboot does not help. When I turn on debug ip cef drop I see CEF is dropping the packets because of missing adjacency. 

 

Many thanks in advance,

Bud

New Member

Yes in the end this was

Yes in the end this was resolved by going to IOS 15.3 on the router; it appears to be a bug on IOS 15.2 which effects CEF.

New Member

We're using 15.4 and the

We're using 15.4 and the problem persists...

3067
Views
0
Helpful
7
Replies