Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Cisco Prime Infrastructure 2.1 Upgrade from 1.3.0.20

Hi,

We have a full fledged CPI 1.3.0.20 running with about 150-200 buildings worth of wireless data. We need to upgrade it to 2.1 version to make use of the 702W APs WPPs. The upgrade is failing in a boot loop again and again no matter what we do. We have setup CPI as a vm on vmware esxi 5.1. See the brief below of what we have tried:

Option 1: Inline upgrade: installed the patch on 1.3.0.20 (required for upgrade to 2.1), then download and install 2.1 upgrade file on it, and after it finishes the installation and goes for reboot, it starts boot loop.

Option 2: Migration option, Create a vm ova template on the esxi host for the 2.1 install from scratch. but here also, when its reboots after the final installtion, it ends up with the same boot loop. Has someone experienced this before, or atleast something you might want to share regarding this would be great.

Thanks

Lovleen

3 REPLIES
Community Member

We have also 1.3.0.20 running

We have also 1.3.0.20 running before. Since we will have to deploy new AP and need to able to synchronize with new code (7.6.110.0) in WLC, so we decided to upgrade CPI to 2.1.0.0.87.

Before the upgrade, we followed the procedure to apply the patch PI_1_3_0_20-Update.4-16.tar.gz. It succeeded (around 10 mins). Then we started to upgrade with the file PI-upgrade-bundle-2.1.0.0.87.tar.gz. It started with no problem, message showed that there will be 7 stages and it will be rebooted after the upgrade completed. However, it was running more than 16 hours, and still hailed at stage 6 (updating database schema), and showed no response at all.

Eventually it showed the upgrade is unsuccessful, and no way to restart the service, but only to reinstall from stretch, and then restore from backup data.

"ERROR: The last upgrade operation was unsuccessful. See dbadmin_StdOut.log for details. To recover, reinstall the server and restore the saved backup data."

It's way more complicated than it should be for doing the upgrade. 

sad Disappointed. Still waiting Cisco TAC to give me help on this.

Sunny

Community Member

Well, although it failed in

Well, although it failed in the test/dev  environment, but we successfully upgraded in the production environment, as we tried it in parallel with the running CPI, and only tuned it off, once we were happy with the 2.1 system

So, what we did, deploy 2.1 ova standard version, and use thin provisioning, and it installed ok, although it took about 20-30 minutes after the installing ncs stage and it looked it was in boot loop, but i left it for some time, and it was all fine after about 30 minutes at that stage, I think it boots it self up few time to install some services etc.

Then I ran a backup on the original CPI 1.3 after installing the patch file (required for restore to a 2.1 system), aand used that backup to restore onto the new CPI2.1 system.

I followed exactly as it was in the Cisco 2.1 documentation.. I suspect the vmware infrastructure in our test/dev might be the reason (as the available resources were just enough for the ova system requirements).  for the first time boot loop issue that we had, and we had also used thick provisioning that time..

Can you try a thin provisioning install and then see if you have any luck.

 

Give it enough time when you see it is boot loop, it might be more time based on your network infrastructure.

 

The above process in this comment, I have double verified it 2 times, and both times was like smooth as.

Good Luck. Let me know how you go on.

L

Community Member

Well, although it failed in

test

336
Views
0
Helpful
3
Replies
CreatePlease to create content