Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco Router 2811 Configuration

Hi

I have netgear modem i want to connet Cisco Router 2811 for natting. So what are the commands to configure the router. I got all the details for ADSl connection which provided by the ISP. i need step by step commands so that i can configure the router for natting purpose.

I want to bring another 2 computers on the network through the cisco 2811 router.

Thanks

6 REPLIES

Re: Cisco Router 2811 Configuration

New Member

Re: Cisco Router 2811 Configuration

1. create your pool

ip nat pool netmask

2. create access-list taht will allow your private address to be nat'ed

access-list 1 permit 192.168.1.0 0.0.0.255

3. do static translation if any needed

ip nat inside source static

4.inform your interfaces

int e0

ip nat inside

int s0

ip nat outside

5-start your nat

ip nat inside source list 1 pool [overload]

overload is optional if you have only one public ip address

i hope that helped...

New Member

Re: Cisco Router 2811 Configuration

ip nat pool testing 192.168.0.1 netmask 255.255.255.0

access-list 1 permit 192.168.0.1 255.255.255.0

int e0

ip nat inside

ip nat inside source list 1 pool testing

============================================

I tried above commands still not working.

My modem is on bridge mode. Where should i do ISP authentication.

=============================================

Here is the connectivity details.

1. Netgear Modem

2. Cisco 2811 Router connected to Netgear Modem via crossover cable.

3. From the router its connected to catalyst 3560.

==============================================

Can you please suggest how do i bring router and PCs on net.

Thanks

========================

Bronze

Re: Cisco Router 2811 Configuration

Hi,

To make ur router do the isp authentication

Step1:

!

Interface serial #connection to modem

description ADSL Internet connection

no ip address

duplex auto

speed auto

pppoe enable

pppoe-client dial-pool-number 1

no cdp enable

!

Step2

interface Dialer1

ip address dhcp # if u have static ip from ISP configure it#

ip nat outside

no ip redirects

no ip unreachables

no ip proxy-arp

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname #####

ppp chap password 7 #######

!

Step 3: Nat and default route

(config)#ip route 0.0.0.0 0.0.0.0 dialer 1

(config)#access-list 10 permit 192.168.0.0 0.0.0.255

(config)#ip nat inside source list 10 interface dialer1 overload

u already have the ip nat inside command on

ur int e0

Hope this helps

Thanks

Raj

New Member

Re: Cisco Router 2811 Configuration

Thanks for replying

When i am applying the above given commands i am getting error.

=============================================router#config t

Enter configuration commands, one per line. End with CNTL/Z.

router(config)#pppoe enable

^

% Invalid input detected at '^' marker.

router(config)#pppoe-client dial-pool-number 1

^

% Invalid input detected at '^' marker.

router(config)#^Z

router#

*Oct 9 22:25:15.958: %SYS-5-CONFIG_I: Configured from console by rafay on conso

le

router#pppoe-client dial-pool-number 1

% Invalid input detected at '^' marker.

router#

=============================================

what is the reason?

Thanks

Hall of Fame Super Bronze

Re: Cisco Router 2811 Configuration

Abdul,

'pppoe enable' is an interface command, not a global config command.

For further info on PPPoE implementation please read

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121newft/121t/121t2/dtpppofe.htm

_____

Please rate helpful posts.

Thanks

1869
Views
0
Helpful
6
Replies