Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

cisco router 871 no internet access

i am studying and practising fo my ccnent and am very new to cisco routers and so far have been doing well until i tried to gain internet access. i have a 871 router that has a catalyst 2950 switch connected to it. connected to the switch is this computer, a cascaded router and a network external hdd. connected to the cascaded router is a xbox, ps3 and another computer. from both computers i can ping the router and the switch but i cannot reach beyond the router to the lynksis router i used to connect my network to. also pingin one computer from the other give me "destination host unreachable"

this is my running config. thanks in adv for any advice

Building configuration...

Current configuration : 3045 bytes

!

! Last configuration change at 11:25:35 UTC Wed Jan 1 2014

! NVRAM config last updated at 11:25:45 UTC Wed Jan 1 2014

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname VanRouter

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

enable secret 5 $1$0tzK$iA3tCXqYHVOHPrM1N2yig0

!

no aaa new-model

!

crypto pki trustpoint TP-self-signed-3288281326

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-3288281326

revocation-check none

rsakeypair TP-self-signed-3288281326

!

!

crypto pki certificate chain TP-self-signed-3288281326

certificate self-signed 02

  30820241 308201AA A0030201 02020102 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 33323838 32383133 3236301E 170D3134 30313031 31313232

  33365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 32383832

  38313332 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100CD3C D7B45599 C442BB9F 7C407C6F 4443DE93 C266494F 5DEE207B 66C9E95A

  A6D99B5F 2880A97E DBB0FB69 745870BA BF29BEE6 23242A17 A271AAAE 48349CCA

  1541878C 5E4EACBB 91C66093 86663331 BA816DB4 6029C7FF 6229F2F3 FE81F9AE

  A0C89C66 DEAE6AE5 BF372DB7 C8F3E6D5 ED28DC8E C06B60BD 06EC0985 DDF58C07

  AC8D0203 010001A3 69306730 0F060355 1D130101 FF040530 030101FF 30140603

  551D1104 0D300B82 0956616E 526F7574 6572301F 0603551D 23041830 16801483

  6BC919AF 05465D05 D3C5E672 D7B0841A 91CEBC30 1D060355 1D0E0416 0414836B

  C919AF05 465D05D3 C5E672D7 B0841A91 CEBC300D 06092A86 4886F70D 01010405

  00038181 002F41E8 36B37541 BA660122 148D3F06 8CADBD62 7E26F5A6 506A60EC

  58F5C139 B8DE5B32 CC1B258B 57988841 3123227F B69D432D 52CC836F 5E51DE5C

  C4B01B53 16F4CC5A BEC27BC0 83AD91B5 54C95549 1F56181C E3901360 32A14551

  18F92BB0 2000BFB9 E29536AF 223F032A 683B8E66 9E554E02 D1E7F631 704A66F6

  222590DC B5

        quit

dot11 syslog

ip source-route

!

!

ip dhcp excluded-address 192.168.100.1 192.168.100.10

!

ip dhcp pool van

   network 192.168.100.0 255.255.255.0

   default-router 192.168.100.1

   dns-server 8.8.8.8 8.8.4.4

!

!

ip cef

no ip domain lookup

ip name-server 8.8.8.8

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

username van privilege 15 password 0 van

!

!

!

archive

log config

  hidekeys

!

!

!

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

ip address dhcp

duplex auto

speed auto

!

interface Vlan1

ip address 192.168.100.1 255.255.255.0

!

ip forward-protocol nd

ip http server

ip http authentication local

ip http secure-server

!

!

!

!

!

!

!

!

control-plane

!

!

line con 0

password van

logging synchronous

no modem enable

line aux 0

line vty 0 4

privilege level 15

password vantel

logging synchronous

login local

transport input telnet ssh

!

scheduler max-task-time 5000

end

VanRouter#

Everyone's tags (4)
2 ACCEPTED SOLUTIONS

Accepted Solutions
New Member

Re: cisco router 871 no internet access

If you can ping from the router out then you should be able to ping from the PC out. Try to source your pings from the VLAN 1 interface IP on your router and see if that works.
Also, you don't need these static routes:
Ip route 0.0.0.0 0.0.0.0 71.246.236.11
ip route 0.0.0.0 0.0.0.0 10.1.41.79
ip route 192.168.0.0 255.255.255.0 192.168.1.1
ip route 192.168.1.0 255.255.255.0 192.168.1.1
ip route 192.168.100.0 255.255.255.0 192.168.100.2

If you don't want to turn up static routing you could possibly get the routes from RIP on the Linksys. You would need to have access to the Linksys though.

At the end of the day, you most likely will need to setup NAT on the interface going towards the Linksys and the VLAN1 interface and then overload:

Int fa 0/4
ip NAT outside

Int vlan1
ip NAT inside

Access-list 10
Permit 192.168.100.0 0.0.0.255

ip nat inside source list 10 interface fa 0/4 overload


Sent from Cisco Technical Support iPhone App

New Member

Re: cisco router 871 no internet access

Hi,

try to add NAT to yout device. Something like this...

int fa4

ip nat outside

int vlan 1

ip nat inside

access-list 1 permit 192.168.100.0 0.0.0.255

ip nat inside source list 1 interface FastEthernet4 overload

6 REPLIES
Purple

cisco router 871 no internet access

Hi,

but i cannot reach beyond the router to the lynksis router i used to  connect my network to. also pingin one computer from the other give me  "destination host unreachable"

Is fa4 connected to this Linksys router which is acting as DHCP server?

PC connected to 2950 has 871 as default gateway? and computer on other router has the router as default gateway.

so PC on 2950 sends traffic to 871 which has no route to second computer and sends a destination host unreachable.

on this PC you can configure a static route for the second computer subnet pointing towards the router where this destination PC is connected with the route add  x.x.x.x mask x.x.x.x y.y.y.y  -p command  where

x.x.x.x is destination subnet  and  the destination subnet mask and y.y.y.y is the router IP in same subnet as the source PC, -p is to make the entry a permanent entry

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Re: cisco router 871 no internet access

first off thank you for your help.

yes fa4 is connected to linksys router and i manual set fa4 to 192.168.1.105 which was the ip address that was given to the cisco router

ipconfig from this PC shows default gateway is 192.168.100.1 cisco router

my network 192.168.100.0 is connected to my uncles network 192.168.1.0 through the lynksis router 192.168.1.1

the cisco router is given an ip 192.168.1.105

how would i setup static routes to get out to the internet with this physical setup?

would i use my public ip from whatsmyip.com in the setup?

i can now ping out from the cisco router to googles ip.

cant ping from this PC out.

Would not setting up NAT prevent me from pinging out from this PC?

this is updated running conf

VanRouter#show run

Building configuration...

Current configuration : 3415 bytes

!

! Last configuration change at 11:45:53 UTC Sun Jan 5 2014

! NVRAM config last updated at 09:03:38 UTC Sun Jan 5 2014

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname VanRouter

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

enable secret 5 $1$0tzK$iA3tCXqYHVOHPrM1N2yig0

!

no aaa new-model

!

crypto pki trustpoint TP-self-signed-3288281326

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-3288281326

revocation-check none

rsakeypair TP-self-signed-3288281326

!

!

crypto pki certificate chain TP-self-signed-3288281326

certificate self-signed 02

  30820241 308201AA A0030201 02020102 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 33323838 32383133 3236301E 170D3134 30313031 31313232

  33365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 32383832

  38313332 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100CD3C D7B45599 C442BB9F 7C407C6F 4443DE93 C266494F 5DEE207B 66C9E95A

  A6D99B5F 2880A97E DBB0FB69 745870BA BF29BEE6 23242A17 A271AAAE 48349CCA

  1541878C 5E4EACBB 91C66093 86663331 BA816DB4 6029C7FF 6229F2F3 FE81F9AE

  A0C89C66 DEAE6AE5 BF372DB7 C8F3E6D5 ED28DC8E C06B60BD 06EC0985 DDF58C07

  AC8D0203 010001A3 69306730 0F060355 1D130101 FF040530 030101FF 30140603

  551D1104 0D300B82 0956616E 526F7574 6572301F 0603551D 23041830 16801483

  6BC919AF 05465D05 D3C5E672 D7B0841A 91CEBC30 1D060355 1D0E0416 0414836B

  C919AF05 465D05D3 C5E672D7 B0841A91 CEBC300D 06092A86 4886F70D 01010405

  00038181 002F41E8 36B37541 BA660122 148D3F06 8CADBD62 7E26F5A6 506A60EC

  58F5C139 B8DE5B32 CC1B258B 57988841 3123227F B69D432D 52CC836F 5E51DE5C

  C4B01B53 16F4CC5A BEC27BC0 83AD91B5 54C95549 1F56181C E3901360 32A14551

  18F92BB0 2000BFB9 E29536AF 223F032A 683B8E66 9E554E02 D1E7F631 704A66F6

  222590DC B5

        quit

dot11 syslog

ip source-route

!

!

ip dhcp excluded-address 192.168.100.1 192.168.100.10

!

ip dhcp pool van

   network 192.168.100.0 255.255.255.0

   default-router 192.168.100.1

   dns-server 8.8.8.8 8.8.4.4

!

!

ip cef

no ip domain lookup

ip name-server 8.8.8.8

ip name-server 8.8.4.4

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

username van privilege 15 password 0 van

!

!

!

archive

log config

  hidekeys

!

!

!

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

ip address 192.168.1.105 255.255.255.0

speed 100

full-duplex

!

interface Vlan1

ip address 192.168.100.1 255.255.255.0

!

router rip

version 2

network 192.168.1.0

network 192.168.100.0

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 71.246.236.11

ip route 0.0.0.0 0.0.0.0 192.168.1.1

ip route 0.0.0.0 0.0.0.0 10.1.41.79

ip route 192.168.0.0 255.255.255.0 192.168.1.1

ip route 192.168.1.0 255.255.255.0 192.168.1.1

ip route 192.168.100.0 255.255.255.0 192.168.100.2

ip http server

ip http authentication local

ip http secure-server

!

!

!

!

!

!

!

!

control-plane

!

!

line con 0

password van

logging synchronous

no modem enable

line aux 0

line vty 0 4

privilege level 15

password vantel

logging synchronous

login local

transport input telnet ssh

!

scheduler max-task-time 5000

end

New Member

Re: cisco router 871 no internet access

If you can ping from the router out then you should be able to ping from the PC out. Try to source your pings from the VLAN 1 interface IP on your router and see if that works.
Also, you don't need these static routes:
Ip route 0.0.0.0 0.0.0.0 71.246.236.11
ip route 0.0.0.0 0.0.0.0 10.1.41.79
ip route 192.168.0.0 255.255.255.0 192.168.1.1
ip route 192.168.1.0 255.255.255.0 192.168.1.1
ip route 192.168.100.0 255.255.255.0 192.168.100.2

If you don't want to turn up static routing you could possibly get the routes from RIP on the Linksys. You would need to have access to the Linksys though.

At the end of the day, you most likely will need to setup NAT on the interface going towards the Linksys and the VLAN1 interface and then overload:

Int fa 0/4
ip NAT outside

Int vlan1
ip NAT inside

Access-list 10
Permit 192.168.100.0 0.0.0.255

ip nat inside source list 10 interface fa 0/4 overload


Sent from Cisco Technical Support iPhone App

New Member

cisco router 871 no internet access

Setting up NAT worked thank you.

i didnt think i needed the first two routes but wired linksys 192.168.1.1 is connected to 192.168.0.2 which is a wireless router. im not sure how my uncle has it setup but when i tracerouted before it went from the wired linksys to the wireless router ot the 10.1.41.79 address out.

i guess my understanding of it now is that i dont need the route to the wireless router because the wired router is auto configed to do routing anyway. once i route the cisco router to the linksys router that should be the end of it on my side?

also setting up NAT did work i just wanted to make sure i understnad what those commands r doing.

ip nat outside sets outside translation at int fa4

ip nat inside sets inside translation for vlan

do i need to enable NAT after that or is it enabled by default?

in the last command what is the purpose of the overlaod. i understand that we are allowing network 192.168.100.0 to access the list we created in the previous command but what does overload do?

thnak you very much for all your help

New Member

Re: cisco router 871 no internet access

Configuring NAT inside and outside essentially "enables" NAT. The overload command tells the router to do PAT instead of 1 to 1 address translation. It allows the multiple LAN IPs on the 192.169.100.0/24 network to use the single fa 0/4 IP address.
Do a "show IP NAT translations" to see what I mean.

Regarding routing, you only have one exit point out of your network (Linksys). Your default route (0.0.0.0 0.0.0.0) is a catch-all for your traffic and pushes all traffic to the Linksys. From there, it's up to him to do routing. Specifically in static routing, a router is only concerned with getting traffic to a single next hop. Not next two hops, etc.

Sent from Cisco Technical Support iPhone App

New Member

Re: cisco router 871 no internet access

Hi,

try to add NAT to yout device. Something like this...

int fa4

ip nat outside

int vlan 1

ip nat inside

access-list 1 permit 192.168.100.0 0.0.0.255

ip nat inside source list 1 interface FastEthernet4 overload

2910
Views
5
Helpful
6
Replies
CreatePlease to create content