Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco Router on Embarq DSL with Redback

Ok, so I've got Embarq DSL, and they gave me one of those 660 modems and it works okay. What I'm trying to do, is get my Cisco 2610 with a WIC-1ADSL to take care of routing and tranceiving the connection. I've confirmed my configuration multiple times, and still nothing. I finally talked to Embarq, and they said that they showed a physical connection, but my connection wasn't "registering" properly with Redback. Is it possible to configure my Cisco router to work like this? How does Redback work?

--scott

7 REPLIES
Hall of Fame Super Gold

Re: Cisco Router on Embarq DSL with Redback

They work with PPPoE (always involved when there's redback). So you need to configure your router for PPPoE. If you think you have partially done so already, send here the relevant config you have.

New Member

Re: Cisco Router on Embarq DSL with Redback

Here is my running config:

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname CNRouter

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$xxxxxxxxxxxxxxxxxxxxxxxxxx

enable password 7 xxxxxxxxxxx

!

no aaa new-model

ip subnet-zero

ip cef

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

bridge irb

!

!

!

interface ATM0/0

description WAN Connection

no ip address

no atm ilmi-keepalive

bundle-enable

dsl operating-mode auto

bridge-group 1

pvc 8/35

encapsulation aal5snap

!

!

interface Ethernet0/0

ip address 192.168.1.99 255.255.255.0

ip nat inside

half-duplex

!

interface Serial0/1

no ip address

shutdown

!

interface BVI1

ip address 65.41.113.xxx 255.255.255.128

ip nat outside

!

ip default-gateway 65.41.113.1

ip nat inside source list 1 interface BVI1 overload

ip http server

ip classless

!

!

access-list 1 permit 192.168.1.0 0.0.0.255

!

bridge 1 protocol ieee

bridge 1 route ip

!

!

!

!

line con 0

password 7 xxxxxxxxxxx

login

line aux 0

line vty 0 4

password 7 xxxxxxxxxxx

login

!

!

end

Thanks for your help!

--scott

Hall of Fame Super Gold

Re: Cisco Router on Embarq DSL with Redback

No, that's not pppoe.

One example:

http://cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a008071a6c3.shtml

hope this helps, please rate post if it does!

New Member

Re: Cisco Router on Embarq DSL with Redback

I looked into PPPoE, and it doesn't quite look right. Embarq says I'm not a PPPoE customer, and I set the encoding on the old 660 modem to RFC 1483 and that worked. In talking more with embarq, they seem to be saying that there isn't any "authentication" happening, but that the redback server cross checks the IP address with its own records, and that the connection just isn't getting that far.

Hall of Fame Super Gold

Re: Cisco Router on Embarq DSL with Redback

Ok, then try that:

interface ATM0/0

description WAN Connection

no ip address

no atm ilmi-keepalive

bundle-enable

dsl operating-mode auto

no bridge-group 1

no pvc 8/35

int atm 0.1 point-to-point

bridge-group 1

pvc 8/35

encapsulation aal5snap

check with show atm pvc is packets are sent and received on the pvc.

New Member

Re: Cisco Router on Embarq DSL with Redback

Okay, tried that, and I get the same kinda stuff.

I try: ping 65.41.113.1 source bvi1 and I get nada. Here is my sh int and sh run:

CNRouter#sh int

ATM0/0 is up, line protocol is up

Hardware is DSLSAR (with Alcatel ADSL Module)

Description: WAN Connection

MTU 4470 bytes, sub MTU 4470, BW 448 Kbit, DLY 4570 usec,

reliability 248/255, txload 1/255, rxload 1/255

Encapsulation ATM, loopback not set

Encapsulation(s): AAL5 AAL2, PVC mode

23 maximum active VCs, 256 VCs per VP, 1 current VCCs

VC Auto Creation Disabled.

VC idle disconnect time: 300 seconds

Last input 00:14:48, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: Per VC Queueing

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

110 packets input, 9326 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 13 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

146 packets output, 6810 bytes, 0 underruns

0 output errors, 0 collisions, 2 interface resets

0 output buffer failures, 0 output buffers swapped out

ATM0/0.1 is up, line protocol is up

Hardware is DSLSAR (with Alcatel ADSL Module)

MTU 4470 bytes, BW 448 Kbit, DLY 4570 usec,

reliability 248/255, txload 1/255, rxload 1/255

Encapsulation ATM

110 packets input, 9326 bytes

146 packets output, 6810 bytes

0 OAM cells input, 0 OAM cells output

AAL5 CRC errors : 0

AAL5 SAR Timeouts : 0

AAL5 Oversized SDUs : 0

Last clearing of "show interface" counters never

BVI1 is up, line protocol is up

Hardware is BVI, address is 0000.0cf0.ea33 (bia 0004.9a8f.c920)

Internet address is 65.41.113.117/25

MTU 4470 bytes, BW 448 Kbit, DLY 5000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/0 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

9 packets output, 540 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

CNRouter#sh run

Building configuration...

Current configuration : 1088 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname CNRouter

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$xxxxxxx

!

no aaa new-model

ip subnet-zero

ip cef

!

!

!

!

!

!

!

!

!

!

!

!

!

!

username cottsay password 7 xxxxxx

!

!

bridge irb

!

!

!

interface ATM0/0

description WAN Connection

no ip address

no atm ilmi-keepalive

bundle-enable

dsl operating-mode auto

!

interface ATM0/0.1 point-to-point

bridge-group 1

pvc 8/35

encapsulation aal5snap

!

!

interface Ethernet0/0

ip address 192.168.1.99 255.255.255.0

ip nat inside

half-duplex

!

interface Serial0/1

no ip address

shutdown

no fair-queue

!

interface BVI1

ip address 65.41.113.xx 255.255.255.128

ip nat outside

!

ip nat inside source list 1 interface ATM0/0.1 overload

ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 65.41.113.1

!

!

access-list 1 permit 192.168.1.0 0.0.0.255

!

bridge 1 protocol ieee

!

!

!

!

line con 0

line aux 0

line vty 0 4

password 7 xxx

login

!

!

end

Hall of Fame Super Gold

Re: Cisco Router on Embarq DSL with Redback

This one is easy to miss and in fact is missing:

bridge 1 route ip

let us know!

591
Views
0
Helpful
7
Replies
CreatePlease to create content