Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco Router Setup 1841

Hey everyone!

I need some help, i am new to using Cisco routers (as far as setting them up my self) so forgive me if this is something simple that i am over looking/not understanding.

I have a cable internet from cox.

They gave the the ip address below....

IP: 98.191.**.147 

DG: 98.191.**.129

SNM 255.255.255.224

the ip address is the ip address that will connect the router to there modem. 

On the lan side i have the following

Ip address 10.0.4.1

DG 10.0.4.254

SNM 255.255.255.0

What i need to do is take 10.0.4 network and tell it the inter net is at  the 90.191 network address and connect to the internet that way.  

i have been watching some youtube videos on how to do this but there is something im missing and i cant figure it out.

If some one could help me shed some light on this i would greatly appreciate the help!!!!

Everyone's tags (1)
5 REPLIES
New Member

as of right now i get no

as of right now i get no internet connection on the 10 dot network. 

New Member

outer#show ip interface brief

outer#show ip interface brief

Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 10.0.4.1 YES manual up up

FastEthernet0/1 98.191.**.147 YES manual up up

Vlan1 unassigned YES unset administratively down down

Router#



!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.0.4.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 98.191.**.147 255.255.255.224
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end



!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.0.4.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 98.191.**.147 255.255.255.224
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

Hi 

Hi 

In order to give access to Internet to your lan network, you need to do natting and add the default route

Below the config 

Interface f0/0

Ip nat inside

 !

Interface f0/1

Ip nat outside 

 !

Ip access-list extended NAT

Permit ip 10.0.4.0 0.0.0.255 any

!

ip nat inside source list NAT interface f0/1 overload

 !

Ip route 0.0.0.0 0.0.0.0 98.191.**.129

how this is clear.

PS: don't forget to rate and mark as correct answer if this solved your issue 


Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question
New Member

New Update as of 6/17/16

New Update as of 6/17/16

Router#
Router#show running
Router#show running-config
Building configuration...

Current configuration : 753 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.0.4.254 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 98.191.**.138 255.255.255.224
 ip nat outside
 duplex auto
 speed auto
!
ip classless
!
ip http server
ip nat inside source list 1 interface FastEthernet0/1 overload
!
access-list 1 permit 10.0.4.0 0.0.0.255
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

Router#

i can ping 98.191.**.147 and get a 100% success but i try to ping 10.0.4.55 (the other pc) i get a 100% fail.

In other words i get single directional traffic

On your acl for nat you need

On your acl for nat you need to deny traffic from your lan network to your lan network. It had to be the first statement before the permit statement 


Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question
75
Views
0
Helpful
5
Replies