Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

cisco router setup for network connection

Hi,

This is my setup:

netopia modem connects my DSL via PPPoE (so my modem handles authentication and assigns the 5 static IPs that my ISP gave me).

I want to setup my CISCO 1812 router to handle the connection and route the traffic to the other ports which I will have computers attached to.

I basically need help setting up the FastEthernet0 (Public static IP) port to handle the connection from the netopia modem. Then have the FE0 port to give a private IP Vlan 1 (192.168.1.1-192.168.1.254)  to all the other ports FE2-9 via dhcp server. I do not know how to do this.

Thanks

7 REPLIES
Hall of Fame Super Silver

Re: cisco router setup for network connection

Hello Roshan,

first of all you need to understand how the modem assigns ip address.

If it uses DHCP and fas0/0 is your external interface

int fas0/0

ip address dhcp

ip nat outside

int fas0/1

ip address 192.168.11.1 255.255.255.0

ip nat inside

Or if you have an etherswitch module:

int fas0/1

no ip addr

shut

int vlan 1

ip address 192.168.1.1 255.255.255.0

ip nat inside

! explicit enable needed here

no shut

!

this allows you to connect devices to etherswitch ports that are associated to vlan1 by default

ip route 0.0.0.0 0.0.0.0 fas0/0 dhcp

access-list 11 permit 192.168.1.0 0.0.0.255

ip nat inside source list 11 interface fas0/0 overload

a local DHCP pool can be configured using following commands

ip dhcp excluded-address 192.168.1.1

!

ip dhcp pool DATI

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.1

   dns-server 192.168.1.1

 

   lease 0 1

note:

if the modem doesn't assign ip address you need to configure it manually on the fas0/0 interface

Hope to help

Giuseppe

New Member

Re: cisco router setup for network connection

Hi,

My modem does not assign it dhcp. Can you tell me the full configuration. If the public ip is 11.11.11.11.

Hall of Fame Super Silver

Re: cisco router setup for network connection

Hello Roshan84,

I report here only the changes from the previous post

int  fas0/0

! adjust for the correct subnet  mask

ip address 11.11.11.11 255.255.255.248

ip nat outside

the default route becomes

ip route 0.0.0.0 0.0.0.0 11.11.11.x

if you know what is the ip address of your default gateway

or

ip route 0.0.0.0 0.0.0 fas0/0

Note:

you should also configure the dns servers provided by your ISP using

ip name-server  y.y.y.y

Hope to help

Giuseppe

Hall of Fame Super Gold

Re: cisco router setup for network connection

ip route 0.0.0.0 0.0.0 fas0/0

By any means, avoid that. It cause router to ARP for every destination and cause performances to degrade unacceptably.

Hall of Fame Super Silver

Re: cisco router setup for network connection

Hello Paolo,

thanks for your correction.

rated as it deserves.

Best Regards

Giuseppe

New Member

Re: cisco router setup for network connection

I'm confused so can you post exactly what I need to do for the config

Hall of Fame Super Silver

Re: cisco router setup for network connection

Hello Roshan,

use all the info in my first post and the following updated info:

report here only the changes from the previous post

ip routing

int  fas0/0

! adjust for the correct subnet  mask

ip address 11.11.11.11 255.255.255.248

ip nat outside

the default route becomes

ip route 0.0.0.0 0.0.0.0 11.11.11.x

note1 :  you need to know what is the ip address of your default gateway

Note2:

you should also configure the dns servers provided by your ISP using

ip name-server  y.y.y.y

where y.y.y.y is the DNS server IP address

Hope to help

Giuseppe

515
Views
5
Helpful
7
Replies
CreatePlease to create content