Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco WS-C6504-e / how to increase maximum of CEF BGP-Routes

Hello to the Community,

i've got a Cisco WS-C6504-e Router, with a  which will be configured as BGP-Router.

The Problem:

If the Router has more than 524000 BGP Routes i got this message,

even after a Reset to Factory Defaults.

"00:12:49: %CFIB-SP-7-CFIB_EXCEPTION: FIB TCAM exception, Some entries will be software switched"

  Output features: HW Shortcut Installation

I tested and had the same Effects with:

Software Version 12.2(33)SRA2

Software Version 12.2(33)SRA3

Software Version 15.1(1)SY (the newest Firmware Version)

The builtin and used Supervisor Modul is a

Cisco Catalyst 6500 Series Supervisor Engine 720 / MSFC3 with 1GB Memory.

What have i to do for getting more (ca 1000000) BGP Routes via CEF handled and not software switched?

Here the Configuration:

Router#show ip cef summary

IPv4 CEF is enabled for distributed and running

VRF Default:

524549 prefixes (524549/0 fwd/non-fwd)

Default network 0.0.0.0/0

Table id 0

Database epoch:        4 (524549 entries at this epoch)

Router#show cef interface GigabitEthernet1/2

GigabitEthernet1/2 is up (if_number 5)

  Corresponding hwidb fast_if_number 5

  Corresponding hwidb firstsw->if_number 5

  Internet address is 10.0.1.2/24

  ICMP redirects are always sent

     IP unicast RPF check is disabled

  Inbound access list is not set

  Outbound access list is not set

  IP policy routing is disabled

  BGP based policy accounting on input is disabled

  BGP based policy accounting on output is disabled

  Hardware idb is GigabitEthernet1/2

  Fast switching type 22, interface type 143

  IP CEF switching enabled

  IP CEF switching turbo vector

  IP Null turbo vector

  IP prefix lookup IPv4 mtrie generic

  Input fast flags 0x0, Output fast flags 0x0

  ifindex 3(3)

  Slot 1 Slot unit 2 VC -1

  Transmit limit accumulator 0x0 (0x0)

  IP MTU 1500

Router# show configuration

Using 2547 out of 1964024 bytes

!

upgrade fpd auto

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

service counters max age 10

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip subnet-zero

!

!

!

mls ip multicast flow-stat-timer 9

no mls flow ip

no mls flow ipv6

no mls acl tcam share-global

mls cef error action freeze

!

!

!

!

!

!

!

!

redundancy

keepalive-enable

mode sso

main-cpu

  auto-sync running-config

spanning-tree mode pvst

spanning-tree extend system-id

diagnostic cns publish cisco.cns.device.diag_results

diagnostic cns subscribe cisco.cns.device.diag_commands

fabric buffer-reserve queue

!

vlan internal allocation policy ascending

vlan access-log ratelimit 2000

!

!

!

!

!

interface GigabitEthernet1/1

no ip address

shutdown

!

interface GigabitEthernet1/2

ip address 10.0.1.2 255.255.255.0

media-type rj45

!

interface GigabitEthernet3/1

no ip address

shutdown

!

interface GigabitEthernet3/2

no ip address

shutdown

!

interface GigabitEthernet3/3

no ip address

shutdown

!

interface GigabitEthernet3/4

no ip address

shutdown

!

interface GigabitEthernet3/5

no ip address

shutdown

!

interface GigabitEthernet3/6

no ip address

shutdown

!

interface GigabitEthernet3/7

no ip address

shutdown

!

interface GigabitEthernet3/8

no ip address

shutdown

!

interface GigabitEthernet3/9

no ip address

shutdown

!

interface GigabitEthernet3/10

no ip address

shutdown

!

interface GigabitEthernet3/11

no ip address

shutdown

!

interface GigabitEthernet3/12

no ip address

shutdown

!

interface GigabitEthernet3/13

no ip address

shutdown

!

interface GigabitEthernet3/14

no ip address

shutdown

!

interface GigabitEthernet3/15

no ip address

shutdown

!

interface GigabitEthernet3/16

no ip address

shutdown

!

interface GigabitEthernet3/17

no ip address

shutdown

!

interface GigabitEthernet3/18

no ip address

shutdown

!

interface GigabitEthernet3/19

no ip address

shutdown

!

interface GigabitEthernet3/20

no ip address

shutdown

!

interface GigabitEthernet3/21

no ip address

shutdown

!

interface GigabitEthernet3/22

no ip address

shutdown

!

interface GigabitEthernet3/23

no ip address

shutdown

!

interface GigabitEthernet3/24

no ip address

shutdown

!

interface Vlan1

no ip address

shutdown

!

router bgp 12345

no synchronization

bgp log-neighbor-changes

neighbor 10.0.1.1 remote-as 64496

no auto-summary

!

ip classless

!

!

no ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

dial-peer cor custom

!

!

!

!

line con 0

line vty 0 4

!

end

thanks for Help

   with regards  

          Thomas Berberich

2 REPLIES
Cisco Employee

Cisco WS-C6504-e / how to increase maximum of CEF BGP-Routes

Hi THomas,

Per my understanding, it varies depending on the Supervisor. Can you try "mls cef maximum-route ip" command and see if you can more than 512?.

You may need a router reload to have this command take effect.

-Nagendra

New Member

Cisco WS-C6504-e / how to increase maximum of CEF BGP-Routes

Thank you very much

that was the Solution for my Problem

394
Views
4
Helpful
2
Replies
CreatePlease to create content