Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Citrix Remote Access

We are using Citrix Presentaion Server 4.0. Our users connected to lan use ICA client or Internet Explorer to access apps. My remote users are telecommuters and a branch office. Both types of remote users were getting disconnected after 15 minutes. I modified Keepalive parameters in IIS for Citrix web access. This resolved issue for telecommuters getting disconnected. My lan subnet is 10.1.0.0/C and my branch office is 10.3.0.0/C. These users access Citrix server with Internet Explorer but I continue to get timed out. It seems my keepalive is not getting to my branch office subnet. I have 2 Cisco 1600 routers running IOS 12.0. Below is a config. Both routers are configured the same.

Current configuration:

version 12.0

service timestamps debug uptime

service timestamps log uptime

service tcp keepalive in

service tcp keepalive out

service password-encryption

!

ip domain name test.com

ip subnet-zero

!

!

interface Ethernet0

ip address 10.1.0.253 255.255.255.0

no ip redirects

no ip unreachables

no ip directed-broadcast

no ip proxy-arp

no cdp enable

!

interface Serial0

ip address 192.168.4.2 255.255.255.0

ip directed-broadcast

!

router rip

network 10.0.0.0

network 192.168.4.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.1.0.51

ip route 10.3.0.0 255.255.255.0 192.168.4.1

no ip http server

Thanks

Danny

2 REPLIES
Bronze

Re: Citrix Remote Access

i ve tested a cirix metafrane xp before for a remote location it worked just fine, but the keepalives you r talking about did you mean the keepalives of the line or of tcp ...

i think there s a ICA prameter to check that disconnects them out after a while of inactivity, what you can do isolate the problem just keep doing someting from the client till the timeout expires and see if you get disconnected ?

New Member

Re: Citrix Remote Access

I have resolved issue for remote users via Internet using IE. This problem is isolated to users on subnet 10.3.0.0/C connecting to 10.1.0.0/C. It seems as if keepalives are not received by users at branch office.

392
Views
0
Helpful
2
Replies
CreatePlease to create content