Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Clients not able to get dhcp address

I have a 2600 router and configured over time, three ip dhcp pools but the third dhcp pool PC's are not able to have an address assigned to them. Is there a limit of the amount of DHCP pools you can configure on a 2600 router?

3 REPLIES
Hall of Fame Super Silver

Re: Clients not able to get dhcp address

Timothy

I do not believe that there is a limit on dhcp pools. I suspect that either there is some issue with the way that the dhcp pool is configured or there is some issue with the way that the dhcp request comes from the client to the router. Can you provide some specifics? Can you post the config of all 3 dhcp pools? are these pools for subnets on interfaces on this router? If so can you post the interface configurations? If any of the pools are for clients on remote subnets can you post the configuration of the interface of the remote router?

Perhaps if we see the specifics we will be able to identify the problem.

HTH

Rick

New Member

Re: Clients not able to get dhcp address

Below is the config. The one that's not working is 10.10.173.64 (xxxx-1)

ip dhcp pool xxxx-1

network 10.10.173.64 255.255.255.224

netbios-name-server 10.10.148.197 10.10.148.198

dns-server 10.10.1.207 10.10.1.208

default-router 10.10.173.65

!

ip dhcp pool xxxx-2

network 10.10.174.128 255.255.255.224

netbios-name-server 10.10.148.197 10.10.148.198

dns-server 10.10.1.207 10.10.1.208

default-router 10.10.174.129

!

ip dhcp pool xxxx-3

network 10.10.183.192 255.255.255.224

netbios-name-server 10.10.148.197 10.10.148.198

dns-server 10.10.1.207 10.10.1.208

default-router 10.10.183.193

interface Ethernet0/0

ip address 10.10.183.193 255.255.255.224 secondary

ip address 10.10.173.65 255.255.255.224 secondary

ip address 10.10.174.129 255.255.255.224

router ospf 1

log-adjacency-changes

passive-interface Ethernet0/0

passive-interface Ethernet0/1

network 10.10.173.0 0.0.0.255 area 20

network 10.10.174.0 0.0.0.255 area 20

network 10.10.183.0 0.0.0.255 area 20

Re: Clients not able to get dhcp address

In your setup the router would allocate addresses from the 2nd pool only when all the addresses on the 1st pool are given out and it goes on like that. You mayn't have used up all the addresses in the 2nd pool for the router to tap into the pool configured to assign address from the 10.10.173.64/27 network.

See the quote from CCO below:

The Cisco IOS DHCP Server itself enables allocation of addresses from secondary address pools. Here we assume that the router is configured with secondary IP addresses. If the client is directly connected, the Cisco IOS DHCP Server attempts to allocate an address from the primary pools. If no free addresses are available in the primary pools, the server automatically allocates an address from a secondary pool. As a result, clients can boot even if all primary addresses are allocated. If all address pools are depleted, the Cisco IOS DHCP Server silently drops the request.

Ref Link: http://www.cisco.com/en/US/products/ps6640/products_white_paper09186a0080091c8b.shtml

Pls. rate the post if it helped.

HTH,

Sundar

269
Views
0
Helpful
3
Replies