Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Common route-map for PBR in multi-VRF?

Hi,

Is it possible to use a common route-map for PBR and apply it in different VRFs?

Consider this config segment:

interface GigabitEthernet0/0.100

encapsulation dot1Q 100

ip vrf forwarding one

ip address 192.168.170.115 255.255.255.254

!

interface GigabitEthernet0/0.200

encapsulation dot1Q 200

ip vrf forwarding two

ip address 192.168.170.115 255.255.255.254

!

interface GigabitEthernet0/0.300

encapsulation dot1Q 300

ip vrf forwarding three

ip address 192.168.170.115 255.255.255.254

!

interface GigabitEthernet0/1

ip vrf forwarding two

ip address 192.168.0.254 255.255.255.0

ip policy route-map pbr2fwl

!

Note that the link address assigned to each sub-interface (in different VRFs) is the same.

If I construct the pbr2fwl route-map like this, then it does not work:

route-map pbr2fwl permit 10

set ip next-hop 192.168.170.114

The documentation suggests I should do this:

route-map pbr2fwl-one permit 10

set ip vrf one next-hop 192.168.170.114

!

route-map pbr2fwl-two permit 10

set ip vrf two next-hop 192.168.170.114

!

route-map pbr2fwl-three permit 10

set ip vrf three next-hop 192.168.170.114

and apply the corresponding route-map to G0/1.

However I've discovered that this appears to work:

route-map pbr2fwl permit 10

set ip next-hop recursive 192.168.170.114

but I can find no explanation as to why. My understanding of recursive  is that it's only needed when the next hop is not directly connected:

Is this valid or have I just been lucky? This is on a 7301 running 12.2(33).

Cheers,

Simon

Everyone's tags (3)
1 REPLY
New Member

Common route-map for PBR in multi-VRF?

Hello,

route-map pbr2fwl permit 10

set ip next-hop recursive 192.168.170.114

this is not recommended config and may create issues and should be avoided.

371
Views
0
Helpful
1
Replies
CreatePlease login to create content